
VCE Pro Quick Start Manual 
 

Date: Jan-16, 2013 v.5.0.0.0 

1 

ICP DAS Website: www.icpdas.com  

 
 
 
 
 

Virtual CE Pro 
 

Quick Start Manual 

[Version 5.0] 

 

For WinPAC / XPAC / ViewPAC 

 

 

 

 

 

 



VCE Pro Quick Start Manual 
 

Date: Jan-16, 2013 v.5.0.0.0 

2 

ICP DAS Website: www.icpdas.com  

Copyright @ 2006-2013 by ICP DAS Co., Ltd.  
 
ICP DAS CO., LTD.(hereinafter referred to as ICP DAS) reserves the copyright and other 
related intellectual property rights of this manual and the software. ICP DAS also 
reserves the right to modify, enhance or improve the software mentioned in this manual 
at any time without the notice.   
 

License 
 

The user can only use, modify and backup the software mentioned in this manual for 
bundling with WinPAC/XPAC/ViewPAC. The user may not reproduce, transfer or 
distribute this software, or any copy, in whole or in part. 
 

Warranty 
 

All products manufactured by ICP DAS are under warranty regarding defective materials 
for a period of one year, beginning from the date of delivery to the original purchaser.  
 
EXCEPT AS EXPRESSLY PROVIDED IN THIS WARRENTY SECTION, ICP DAS 
MAKES NO REPRESNTATION OR WARRENTY OF ANY KIND, EXPRESS OR 
IMPLIED, WITH RESPECT TO THE PRODUCT, INCLUDING, WITHOUT LIMITATION, 
ANY WARRENTY OF MERCHANTABILITY, NONINFRINGEMENT OR FITNESS FOR 
ANY PARTICULAR PURPOSE. 
 
In no event will ICP DAS be liable, whether in contract, tort or under any other legal 
theory, for lost profits or revenues, loss of use or similar economic loss, for any indirect, 
special, incidental, consequential, punitive or similar damages arising out of or in 
connection with the product (including non-conforming), or for any third-party claims 
against user relating to the product, even if ICP DAS has been advised of the possibility 
of such claim.   
 
Unless otherwise specified or agreed, this product is not fault-tolerant and is not 
designed or intended for use or resale as on-line control equipment in hazardous 
environments requiring fail-safe performance, such as in the operation of nuclear 
facilities, aircraft navigation or communication systems, air traffic control, direct life 
support machines, or weapons systems, in which the failure of the product could lead 
directly to death, personal injury or sever physical or environmental damage. 
 

Trademark 
 

The trademarks, trade names, logos, service marks and the product names mentioned in 
this manual and the software are properties of ICP DAS or other third parties. The user is 
not permitted to use the Marks without the prior written consent of ICP DAS or such third 
party which may own the Marks.  
 
 
Writer: Wilson Chen,   Last Editor: Eva Li 
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About This Manual 

The manual is divided into four parts.  
1. ‘Introduction’ describes basic function and infrastructure of VCEP.  
2. ‘Getting Started’ describes installation and running procedures step by step. 
3. ‘Function Overview’ describes all functions of VCEP.  
4. ‘Applications’ describes different VCEP scenario in different application. 
 
 

1. Introduction 

 
VCEP, the Virtual CE Pro, is designed for managing your WinPAC/XPAC/ViewPAC 
anywhere. No matter where you are, VCEP provides a convenient environment on the 
Desktop PC and lets you control your WinPAC/XPAC/ViewPAC remotely. 

 
VCEP is composed of two main components: The ‘Server’ which runs on 
WinPAC/XPAC/ViewPAC and the ‘Client’ which runs on a Desktop PC. Once a 
connection is established between the client and server (initiated by the client), the client 
will periodically send requests for screen updates and send mouse/key click information 
to the server to simulate. Each video frame is inter-compressed against the previous 
frame and then intra-compressed with a modified LZW scheme to minimize the amount 
of data transmitted from server to client. 
 
HARDWARE REQUIREMENTS 

Device Minimum Recommended 

IBM compatible PC with 
Pentium processor 

Pentium II 
350 MHz 

Pentium III 
500 MHz 

System RAM 64 MB 128 MB 

Hard disk 100 MB free memory space 
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SOFTWARE REQUIREMENTS 
Microsoft Windows 2000 SP2, Windows XP or Windows 7 
 
FEATURES 

 Save compressed AVI files 
 Rotate the display to any angle in 90 degree increments 
 Screen captures saved to BMP, GIF or JPG 
 Copy clipboard contents to CE and back to PC 
 Rapid data entry from your more comfortable PC mouse and keyboard 
 1-18 frames per second capture speed (depending on device and communication 

conduit) 
 Support serial, Ethernet communications 
 Minimal impact on target device CPU while capturing 
 Auto-discovery of the target device on a LAN 
 Works across the internet 
 Capture screen shots to a BMP file or the clipboard 
 Supports 2 + 4-bit monochrome and 8 + 16-bit color displays 
 Scale image 1-4X 
 Multiple instances of VCEP can run on the same PC allowing multiple devices to 

be controlled simultaneously 
 One-click capture of screen shots to BMP files with auto-naming 
 Capture session to a standard AVI file for distribution 
 Capture session keys/clicks for later playback 
 Toggle toolbar display 
 Toggle 'always-on-top' window feature 
 Paste text from the PC clipboard to the CE device 
 Actively connect from Server to Client 
 Watchdog auditing 
 Record/Play script events 
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2. Getting Started 
2-1 Installation 
 
Step 1: Execute v_remote.exe in ‘\system_disk\tools\vcep’ of WinPAC/XPAC/ViewPAC. 

If you cannot find it, please go to the ‘Download Center’ of the VCEP website. 
http://www.icpdas.com.tw/product/solutions/software/utilities/vecp/vecp.html  

 
Step 2: Configure ([File] -> [Configure]) it as below then click OK. After setting password, don’t 

forget to press ‘Save an Reboot’ button in WinPAC/XPAC/ViewPAC Utility. 

 
Step 3: Execute VCEP_5.0.x.x.exe in CD:\\pc_tools\vcep_5.0.0.0 folder to install VCEP 

Client to Desktop PC. Or download from VCEP website listed in the Step 1. 

 
Step 4: After that, you will find out Virtual CE Pro Client at ‘Program File’ as below. 

 

http://www.icpdas.com.tw/product/solutions/software/utilities/vecp/vecp.html
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2-2 Running 
 
Step 1: Make sure the v_remote.exe is executed in WinPAC/XPAC/ViewPAC 
 
Step 2: Select “Virtual CE Pro Client” from [Start]->[ICPDAS]->[VCEP_5.0.0.0] or 

execute "C:\ICPDAS\VCE_Pro\v_ppc.exe" 

 
 

Step 3: Configure some basic settings at [File]->[Default Settings]. 
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Step 4: Create a new connection at [Connection]->[New]. 
 

 
 
 

Step 5: Press ‘Connect’ button. VCEP will automatically scan the available device within 
LAN. Select the Device and press ‘Connect’ button. 
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Step 6: Enter your password and press ‘OK’ button. 

 

 
 

Step 7: After that, you will see the screen of target device. 
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3. Function Overview 
 

VCEP function is divided into three parts:  
Functions on Client site, Functions on Server site, and Functions when connecting. 

 

3-1 Functions on Client (PC) 
 

All functions and settings at this section are on Client (PC) site. 
 

3-1-1 Default Settings 
 

[File]->[Default Settings] 
 

 
 

Refresh Rate: High refresh rate requires high LAN traffic. 1fps ~18fps for option 

Scale: Display scale. 1x / 2x / 3x / 4x for option 

16-color mode: Choosing this option can reduce data by 50% 

Queue events: Choosing this option can reduce LAN traffic 

Screen Capture: Choosing the method to capture screen and the format 
(BMP/BMP24/GIF/JPEG) to store 

Recording Method: Choosing the method (Script/AVI) to record and showing cursor or 
not 

Script Dir: The location to save script 
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3-1-2 New Connection 
 
[Connection]->[New] 
 

 
 

Name: Any name 

Connection Type: Choosing the type of connection (WAN / LAN / Connect From Server) 

Target IP Address: The IP address of Server should be entered if choosing the type of 
‘WAN’ 

Port: Port means IP port which is the same with server if choosing the type of ‘Connect 
From Server’ 

Refresh Rate: High refresh rate requires high LAN traffic. 1fps ~18fps for option. 

Scale: Display scale. 1x / 2x / 3x / 4x for option 

Windows Background Color: Windows’ background color 

Open Maximized: Maximize the display when connecting 

Automatically connect at startup: Connect to server automatically when startup 

Low color mode: Choosing this option can reduce data by 50% 

Queue Events: Choosing this option can reduce LAN traffic 

Screen Capture: Choosing the method to capture screen and the format (BMP/ BMP24/ 
GIF/ JPEG) to store 

Recording Method: Choosing the method (Script/AVI) to record and showing cursor or 
not 
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3-1-3 Connection Edit 

 
New: See ‘3-1-2 New Connection’ 

Delete: Delete the connection in the list 

Edit: Edit old connection. See ‘3-1-2 New Connection’ 

Connect: Start connecting to WinPAC/XPAC/ViewPAC 
 

3-1-4 New Scenario 
 
[Script]->[New] 
 

 
 

Scenario Name: Any name 

Log Results: Log the results of scenario operating 

Scenario Loop Count: The times of playing scenario  

Loop Delay: The delay time between scenario and scenario 

Add: Add a script 

Remove: remove a script 

Up: push a script up 

Down: pull a script down 

Script Loop Count: The times of playing scripts in scenario: 

Script Loop Delay: The delay time between script and script in scenario 

Disable video update: No update on Client site for reducing traffic load  
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3-1-5 Scenario Edit 

 
 

New: See ‘3-1-4 New Scenario’ 

Edit: See ‘3-1-4 New Scenario’ 

Delete: Delete the scenario in the list 

Play/Pause: Play/Pause the scenario in the list 

Stop: Stop playing the scenario in the list 
 

 

3-1-6 About 
 
[Help]->[About VCE…] Show version message. 
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3-2 Functions on Server (WinPAC/XPAC/ViewPAC) 
 

All functions and settings at this section are on WinPAC/XPAC/ViewPAC. 
 

 

3-2-1 Configure 
 

[File]->[Configure…] 
 

 
 

Connection Type: Choosing an appropriate ‘Connection Type’ (LAN / WAN) depends 
on WinPAC/XPAC/ViewPAC’s real situation 
Port Binding: IP address number of the WinPAC/XPAC/ViewPAC 
Require a password for LAN: Password for Ethernet connection from Client  
Active Watchdog: This function can let VCEP restore automatically if VCEP crash for 
un-known reason 
Connect to client: When WinPAC/XPAC/ViewPAC is in LAN and Client is in WAN with 
public IP, you can check this and assign two Client IP for active connection from 
WinPAC/XPAC/ViewPAC. If the first Client IP can not be connected to, VCEP will 
connect to second Client IP automatically. If the connection of the first Client IP restore, 
you have to disconnect the second connection manually to connect to the first one. The 
‘Retry Cycle’ means the time between two connections 
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3-2-2 Disconnect 
 
[File]->[Disconnect] Disconnect the connection from server site. 
 

 
 

 

3-2-3 About 
 
[Help]->[About…] Show version message. 
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3-3 Functions when Connecting 
 

When connecting, you can see some functions upper the window. These function 
descriptions are as below.  
 

 
 

3-3-1 Configure 
 
[File]->[Configure…] See ‘3-1-1 Default Settings’ 
 

 
 

Refresh Rate: High refresh rate requires high LAN traffic. 1fps ~18fps for option 

Scale: Display scale. 1x / 2x / 3x / 4x for option 

16-color mode: Choosing this option can reduce data by 50% 

Queue events: Choosing this option can reduce LAN traffic 

Screen Capture: Choosing the method to capture screen and the format 
(BMP/BMP24/GIF/JPEG) to store 

Recording Method: Choosing the method (Script/AVI) to record and showing cursor or 
not 

Script Dir: The location to save script 
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3-3-2 File Explorer 
 
[File]->[File Explorer] 
 

 
 

Left side of window shows the file tree on PC. Right side of window shows the file tree on 
WinPAC/XPAC/ViewPAC. You can transfer files by clicking the buttons between two 
windows.  
 

 

3-3-3 Edit 
 
[Edit] 

 
 

Paste to device: This function allows you paste text from PC to WinPAC/XPAC/ViewPAC 

Capture to Clipboard: Capture the screen and save it into clipboard. After capturing to 
clipboard, you can paste the image to any application program. 

Capture to File…: Capture the screen and save in file 

Capture (One Click): Capture the screen to be file in ‘Script Dir’ folder 
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3-3-4 Tools 
 
[Tools] 

 
 

Start Recording: Start recording according to the settings in ‘3-1-1 Default Settings’  

Stop Recording: Stop recording according to the settings in ‘3-1-1 Default Settings’ 

Soft Reset: Soft-reset WinPAC/XPAC/ViewPAC 
 
 
 

3-3-5 View 
 
[View] 

 
 

Device Info…: Show WinPAC/XPAC/ViewPAC information 

Process Info…: Show process information of WinPAC/XPAC/ViewPAC 

Refresh Display: Refresh display once when using this function 

Scale: Change the display scale (1x / 2x / 3x / 4x) 

Rotate: Rotate display (0∘ / 90∘ / 180∘ / 270∘) 
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4. Applications 
This section describes how to set VCEP in different scenario step by step. 
 

4-1 General Remote Control from Client 
 
Generally speaking, VCEP will be applied when PC and WinPAC/XPAC/ViewPAC are all 
in LAN (See Figure 1) or in WAN (See Figure 2). This section highlights some important 
settings and reminds you of functions in common use. 

 
 
 

Step 1: PC side: Refer to ‘2-2 Running’ and connect PC and WinPAC/XPAC/ViewPAC.  
The setting of ‘Connection Type’ in ‘2-2 Running’ depends on the real situation. If 
PC and WinPAC/XPAC/ViewPAC are all in WAN, you have to set IP address. 

 

 

Figure 1 Figure 2 
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Step 2: You can adjust ‘Color Mode’, ‘Queue Events’ and ‘Refresh Rate’ to reduce traffic 

load. 
 

 
 
 
 

Step3: PAC side: You can check ‘Active Watchdog’ in ‘3-2-1 Configure’. This function 
can let VCEP restore automatically if VCEP crash for un-known reason. 
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Step4: Though WinPAC/XPAC/ViewPAC supports FTP itself, you can use ‘3-3-2 File Explorer’ 
function of VCEP to transfer files between PC and WinPAC/XPAC/ViewPAC as well. 

 

 
 

Step5: Finally, don’t forget these convenient functions of ‘Screen Capture’ of ‘3-3-3 Edit’ 
and ‘Recording Script/AVI’ of ‘3-3-4 Tools’. 

 

    
 
 

NOTE: If your WinPAC/XPAC/ViewPAC is behind the firewall, please make sure to 
keep port 1899 and 1903 open. 

 
 

 

 



VCE Pro Quick Start Manual 
 

Date: Jan-16, 2013 v.5.0.0.0 

22 

ICP DAS Website: www.icpdas.com  

4-2 Active Connection from Server 
 

4-2-1 To Client With Public IP 
 
In some situation, WinPAC/XPAC/ViewPAC only has private IP in LAN, but has to 
communicate with PC in WAN (See Figure 3).  

 
 

 

Step 1: Refer to ‘3-2-1 Configure’. Enter appropriate variables in ‘Connect to client’. 
 
PAC Side: Check ‘Connect to client’ and assign two ‘Client Addr.’ for active connection 
from WinPAC/ XPAC/ViewPAC. If the first ‘Primary Client Addr.’ cannot be connected to, 
VCEP will connect to the second ‘Secondary Client Addr’ automatically. If the connection 
of the first ‘Client Addr.’ restore, you have to disconnect the second connection manually 
to connect to the first one. The ‘Retry Cycle’ means the time between two connections 

 

Figure 3 
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Step 2: PC Side: Refer to ‘3-1-2 New Connection’ and create a new connection on PC. 

Choose ‘Connect From Server’ in ‘Connection Type’. The ‘Port’ number should 
be the same with the ‘Port’ number at Step 1. 

 

  
 
Step 3: Press the ‘Connect’ button and have patient waiting the connection from 

WinPAC/XPAC/ViewPAC.  

 
 

Step 4: After successful connection, you can refer to ‘4-1 General Remote Control from 
Client’ for all activities on WinPAC/XPAC/ViewPAC. 

 
NOTE: If your WinPAC/XPAC/ViewPAC is behind the firewall, please make sure to 

keep port 1899 and 1903 open. 
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4-2-2 To Client With Private IP in Other Domain 
 
System Architecture 
 

 
 
 
PC using a network device, for example D-Link device, automatic connects to the 
Internet, through a DDNS provided domain name, e.g. dlinkddns, to link with the local IP, 
and WinPAC/XPAC/ViewPAC through the dlinkddns provided domain name to connect 
with remote PC. If the DDNS network device and PC work well, even in different domains, 
PC and the remote WinPAC/XPAC/ViewPAC can make connection anytime. 
 
 
Note: This example uses D-Link DIR-615 as the network device. The ‘dlinkddns’ is 

for use of the D-Link devices, please check if you use the D-Link network device, 
or you may use other DDNS provided by the third party.  

 
 

Figure 4 
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Step 1. Link to the D-Link DDNS website (https://www.dlinkddns.com) . If you don’t have 
any D-Link DDNS account, please click on "START" to create one. If you have 
one, please go to Step 4. 

 

 
 
Step 2.  Enter Username, Password, E-mail address, and check the box below. At last, 

click on "Create Account" button. 
 

 
 

Check this option 

https://www.dlinkddns.com/
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Step 3.  Please check the ‘dlinkddns’ mail in your e-mail box, and click the link address 
in the e-mail to confirm your D-Link DDNS account. 

 

 
 

Step 4. Go to D-Link DDNS website. Enter your User ID and Password to log in. 
 

 
1. Enter your ID and password 

2. Click ‘LOG IN’ 
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Step 5. After logged in, click "Add host" to create your domain name. 
 

 
 
 
 
Step 6.  In ‘Hostname’, enter the domain name you want. In ‘New IP Address’, enter the 

IP Address for external use (Refer to the Browser IP Address), and save it. 

 
 
 
 
Step 7. Then you will see the domain name as below picture. 
 

 
 
 
 

1. Enter your ‘domain name’ 

This IP is your external IP address 

3. Click ‘Save’ to add a domain name 

2. Enter your external IP. Refer to ‘Browser 
IP Address’. 

The domain name you create 
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Step 8. Enter “192.168.0.1” in the address line of your Browser (e.g. IE) to go the 
DR-615 website. Enter the User Name and Password of your administrator. 

 

 
 
Step 9. First, select "TOOLS", and then "DYNAMIC DNS".  
 

 
 
Step 10. Check "Enable Dynamic DNS" first. Then enter the domain name created in the 

Step 8 into "Host name", and enter the ‘dlinkddns’ username and password into 
the "Username or key" and "password or key". 

 

 
 
 

1 
2 

1. Check this item 

2. Enter domain name, 
username and password 

of dlinkddns. 
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Step 11. Click "Save Settings". 
 

 
 
 
Step 12. Waiting the IP Hub restart to enable the setting. The DDNS service is ready for 

use after the IP hub restart. 
 

 
 
 



VCE Pro Quick Start Manual 
 

Date: Jan-16, 2013 v.5.0.0.0 

30 

ICP DAS Website: www.icpdas.com  

To set the IP Hub can forward the specific port data to the VCEP in PC, please follow the 
steps below. 
 
Step 1. First select "ADVANCED", and then "PORT FORWARDING" 
 

 
 
 
Step 2. The VCEP name will not show in the pull down menu box, please key in 

"VCEP" in the column "NAME". 
 

 
 
 

1 2 

Key in "VCEP" here 

Here will not show "VCEP" 
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Step 3. Select your VCEP PC from the pull down menu box in the right hand side, then 
click "<<" button to add the IP address. 

 

 
 
 
 
 
Step 4. Enter the Port number that VCEP wants to use for "TCP" and "UDP". 
 

 
 
 
Step 5. Click "Save Settings". 
 

 
 
Step 6. Waiting the IP Hub restart to enable the setting. 
 
 
 

1. Select your VCEP PC here 

2. Click "<<" button to add IP Address 

1. Enter the Port that VCEP uses 

2. "Schedule": select "Always" 

3. "inbound": select "Allow All" 
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Connection with the WinPAC/XPAC/ViewPAC, please follow the steps below. 
 
Step 1: PAC Side: Configure appropriate variables in ‘Connect to client’ (Refer to ‘3-2-1 

Configure’). Check ‘Connect to client’. Assign the domain name and port number 
to ‘Client Addr’. 

 

  
 
Step 2: PC Side: Create a new connection on PC (Refer to ‘3-1-2 New Connection’). 

Choose ‘Connect From Server’ in ‘Connection Type’. The ‘Port’ number should 
be the same with the ‘Port’ number at Step 1. 
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Step 3: Press the ‘Connect’ button and have patient waiting the connection from 
WinPAC/XPAC/ViewPAC.  

 
Step 4: After successful connection, you can refer to ‘4-1 General Remote Control from 

Client’ for all activities on WinPAC/XPAC/ViewPAC. 
 
NOTE: If your WinPAC/XPAC/ViewPAC is behind the firewall, please make sure to 

keep port 1899 and 1903 open. 
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4-3 Debugging and Maintaining 
 
VCEP allows user recording and playing script. This function is very convenient to debug 
and maintain WinPAC/XPAC/ViewPAC. For example, user can re-play a script to 
re-generate the problem for debugging. Also, user can record a script for registration 
which can simplify the procedure of deploying application to different WinPAC/XPAC/ 
ViewPAC. 
 

[Recording] 

 
Step 1: Choose ‘Script Events’ of ‘Recording Method’ in ‘New Connection’ dialog 

 
Step 2: Connect to WinPAC/XPAC/ViewPAC. (Refer to ‘4-1 General Remote Control 

from Client’ ) 
 
Step 3: Choose [Tools]-> 

[Start Recording] to 
record all activities 
when connecting 

 
Step 4: Choose [Tools]-> 

[Stop Recording] 
to stop recording 
and save in file 
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[Playing] 

 
Step 1: Create a scenario (Refer to ‘3-1-4 New Scenario’). If you check ‘Log Results’, the 

log file will record all results when playing scenario. If you have several scripts 
should be played in one scenario, you can add all of them in the list by ‘Add’ 
function and set loop for each one. If the activities in scenario do not need to see 
on PC, remember to check ‘Disable Video Update’. 

 
Step 2: Choose one WinPAC/XPAC/ViewPAC to connect 
 
Step 3: After press ‘Play’ button, you will see a ‘Run Script’ dialog. Choose the 

WinPAC/XPAC/ViewPAC and ‘Run’. Now, you can find out WinPAC/XPAC/ 
ViewPAC act as you record before 
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