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關於這本使用手冊 

本使用手冊分為四部分 :  

1. ‘簡介’ 介紹 VCEP 的基本特色功能與軟硬體需求。 

2. ‘入門開始’ 介紹 VCEP 的安裝、啟用與執行步驟。 

3. ‘功能說明’ 介紹 VCEP 所有功能選項。 

4. ‘應用’ 介紹 VCEP 常用應用，並示範不同情境。 
 
 

1. 簡介 

 
VCEP 是 Virtual CE Pro 的簡稱，能隨時隨地控管 WinPAC/XPAC/ViewPAC 控制器。VCEP

提供 PC 端便利的平台，無論何處，皆可遠端遙控您的 WinPAC/XPAC/ViewPAC 控制器。 
 

VCEP 由兩個主要部分組成：‘Server (伺服端)’ 是在 WinPAC/XPAC/ViewPAC 上運行的

部分，‘Client (客戶端)’ 是在 PC 電腦上運行的部分。當客戶端和伺服端之間建立連接後(由

客戶端發起)，客戶端會定時發送更新螢幕畫面的要求，並將滑鼠/鍵盤的點擊資訊發送到

伺服端來模擬運作。每個影像畫面以對應前一個畫面差異的方式來壓縮，然後再以 LZW

修正壓縮法內部壓縮後，將壓縮到最小化的資料從伺服端傳送到客戶端。 
 
 

硬體需求 

設備 最小需求 建議需求 

IBM相容PC, Pentium 處理器 Pentium II, 350 MHz Pentium III, 500 MHz 

System RAM 64 MB 128 MB 

硬碟 100 MB 可用記憶體空間 
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軟體需求 
Microsoft Windows 2000 SP2, Windows XP or Windows 7 
 

特色 

 儲存壓縮 AVI 檔案 

 90 度倍數螢幕旋轉顯示 

 螢幕截取可存 BMP、GIF、JPG 格式圖檔 

 可複製 CE 內容到剪貼簿並貼回 PC 使用 

 PC 端滑鼠鍵盤資料輸入與快速操控，更便利 

 截取速度可達每秒 1-18 frames (依據使用設備與通訊狀態而有不同) 

 支援 Serial、Ethernet 通訊 

 擷取影像時，設備端 CPU 影像自動壓縮 

 自動搜尋網路中(LAN)的目標設備 

 支援 internet 跨網域工作 

 支援螢幕截取到 BMP 檔或剪貼簿 

 支援 2 + 4-bit 黑白 與 8 + 16-bit 彩色顯示器 

 影像縮放比率 1-4X 

 一台 PC 可開啟 VCEP 多重視窗同時連結控制多台設備 

 One-click 螢幕畫面截取功能支援自動命名 BMP 檔 

 擷取功能支援標準 AVI 檔案格式, 方便播放使用 

 擷取功能支援滑鼠鍵盤操作, 方便復原動作 

 支援功能表切換顯示 

 支援 'always-on-top' 視窗置頂功能 

 文字可從 PC 剪貼簿貼至 CE 設備 

 支援伺服端主動式連結客戶端(Server to Client) 

 支援看門狗(Watchdog) 功能 

 支援腳本事件錄製/播放 
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2. 入門開始 

2-1 安裝 

步驟 1: 執行 WinPAC/XPAC/ViewPAC 控制器中 \system_disk\tools\vcep 路徑下的檔案

v_remote.exe. 若找不到該檔案，請至 VCEP 網站 Download Center 下載. 
http://www.icpdas.com.tw/product/solutions/software/utilities/vecp/vecp.html  

 

步驟 2: 參照下圖設定 ([File] -> [Configure]) 再點選 OK. 設定 password 密碼後, 不要忘

了到 WinPAC/XPAC/ViewPAC Utility 選擇 ‘Save an Reboot’ 選項. 

 
步驟 3: 執行光碟 CD:\\pc_tools\vcep_5.0.0.0 路徑下的 VCEP_5.0.x.x.exe 檔案, 將

VCEP Client 安裝到 PC. 或至步驟 1 所列的 VCEP 網站下載檔案. 

 
步驟 4: 安裝後, 即可在 [開始] 程式列表中看到 Virtual CE Pro Client, 如下圖. 

 

http://www.icpdas.com.tw/product/solutions/software/utilities/vecp/vecp.html
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2-2 執行 
 

步驟 1: 在 WinPAC/XPAC/ViewPAC 控制器執行 v_remote.exe 檔案 
 

步驟 2: 在 PC 點選 [開始]->[ICPDAS]->[VCEP_5.0.0.0] “Virtual CE Pro Client” 程式 

或執行 "C:\ICPDAS\VCE_Pro\v_ppc.exe" 

 
 

步驟 3:點選 [File]->[Default Settings], 規劃初始設定. 
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步驟 4: 點選 [Connection]->[New], 建立一個新連線.  
 

 
 
 

步驟 5: 點選 ‘Connect’ 按鈕, VCEP 會自動搜尋 LAN 網路列出可連線的設備. 選擇要連

接的設備, 按下 ‘Connect’ 按鈕. 
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步驟 6: 輸入設定的密碼, 點選 ‘OK’ 按鈕. 
 

 
 

步驟 7: 連線後, 即可進入連線設備的螢幕畫面. 
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3. 功能說明 
 

VCEP 功能項目分為三部分:  

客戶端功能項目(PC), 伺服端功能項目(PAC), 以及 連線時功能項目. 
 

3-1 客戶端功能項目(PC) 
 

這一節介紹 PC 客戶端所有的功能與設定. 
 

3-1-1 初始設定 
 
[File]->[Default Settings] 
 

 
 

Refresh Rate: 高更新率則需求高 LAN 網路傳輸量. 請選擇適當選項: 1fps ~18fps 

Scale: 顯示畫面的大小比率, 1x / 2x / 3x / 4x  

16-color mode: 選擇此項可減少 50%資料量  

Queue events: 選擇此項可降低 LAN 網路傳輸量 

Screen Capture: 選擇截取螢幕畫面的方式和儲存的格式 (BMP/BMP24/GIF/JPEG)  

Recording Method: 選擇錄製方式 (Script 腳本事件集/AVI 影像) 與是否顯示游標 

Script Dir: 儲存腳本的位置 
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3-1-2 建立連線 
 
[Connection]->[New] 
 

 
 

Name: 連線名稱, 可使用任何名稱 

Connection Type: 連線的網路型態 (WAN 廣域網路/LAN 區域網路/Connect From 

Server 由伺服端連線) 

Target IP Address: 選擇 ‘WAN’ 網路型態時, 此項需輸入 PAC 伺服端 IP 位址 

Port: 選擇 ‘Connect From Server’ 網路型態時, 此項需與Server端輸入相同 IP port編號 

Refresh Rate: 高更新率需求高 LAN 網路傳輸量. 請選擇適當選項: 1fps ~18fps. 

Scale: 顯示畫面的大小比率, 1x / 2x / 3x / 4x 

Windows Background Color: 視窗背景顏色 

Open Maximized: 連線後顯示畫面至最大化 

Automatically connect at startup: 啟動後自動連接 Server 

Low color mode: 選擇此項可減少 50%資料量 

Queue Events: 選擇此項可降低 LAN 網路傳輸量 

Screen Capture: 選擇截取螢幕畫面的方式和儲存的格式 (BMP/BMP24/GIF/JPEG) 

Recording Method: 選擇錄製方式 (Script 腳本事件集/AVI 影像) 與是否顯示游標 
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3-1-3 編輯連線 

 

New: 建立連線的工具按鈕, 參照 ‘3-1-2 建立連線’ 

Delete: 刪除清單中的連線 

Edit: 編輯舊有連線設定, 參照 ‘3-1-2 建立連線’ 

Connect: 開始連接到 WinPAC/XPAC/ViewPAC 控制器 
 

3-1-4 建立情境 
[Script]->[New] 

 
 

Scenario Name: 情境名稱, 可使用任何名稱 

Log Results: 記錄情境操作的結果 

Scenario Loop Count: 播放情境的次數  

Loop Delay: 播放的情境間延遲的時間 

Add: 加入一個腳本 

Remove: 移除一個腳本 

Up: 腳本往上移動一個位置 

Down: 腳本往下移動一個位置 

Script Loop Count: 情境中, 播放腳本的次數 

Script Loop Delay: 情境中, 播放的腳本間延遲的時間 

Disable video update: 停止客戶端更新以減少網路傳輸量  
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3-1-5 編輯情境 

 
 

New: 建立連線的工具按鈕, 參照 ‘3-1-4 建立情境’ 

Edit: 編輯舊有連線設定, 參照 ‘3-1-4 建立情境’  

Delete: 刪除清單中的情境 

Play/Pause: 撥放/暫停清單中的情境 

Stop: 停止清單中撥放的情境 
 

3-1-6 關於 
 

[Help]->[About VCE…] 顯示版本資訊 
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3-2 伺服端功能項目(PAC) 
 

這一節介紹 WinPAC/XPAC/ViewPAC (PAC) 伺服端所有的功能與設定. 
 

3-2-1 規劃設定 
 
[File]->[Configure…] 
 

 
 

Connection Type: 依據 WinPAC/XPAC/ViewPAC 控制器實際狀況選擇適當的連線型態 
(LAN/WAN)  

Port Binding: WinPAC/XPAC/ViewPAC 控制器的 IP 位址 

Require a password for LAN: 客戶端連上乙太網路的密碼 

Active Watchdog: 勾選可啟動看門狗功能, 在 VCEP 當機時能自動回存 

Connect to client: 當 WinPAC/XPAC/ViewPAC 在區域網路(LAN), 而客戶端在公共 IP

的廣域網路(WAN)時, 請勾選此選項. 可從 WinPAC/XPAC/ViewPAC 啟動連線到指定 2 個

Client IP. 若第一個Client IP無法連接, VCEP會自動連接第二個Client IP. 若第一個Client 

IP 恢復連線, 則需手動停止第二個連線, 換回第一個連線. ‘Retry Cycle’ 設定切換兩個連

線的時間.  
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3-2-2 停止連線 
 

[File]->[Disconnect] 由伺服端停止連線. 
 

 
 
 

3-2-3 關於 
 

[Help]->[About…] 顯示版本資訊. 
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3-3 連線時功能項目 
 

當網路連接時, 視窗上方有一些功能選項. 本節說明這些選項的功能. 
 

 
 

3-3-1 規劃設定 
 

[File]->[Configure…] 參照 ‘3-1-1 初始設定’ 
 

 
 

Refresh Rate: 高更新率則需求高 LAN 網路傳輸量. 請選擇適當選項: 1fps ~18fps 

Scale: 顯示畫面的大小比率, 1x / 2x / 3x / 4x  

16-color mode: 選擇此項可減少 50%資料量  

Queue events: 選擇此項可降低 LAN 網路傳輸量 

Screen Capture: 選擇截取螢幕畫面的方式和儲存的格式 (BMP/BMP24/GIF/JPEG)  

Recording Method: 選擇錄製方式 (Script 腳本事件集/AVI 影像) 與是否顯示游標 

Script Dir: 儲存腳本的位置 
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3-3-2 檔案總管 
 
[File]->[File Explorer] 
 

 
 

左視窗顯示PC上的檔案樹狀結構. 右視窗顯示WinPAC/XPAC/ViewPAC的檔案樹狀結構. 

按兩個視窗中間的按鈕可以互相傳輸檔案. 
 
 

3-3-3 編輯 
 
[Edit] 

 
 

Paste to device: 複製 PC 上的文字到 WinPAC/XPAC/ViewPAC 

Capture to Clipboard: 截取螢幕畫面儲存到剪貼簿. 儲存到剪貼簿的影像可貼到任何應

用程式中. 

Capture to File…: 截取螢幕畫面儲存到檔案. 

Capture (One Click): 截取螢幕畫面儲存到檔案, 並放在 ‘Script Dir’ 資料夾中 
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3-3-4 工具 
 
[Tools] 

 
 

Start Recording: 開始錄製, 依據 ‘3-1-1 初始設定’ 的設定. 

Stop Recording: 停止錄製, 依據 ‘3-1-1 初始設定’ 的設定. 

Soft Reset: WinPAC/XPAC/ViewPAC 軟開機 
 
 
 

3-3-5 檢視 
 
[View] 

 
 

Device Info…: 顯示 WinPAC/XPAC/ViewPAC 控制器資訊 

Process Info…: 顯示 WinPAC/XPAC/ViewPAC 控制器的程序資訊 

Refresh Display: 點選使用此功能選項時，更新顯示畫面一次 

Scale: 縮放顯示畫面的倍數 (1x / 2x / 3x / 4x) 

Rotate: 旋轉顯示畫面 (0∘ / 90∘ / 180∘ / 270∘) 
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4. 應用 
本章介紹一般常見的情境應用，依照步驟介紹如何設定 VCEP 與各種應用情境. 
 

4-1 客戶端發起的一般遠程連線控制 
 

一般來說, VCEP 最常應用於 PC 與 WinPAC/XPAC/ViewPAC 控制器都在同樣的區域網路

(LAN, 如圖 1) 或廣域網路(WAN, 如圖 2) 中. 本節列出各個步驟, 並提醒一般應用時的

重要設定與功能. 

 
 
 

步驟 1: PC 端: 參考 ‘2-2 執行’ 連接 PC 與 WinPAC/XPAC/ViewPAC 控制器.  

請依照實際連線狀況選擇 ‘2-2 執行’ 中的 ‘Connection Type’. 若 PC 與

WinPAC/XPAC/ViewPAC 位於 WAN, 您必須設定 IP 位址. 

 

 
 

圖 1 圖 2 



VCE Pro 快速使用手冊 

 

日期: 2013 年 1 月 21 日 v.5.0.0.0 

20 

ICP DAS 網頁: www.icpdas.com  

步驟 2: 可調整或勾選 ‘Color Mode’, ‘Queue Events’ 與 ‘Refresh Rate’ 來減少網路傳輸

流量. 
 

 
 
 
 

步驟 3: PAC端: 可勾選 ‘3-2-1 規畫設定’ 的 ‘Active Watchdog’. 當VCEP因不明原因無

故當機時，此功能可讓 VCEP 自動重新啟動回存資料. 
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步驟 4: 儘管 WinPAC/XPAC/ViewPAC 控制器本身支援 FTP, 您也可以參考 ‘3-3-2 檔案

總管’ 使用 VCEP 功能在 PC 與 WinPAC/XPAC/ViewPAC 間傳輸檔案. 
 

 
 
 

步驟 5: 最後, 不要忘了幾個好用的功能, ‘3-3-3 編輯’ 介紹的螢幕功能 ‘Screen Capture’ 

與 ‘3-3-4 工具’ 介紹的錄製功能 ‘Recording Script/AVI’ . 
 

    
 
 

注意: 若您的 WinPAC/XPAC/ViewPAC 控制器設定防火牆保護, 請設定開啟 1899 與

1903 通訊埠. 
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4-2 伺服端發起的連線控制 

4-2-1 連線到 Public IP 的客戶端 
 

當 WinPAC/XPAC/ViewPAC 控制器只有區域網路(LAN) 的 private IP, 但卻需要與位於廣

域網路(WAN) 的 PC 連線 (如圖 3).  

 
 
 

步驟 1: 參考 ‘3-2-1 規劃設定’. 在 ‘Connect to client’ 輸入適當的資料. 
 

PAC端: 勾選 ‘Connect to client’ 並在 ‘Client Addr.’ 輸入WinPAC/ XPAC/ViewPAC要主

動連線的伺服端位址, 可輸入兩個, 當第一個 ‘Primary Client Addr.’ 無法連線, VCEP 會

自動連線到第 2 個 ‘Secondary Client Addr’. 若第 1 個 ‘Client Addr.’ 重新連上時, 您需要

手動停止第 2 個連線來連回第 1 個連線. ‘Retry Cycle’ 可設定切換兩個連線間隔的時間. 

 
 

Figure 3 



VCE Pro 快速使用手冊 

 

日期: 2013 年 1 月 21 日 v.5.0.0.0 

23 

ICP DAS 網頁: www.icpdas.com  

步驟 2: PC 端: 參考 ‘3-1-2 建立連線’ 在 PC 上建立一個新連線. 在 ‘Connection Type’ 

選擇 ‘Connect From Server’. ‘Port’ 選項需填入與步驟 1 ‘Port’ 相同的埠號. 
 

  
 

步驟 3: 選擇連線並按下 ‘Connect’ 按鈕, 稍待片刻即可連上 WinPAC/XPAC/ViewPAC.  

 
 

步驟 4: 連線成功後, 可參考 ‘4-1 客戶端發起的一般遠程連線控制’ 來操作控制

WinPAC/XPAC/ViewPAC 控制器. 
 
 

注意: 若您的 WinPAC/XPAC/ViewPAC 控制器設定防火牆保護, 請設定開啟 1899 與

1903 通訊埠. 
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4-2-2 連線到位於他網的 Private IP 客戶端 
 

系統架構 
 

 
 
 
 
PC 透過網路設備，例如: D-Link 公司的網路設備，自動連接上 Internet，透過 DDNS，例

如: D-Link DDNS，提供的 Domain name 和本地 IP 連結在一起，WinPAC/XPAC/ViewPAC 

則透過 D-Link DDNS 提供的 Domain name 和遠端 PC 連線。只要 DDNS 網路設備和 PC

正常運作，即使不同網域，PC 仍隨時可以和遠端的WinPAC/XPAC/ViewPAC 進行連線。 

 
 

注意: 此範例使用 D-Link 的 DIR-615 為例，因 dlinkddns 是專門給 D-Link 公司的網路設

備所用，請先確認你的網路設備是否為 D-Link 的網路設備，您亦可使用第三方提供

之 DDNS。 
 

圖 4 
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步驟 1. 連線到 D-Link DDNS 的網站 (https://www.dlinkddns.com)，若您沒有 D-Link 

DDNS 帳號，請按首頁的 "START" 進行帳號註冊，若已有 D-Link DDNS 的帳號

請跳至步驟 4。 
 

 
 

步驟 2.  輸入 ID、密碼和 e-mail 信箱，勾選下圖圈選的選項，按下 "Create Account" 按

鈕. 
 

 
 

勾選此項目 
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步驟 3.  請至你填寫的信箱收取 D-Link DDNS 發送的信件，信件含有啟動帳號的連結，

按下連結後你註冊的帳號將可使用。 
 

 
 

步驟 4. 請至 D-Link DDNS 網站，在首頁輸入帳號密碼登入。 
 

 
 

1. 輸入註冊所填的帳號和密碼 
2. 按下 Login 
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步驟 5. 登入成功的畫面如下所示，請按下 "Add host" 建立自訂的 domain name 
 

 
 
 
 
步驟 6.  在 Hostname 輸入你想要的 domain name 名稱，在 New IP Address 輸入你對外

的 IP 位址。 

 
 
 
 

步驟 7. 建立成功會如下圖所示 

 

 
 
 
 
 
 

1. 輸入 domain name 名稱 

此 IP 是你對外的 IP 位址 

3.按下 Save 新增 domain name 

2. 輸入你對外的 IP 位址，可參考 Browser IP 
Address 

此項目為你新建的 domain name 名稱 



VCE Pro 快速使用手冊 

 

日期: 2013 年 1 月 21 日 v.5.0.0.0 

28 

ICP DAS 網頁: www.icpdas.com  

步驟 8. 在瀏覽器上輸入 192.168.0.1 以進入 DR-615 登入頁面，再輸入你設定的管理者

密碼以進行設定。 
 

 
 

步驟 9. 先選擇 "工具"，再選擇 "動態 DNS (DDNS)".  
 

 
 

步驟 10. 先勾選 "啟用動態 DNS (DDNS)"，在 "主機名稱" 輸入在步驟 8 建立的 domain 

name 名稱，在 "使用者名稱或金鑰" 和 "密碼或金鑰" 兩個欄位輸入 D-Link 

DDNS 的帳號和密碼. 

 

 
 

1 

2 

1. 勾選此項目 

2. 輸入 domain name 名稱 

和 D-Link DDNS 帳號和密碼 
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步驟 11. 按下 "儲存設定" 
 

 
 
 
步驟 12. IP 分享器將會重新啟動。待倒數時間結束，此 IP 分享器將可使用 DDNS 服務。 
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以下步驟將會讓 IP 分享器可轉送特定 port 的資料至你電腦中的 VCEP，請按照下列步驟
進行設定。 

 

步驟 1. 先選擇 "進階設定"，再選擇 "通訊埠輸送" 
 

 
 
 
步驟 2. 因為右方的下拉選單不會有 VCEP 的名稱，所請手動在 "名稱" 欄位上輸入

"VCEP"名稱 

 

 
 

1 2 

請手動輸入名稱 此下拉選單不會有 VCEP 
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步驟 3. 在右方的下拉選單選擇你要使用 VCEP 的電腦，並按下"<<"按鈕加入 IP 位址。 

 

 
 
 
 
 

步驟 4. 在 TCP 和 UDP 的服務埠輸入 VCEP 要使用的 Port 

 

 
 
 

步驟 5. 按下 "儲存設定" 的按鈕  

 

 
 

步驟 6. 等待 IP 分享器重新啟動使設定生效 

 
 

1. 在下拉選單中選擇你要使用 VCEP 的電腦 

2. 按下 "<<" 按鈕加入 IP 位址 

1. 輸入 VCEP 要使用的通訊埠編號 

2. "排程" 選擇 "永遠" 

3. "流入封包過濾器" 選擇 "允許全部" 
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然後依照下列步驟連線到 WinPAC/XPAC/ViewPAC 控制器. 
 

步驟 1: PAC 端: 在 ‘Connect to client’ 設定適當資料(參考 ‘3-2-1 規劃設定’). 勾選 

‘Connect to client’. 在 ‘Client Addr’ 輸入 domain name 名稱與 port 編號. 
 

  
 

步驟 2: PC 端: 建立新連線 (參考 ‘3-1-2 建立連線’). 在 ‘Connection Type’ 選擇 

‘Connect From Server’. ‘Port’ 選項需填入與步驟 1 ‘Port’ 相同的埠號. 
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步驟 3: 點選 ‘Connect’ 按鈕, 等候連上 WinPAC/XPAC/ViewPAC 控制器.  
 

 

步驟 4: 連線成功後, 可參考 ‘4-1 客戶端發起的一般遠程連線控制’ 來操作控制

WinPAC/XPAC/ViewPAC 控制器. 
 
 

注意: 若您的 WinPAC/XPAC/ViewPAC 控制器設定防火牆保護, 請設定開啟 1899 與

1903 通訊埠. 
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4-3 偵錯與維護 
 

VCEP支援使用者自行錄製與播放腳本的功能. 此功能對於WinPAC/XPAC/ViewPAC控制

器的偵錯與維護有很大的幫助, 例如, 可重複撥放一段腳本來重現問題以便偵查錯誤所在. 

另外, 也可以錄製一段有關貴公司專案註冊的腳本 , 來簡化生產不同 WinPAC/XPAC/ 

ViewPAC 控制器時重複的專案註冊步驟. 
 
 

[ 錄製 ] 

 

步驟 1: 在 ‘New Connection’ 視窗的 ‘Recording Method’ 選擇 ‘Script Events’ 腳本方式 

 
步驟 2: 連線到 WinPAC/XPAC/ViewPAC. (參考 ‘4-1 客戶端發起的一般遠程連線控制’ ) 
 

步驟 3: 選擇 [Tools] -> 
[Start Recording] 

開始操作連線後所

有要錄製的動作 
 

步驟 4: 選擇 [Tools] -> 
[Stop Recording] 

停止錄製, 並儲存

檔案. 
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[ 撥放 ] 

 

步驟 1: 建立一個情境 (scenario, 參考 ‘3-1-4 建立情境’). 若您勾選 ‘Log Results’, 當播

放情境時, 記錄檔會紀錄所有結果. 若一個情境中要撥放數個腳本, 可以一一點選 

‘Add’ 加入腳本清單, 並可一一設定撥放次數. 若情境撥放的操作動作不需在 PC

上顯示, 可勾選 ‘Disable Video Update’. 

 
步驟 2: 連線到 WinPAC/XPAC/ViewPAC 控制器. 
 

步驟 3: 選擇一個情境再點選 ‘Play’ 按鈕, 出現 ‘Run Script’ 對話框. 點選所要控制的

WinPAC/XPAC/ViewPAC 並按 ‘Run’. 該 WinPAC/XPAC/ViewPAC 即會開始操作

您事先錄製的動作. 
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