EZ Data Logger

EZ Data Logger 是一个简易型的数据采集软体，可以让使用者可以很快速、简单的架设一个数据采集系统，省去撰写程式的麻烦。

下载:

CD:\napdas\Driver\EZ_Data_Logger 　或是
http://ftp.icpdas.com/pub/cd/8000cd/napdos/driver/ez_data_logger/


Features

主要功能

  • 支援 DCON, Modbus RTU, Modbus Ascii, Modbus TCP(支援IP及网域名称设定) 等通讯协定

  • 支援多个 COM Ports 与 TCP/IP 连线

  • 支援虚拟通道的定义
    使用者可以利用各通道的Tag名称来建立运算式，虚拟通道会自动算出结果。比如: VC1 = (AI_2 + AI_3) / 2

  • 支援逻辑控制 (VB Script)
    使用者可以编辑Script，利用通道的Tag名称来设定输出值或是计算虚拟通道的数值 。比如: If AI_0 > 50 Then DO_0 = 1

  • 支援警报通知(使用手机简讯或是电子邮件)
    使用者可以编辑工程师的手机号码与电子邮件，当通道数值超过警戒值或是回覆正常时，系统会寄出通知简讯(使用支援PDU模式的GSM Modem)或是电子邮件(使用网际网路) 。

  • 灵活的模组设定
    每一个I/O点都可以批次修改与命名，让使用者容易辨识，也可以个别设定趋势图的颜色。

  • 灵活的群组设定
    IO通道可以任意加入群组。
  • 即时趋势图 (可放大缩小)
    趋势图可以纪录超过一天的资料。

  • Layout嵌入背景图
    使用者可以嵌入工厂平面图，拖曳IO点到对应位置来显示。使用者也可以选择各种不同的Layout物件，例如: 指针型表头、刻度型表头、数字型LED......

  • 网路摄影机检视
    使用者可以新增网路摄影机网址，然后加到群组，在平面配置图会显示子视窗，用来检视网路摄影机画面。

  • 使用Access资料库格式
    内建资料库开启程式，并且可以将旧资料制表、绘图、与汇出成Excel或CVS档案格式。

  • 报表列印
    即时的趋势图、资料库制表、资料库绘图都可以列印出来。

  • 警示灯与警示声
    每一个类比输入通道都可以设定 上/下限的警示值，当采集到的数值超出或低于警示范围，警示灯会亮起，并且有警示声提醒，直到使用者将警示灯关闭。

  • 可以直接搜寻DCON与M7000系列的模组
    DCON系列包含7000, 87K, 8000等, Modbus系列包含M7000可以自动搜寻加入。

  • 数值转换
    设定Gain(斜率)及Offset (补偿值)后，可以直接将类比数值的单位从原先的伏特或安培转换成另一个实际的物理量，例如代表旋转速度的 rpm 或代表重量的 kg。

  • 支援权限管理
    管理者：拥有全部权限
    进阶使用者：可以执行或是停止程式，可以设定输出值。
    使用者： 可以切换页面显示。
  • 不需撰写程式
    所有操作使用滑鼠和输入数值即可完成。


Module Supported

支援的模组

  • DCON modules (I-7000, I-87K, I-8000 series)
    I-7000 Remote I/O Module
    I-8000 Main Control Unit
    8K and 87K I/O Modules
  • Modbus/TCP
    I-8000E-MTCP
    I-8000E-MTCP Support modules
    ET-6000
    ET-7000
    ISaGRAF controllers ( I-8417/8817/8437/8837, I-7188EG, I-7188XG, Wincon-8x37 )
    7188E-MTCP
    μPAC-7186EX-MTCP
    I-7188EF-016 Ethernet to FRnet Convert
    I-7243D Modbus TCP server/DeviceNet Master Gateway
  • Modbus/RTU
    M-7000 series
  • Devices with Modbus RTU, Modbus Ascii, Modbus TCP protocols


Limitation

软体性质

  • 每个群组最多可以设定32个IO通道
  • 必须使用至少一个ICPDAS的Modbus装置来启动所有的Modbus驱动(请参阅 Q2 )


Quick Start

快速上手

  • Step 5.1 系统设定
  • Step 5.2 群组设定
  • Step 5.3 开始执行(或是进行模拟)
    • Step 5.3.1 量测计
    • Step 5.3.2 趋势图
    • Step 5.3.3 对应位置
  • Step 5.4 开启资料库


Configure System

系统设定

显示方式:

  • 数列模式:使用笔数序列来记录， 最小取样时间 0.01 秒。
  • 时间模式:使用时间序列来记录， 最小取样时间 1 秒。

    X轴的座标显示方式不同

    数列模式
    时间模式

取样时间(秒):
扫描数值、更新资料库、显示数值的时间间隔。

可视范围(分):
趋势图X轴的可视范围。

趋势图记录笔数:
每一条曲线所能纪录的点数。

资料格式:
数值显示的资料格式。

程式启动时自动开始纪录:
勾选此项设定可以在程式执行时自动开始纪录。你可以在开始=>程式集=>启动 的地方建立程式捷径，当电脑电源启动进入Windows时，即可自动记录。

储存间隔(秒):
储存到资料库的时间间隔，必须是取样时间的倍数。

纪录长度(小时):
当纪录长度的时间期满，EZ Data Logger 会重新建立新的资料库开始纪录。

资料库路径:
资料库档案名称会以Datayyyymmdd_hh.mdb 来自动命名，并储存在设定的资料库路径。(yyyy:西元年 mm:月 dd:日 hh:小时)


2.Group setup

群组设定

Step 5.2.1 安装驱动程式
Step 5.2.2 安装装置
Step 5.2.3 修改通道设定予新增到群组
Step 5.2.4 工作群组属性


2.1 Install driver

安装驱动程式

驱动程式列表
你可以从这边安装 DCON / Modbus serial / Modbus TCP 驱动程式
安装驱动程式
修改驱动程式
删除指定驱动程式(如果有装置正在使用该驱动程式时，将无法删除)


安装驱动程式 DCON

驱动类型: DCON

Time Out(ms): 200 (预设值)(可修改)

COM Port: 选择连线的序列埠(不可变更)。 你无法在同一个序列埠上安装其他类型的驱动程式。

BaudRate: 115200 (预设值)(可修改)

Checksum: Disable (预设值)(可修改)

安装: 安装驱动程式，安装以后只有可修改的选项可以变更设定

修改: 变更修改的设定。

搜寻: 可以搜寻DCON的模组并自动新增。

新增装置: 使用者自订的方式新增DCON模组。 See 5.2.2 新增装置 DCON.

装置列表: 列出正在使用这个驱动程式的装置。

>Search: To search for M7000 modules and add them after stop searching.


安装驱动程式 Modbus Serial

驱动类型: Modbus Serial

Time Out(ms): 400 (预设值)(可修改)

Mode: RTU or ASCII

COM Port:选择连线的序列埠(不可变更)。 你无法在同一个序列埠上安装其他类型的驱动程式。

BaudRate: 115200 (预设值)(可修改)

Data Bits: 8 (预设值)(可修改)

Parity: 0-NoneParity (预设值)(可修改)

Stop Bit: 1 (预设值)(可修改)

Delay Between Polls: 命令延迟时间.

修改: 变更修改的设定。

搜寻: 可以搜寻M-7000的模组并自动新增。

新增装置: 使用者自订的方式新增Modbus Serial模组。 See 5.2.2 新增装置 Modbus Serial 。

装置列表: 列出正在使用这个驱动程式的装置。

lass=a12b


安装驱动程式 Modbus TCP

驱动类型: Modbus TCP

Time Out(ms): 1500 (预设值)(可修改)

Host: IP位址或是网域名称。

Port: TCP/IP连线埠。

修改: 变更修改的设定。

搜寻: 不支援。

新增装置: 使用者自订的方式新增Modbus TCP模组。 See 5.2.2 新增装置 Modbus TCP。

装置列表: 列出正在使用这个驱动程式的装置。

修改: 变更修改的设定。

搜寻: 不支援。

新增装置: 使用者自订的方式新增Modbus TCP模组。 See 5.2.2 新增装置 Modbus TCP l 。

装置列表: 列出正在使用这个驱动程式的装置。


2.2 Add Device

新增装置

装置列表
你可以从这边新增装置DCON / Modbus serial / Modbus TCP
新增装置
修改装置设定
删除指定装置


新增装置 DCON

选择 "DCON Device" 然后按下

选择使用的驱动程式 => 输入各项参数 =>按下

选项的差异:

 | 7K | 87K on 87K4/87K8 | 87K on 8431/8831 | 8K
Slot | X | X | 0~7 | 0~7

Module: 你可以从这里选一个DCON装置，参数将会自动填入。

Nickname: 你可以自订装置的名称方便辨识。

Address: 装置在485网路上的ID数值。

Slot: Slot number (for 8000 MCU).

AINum: 类比输入的通道数。

AONum: 类比输出的通道数。

DINum: 数位输入的通道数。

DONum: 数位输出的通道数。

Description: 会在装置状态区域显示成提示文字。

Nickname与Description可以稍候修改。


新增装置 Modbus Serial

选择 "Modbus/RTU" 然后按下

选择使用的驱动程式 => 输入各项参数 =>按下

Slave ID: The modbus ID number.

Module: 你可以选择一个 ICPDAS M-7000 系列的模组。

Nickname: 你可以自订装置的名称方便辨识。

Description: 会在装置状态区域显示成提示文字。

0xxxx Coils (DO): 从起始位址到结束未址。

1xxxx Discrete Input (DI): 从起始位址到结束未址。

3xxxx Input Registers (AI): 从起始位址到结束未址。

4xxxx Holding Registers (AO): 从起始位址到结束未址。

Address format: Dec 为十进位、Hex 为十六进位。

Base Address: 0 or 1.

Nickname与Description可以稍候修改。


新增装置 Modbus TCP

选择 "Modbus/TCP" 然后按下

选择使用的驱动程式 => 输入各项参数 =>按下

Nickname: 你可以自订装置的名称方便辨识。

Description: 会在装置状态区域显示成提示文字。

Slave ID: The modbus ID number.

0xxxx Coils (DO): 从起始位址到结束未址。

1xxxx Discrete Input (DI): 从起始位址到结束未址。

3xxxx Input Registers (AI): 从起始位址到结束未址。

4xxxx Holding Registers (AO): 从起始位址到结束未址。

Address format: Dec 为十进位、Hex 为十六进位。

Base Address: 0 或 1。

Nickname与Description可以稍候修改。


通道修改与新增到群组

所有通道可以任意加到指定的群组。

按下 [image] 将选择的通道加到群组。.

按下 [image] 可以修改通道的nickname, gain, offset, high/low alarm, or description 等设定。

修改完设定值后，请按下"Modify"储存。

Nickname: 你可以指定nickname以方便辨识。

Tag: Tag name 可以用在Virtual Channel或是Control logic. (请注意 : Tag name 必须使用开头为a~z的英文字母,第一个字母不可以使用数字)

Description: 可以在显示的物件上显示提示文字。

Gain and Offset: 设定 Gain 和 Offset 可以转换成你需要的单位。

Caculate: 按下 [image] 可以利用point1和point2计算出 gain 和 offset。请参阅 Q&A.

High/Low Alarm: 每一个类比输入通道都可以设定其高或是低的警戒值，一但数值高于高警戒值或是低于低警戒值时，警示灯会亮起并会播放警示声。警示状态会持续到使用者将警示灯关闭(位于量测计里面)。

Init Value: Virtual channel的初始值 。

Operation: Virtual channel 的运算式。

Display Mode: 你可以选择各通道的显示物件(Text Box / Angular Gauge / Linear Gauge / Perecent / Number LED / Toggle)。

Style List: 你可以选择各类物件的不同样式。


Workgroup Property

工作群组属性

你可以从这里新增或是删除工作群组，每一个工作群组可以加入32个通道。

: 增加一个工作群组

: 删除指定的工作群组

: 设定工作群组名称与自动开启的画面

: 清除所有的通道

: 回到主画面

工作群组属性设定:

工作群组名称: 你可以设定一个方便辨识的工作群组名称。

随启动开启画面: 勾选时，可以随程式启动时自动开启画面。


Workgroup Property

专案档操作

使用中的专案包括一个设定档,一个Script档案与图片目录， 你可以作下列这些专案的操作。

新增专案: 开启一个新的专案。

开启专案: 开启其他专案档。

另存专案: 将目前的专案另存。


Workgroup Property

保全功能

如果您不希望其他使用者变更程式设定，您可以设定密码来取消系统设定与群组设定的按钮功能。

Set Password:

Password protection: Click logout to disable these buttons. Every time to excute EZ Data Logger will disable these buttons also.

Login: Click login to enable these two buttons. Set password empty to disable password protection.


Screen

开始执行

开始执行。开始显示数值与纪录。

停止执行。

模拟数值并开始纪录。

停止模拟。

暂停动态显示所有趋势图。

继续动态显示趋势图。

暂停记录到资料库。

记录到资料库。


Gauge

量测计划面

点选主画面的"量测计"来显示量测计划面。

范围 (AI最大值 / AI最小值): 变更Gauge的显示范围。

<<: 切换到前一个工作群组。

>>: 切换到下一个工作群组。

趋势图: 切换到趋势图显示。

平面配置图: 切换到平面配置图显示。

隐藏: 隐藏画面并显示主画面。

AO

切换通道按钮: 假如群组有超过8个类比输入通道的话，可以点选按钮切换显示的通道。

警示灯: 当数值超过警戒值时，警示灯会亮起，并保持亮灯的状态。

关闭警示灯: 点一下以关闭警示灯。如果有警示灯亮起， EZ Data Logger 会播放警示音效。


Trend

趋势图显示

点选主画面的"趋势图"来开启趋势图显示。

显示(暂停/继续): 暂停/继续 趋势图。

列印: 列印趋势图。

显示范围: 设定Y最大最小值,X轴范围(分).

背景颜色: 设定趋势图背景颜色。

全选: 显示所有趋势图线条。

全不选:隐藏所有趋势图线条。

<<: 切换到前一个工作群组。

>>: 切换到下一个工作群组。

量测计: 切换到量测计显示。

平面配置图: 切换到平面配置图显示。

隐藏:隐藏画面并显示主画面。

滑动按钮: 可以放大缩小显示范围。

Value: 点选Value的格子可以开启设定AO/DO 的设定视窗, 也可以将Counter 归零。

Track: 点选Track的格子来切换显示到不同的Track

Color: Click the color grid to change the trend line color( You can not change the color when start logging ).

Check box: =>show the trend line, [image] =>hide the trend line.

Cursor Mode: Set display pause to change trend to cursor mode. Then you can click the trend to show the before values .


Trend

平面配置图

点选主画面的"平面配置图"来开启平面配置图显示。

图片(背景图): 设定配景图片，支援图片格式 *.jpg, *.bmp。

图片(取消背景图): 清除背景图。

重设位置: 重设所有物件位置。

字体颜色: 设定标签颜色。

<<: 切换到前一个工作群组。

>>: 切换到下一个工作群组。

量测计: 切换到量测计显示。

平面配置图: 切换到平面配置图显示。

隐藏:隐藏画面并显示主画面。

滑鼠右键功能表:

手动控制 : 启用滑鼠控制 ( 滑鼠控制输出值 )。

自动输出 : 取消滑鼠控制 ( control logic 会自动设定输出值 )。

属性 : 显示通道属性。

设定小数位数 : 设定显示的小数位数。

设定单位 : 设定显示单位。

显示数值设定范例: (数值 = 123.456)

小数位数 | 单位 | 显示
0 | ℃ | 123 ℃
1 | ℉ | 123.5 ℉
2 | kg | 123.46 kg
3 | V | 123.456 V


Trend

开启资料库

开启资料库可以将较早的资料叫出绘出趋势图，并且可以汇出成 Excel 或是 CSV 的档案。

列印: 列印趋势图或是资料表格(最多12个通道)。

全选: 显示趋势图所有的线条。

全不选: 隐藏所有趋势图线条。

Y轴范围(最大值/最小值): 设定Y轴最大值最小值

X轴范围: X轴的可视范围(分)。

背景颜色: 设定趋势图背景颜色。

开启资料库绘图三步骤

步骤一. 选择资料库: 在资料库列表上点一下或是点 [image] 开启其他路径的资料库档案。

步骤二. 选择一个工作群组: 点一下工作群组列表上的工作群组。

步骤三. 卷动指标来选择时间范围. 然后你可以载入趋势图或是载入表格.

列印趋势图

汇出资料表到 Excel 或是 CSV

趋势图: 点选趋势图可以在右边的表格上显示该时间点的数值.

资料表: 勾选方块来显示或是隐藏该通道资料.


Virtual Channel

你可以使用通道的Tag名称来作运算，将运算结果存到Virtual Channel。

设定 virtual channel 数量: (最多256个通道)

设定virtual channel 运算式:

1. Virtual Channels 是可运算的. 你可以使用Tag name 来作运算

例如:
VC0 = (AI_1 + AI_2) / 2
VC1 = AI_3 ^ 2 * 100
VC2 = DO_0 And DO_1
VC3 = Abs(AI_6)

2.可以用的运算子

乘 *
除 /
加 +
减 -
次方 ^
逻辑运算子 Not, And, Or, Xor....

3.可以使用的基本函数

你可以在算式中使用这些VB函数
Sin(number) | 传回引数的 sine(正弦函数)值
Cos(number) | 传回引数值的 cosine(余弦函数) 值。
Tan(number) | 传回引数的“正切”(tangent)函数值。
Atn(number) | 传回引数的“反正切”(arctangent)函数值。
Abs(number) | 传回引数的绝对值。
Sqr(number) | 传回引数的平方根。

4.Initial Value
  VC的起始值


控制逻辑

控制逻辑使用VB Script。你可以编辑 Script 内容来设定输出数值或是将计算资料放到Virtual Channel，使用时你可以使用各通道的 Tag 名称来取得或是设定数值。

你可以在Control Logic里面编辑逻辑控制, 如果你启用逻辑控制, EZ Data Logger会自动对逻辑控制的AO/DO数值作输出的动作,此时Layout的AO/DO的控制将无法操作,如需切换到手动, 可以选择控制模式, 请参阅: 平面配置图显示滑鼠右键功能表

陈述式 :

可以使用的If...Then...., For...Next....的陈述式如下

If condition1 Then
  [statementblock-1]
ElseIf condition2 Then
  [statementblock-2]] ...
Else
  [statementblock-n]]
End If

变数 :

你可以在Script里面使用这些参数

iYear : | 年
iMonth : | 月
iDay : | 日
iHour : | 时
iMinute : | 分
iWeekDay : | 每星期的第几天 (星期日 = 1, 星期一 = 2, 星期二= 3.....星期六 = 7)
Now : | 回覆系统时间。
Timer : | 回覆从午夜12:00到此刻经过的秒数。
Msg : | 如果Msg不为空的话， 会将内容输出到主画面的警告视窗。

常数 :

你可以在Script里面使用这些常数

常数 | 代表意义
Sunday | 星期日
Monday | 星期一
Tuesday | 星期二
Wednesday | 星期三
Thursday | 星期四
Friday | 星期五
Saturday | 星期六

函数 :

你可以在 Script 里面使用这些函数

Sin(number) | 传回引数的 sine(正弦函数)值
Cos(number) | 传回引数值的 cosine(余弦函数) 值。
Tan(number) | 传回引数的“正切”(tangent)函数值。
Atn(number) | 传回引数的“反正切”(arctangent)函数值。
Abs(number) | 传回引数的绝对值。
Sqr(number) | 传回引数的平方根。

范例 :

'开启DO警报
If AI_5 > 100 Then
  DO_3 = 1
  Msg="High Alarm"
End If

'纪录最大值
If AI_2 > VC0 Then
  VC0 = AI_2
  Msg = "AI_2 Max Value is " & VC0
End IF

'计算平均值并设定到AO_2
AO_2 = ( AI_1 + AI_2 + AI_3 ) / 3

'使用公用变数判断星期六星期日关闭冷气
If iWeekDay = Saturday Or iWeekDay = Sunday Then
  AirConditioning = 0
Else
   AirConditioning = 1
End If

'使用逻辑运算
DO_3 = DI_2 And DI_3

'


IP Camera Viewer

IP Camera viewer use the web browser to show. You can add an IP camera web address, then resize the viewer and scroll the windows to fit the camera pucture. After all, add the IP camera to group. Then Layout display will show the IP camera page in a sub windows.

In layout display:

: Save the IP camera's window as a jpg picture in "capture\group name\camera name" folder.

: Refresh the web page.


Alarm Notifier

Alarm Notifier(by sending SMS or E-Mail)

User can set the engineer's cell phone number and email address. When the channel value over the alarm value or back to normal, the contact messanger will send a message by SMS (using GSM Modem) or by E-Mail(using ethernet).

Mail notify configuration

SMS notify configuration

Edit the contact list

Set the alarm to notify

Mail & SMS Sender

Mail notify configuration:

1. Edit the MailNotifier driver: set SMTP server, sender's e-mail, name, and the mail's head text.

SMS notify configuration :

1. Connect a GSM modem to your COM port. (your GSM modem have to support PDU mode)

2. Install a GSM modem driver.

3. Add a GSM device, then edit the SMS head text.

Edit the contact list.

Set the alarm to notify:

1.Select the AI channels, and click "Modify".

2.Select the alarm contact to.

Mail & SMS Sender:

Mail & SMS Sender can send the the e-mail and SMS. It will be minimized to the system icon tray.

Mouse right click to show the main form.

You can enable/disable the mail/SMS sending.


权限管理

你可以从主画面功能表=>使用者=>设定密码来设定管理者与进阶使用者密码：

 | 管理者 | 进阶使用者 | 使用者
编辑专案 | ● | ○ | ○
权限管理 | ● | ○ | ○
开始/停止专案执行 | ● | ● | ○
设定 AO/DO 数值 | ● | ● | ○
切换页面显示 | ● | ● | ●

●：允许 ○：不允许

管理者：所有权限。

进阶使用者：可以执行结束程式，可以设定AO/DO值。

使用者：可以切换画面显示。(无密码)

若密码为空，则以空密码的最高权限登入。

管理者登入：验证密码后以管理者身份登入。

进阶使用者登入：验证密码后以进阶使用者登入。


问题与解答

问题一:如何将类比讯号转换成其他单位，列如 kg?

设定Gain(斜率)及Offset(补偿值)可以将电压值( V )转换成您需要的单位量( kg )。要获得这两个数值请依照它们的对应关系先找出两组数据，然后依照以下步骤来求得Gain与Offset

在通道修改的设定画面可以自动计算 : 输入两点的撷取数值(AI Value)和显示数值(Display Value)即可自动计算出Gain, Offset。

问题二 : 如何启动Modbus驱动程式?
当您安装Modbus驱动程式时,你必须至少连接一个ICPDAS的Modbus装置来启用所有的Modbus驱动程式。然后这些Modbus驱动程式即可存取其他Modbus的装置, 例如PLC.....
下列ICPDAS模组可以用来连线启动Modbus驱动程式。

M7000 serial modules, I-7188EX-MTCP, I-8000-MTCP, ET-6000, ISaGRAF controllers ( I-8417/8817/8437/8837, I-7188EG, I-7188XG, Wincon-8x37 )