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Introduction 

The YOF3 driver enables communication between Studio and Yokogawa devices using the Yokogawa 
Host proprietary protocol. This document explains how to enable that communication. 

The information in this document is organized as follows: 

 Introduction: Provides an overview of the driver documentation. 

 General Information: Identifies all the required components (hardware and software) you need to 
implement communication between Studio and the Yokogawa devices. This section also describes 
general characteristics of the communication. 

 Installing the Driver: Explains the procedure for installing the software and hardware required to 
configure the communication. 

 Configuring the Driver: Explains how to configure the communication driver, including different 
permutations and default values for the configuration. 

 Executing the Driver: Explains how to test the driver to verify that you installed and configured it 
correctly.   

 Troubleshooting: Lists the most common error codes for this protocol and provides the procedures to  
fix the errors.   

 Revision History: Provides a log of all the modifications made to the driver and driver documentation. 

Note: This document assumes that you have read the “Driver Configuration” chapter in the Studio 
Technical Reference Manual. 
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General Information 

This section identifies all the hardware and software components and characteristics used to implement 

communication between Studio and a Yokogawa device.  

The information is organized into the following sections: 

 Device Characteristics 

 Link Characteristics 

 Driver Characteristics 

Device Characteristics 

This driver has been tested with the following devices: 

 Manufacturer: Yokogawa 
 Compatible Equipment: 

– F3LC11, F3LC12, F3LE01, F3GB01 
– F3SP (05,21,25,28,35,38,53,58) 

 Yokogawa PLC programmer software: WideField. 

Note: See “Conformance Testing” for information about the equipment used for the standard 
conformance tests of this driver. 

Link Characteristics 

To establish communication, you must use links with the following specifications: 

 Physical protocol: Serial RS232 and Ethernet 
 Specific PC Board: None 

Driver Characteristics 

The YOF3 driver is composed of the following files: 

 YOF3.INI: Internal driver file (Do not modify this file.) 
 YOF3.MSG: Internal driver file containing error messages for each error code. (Do not modify this file.) 
 YOF3.PDF: Document providing detailed information about the driver. 
 YOF3.DLL: Compiled library for the driver. 

You can use the YOF3 driver on the following operating systems:   

 Windows NT 
 Windows XP 
 Windows 7 
 

 Notes:  

• All of the preceding files are installed in the /DRV subdirectory of the Studio installation directory.  

• You must use Adobe Acrobat® Reader™ (provided on the Studio installation CD-ROM) to view  
the YOF3.PDF document. 

 

 

Conformance Testing  

The following configuration parameters and equipment were used for the conformance testing: 
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 Serial Configuration: 

– PLC Program: WideField 
– 1-Serial Configuration: 
– Baud Rate: 9600 
– Data Bits: 8 
– Stop Bits: 1 
– Parity: Even 
– COM port: COM2 

 Ethernet Configuration: 

– PLC Program: WideField 
– Port: 3001 

 Operating System (Development): Windows XP  

 Studio version: 7.0 

 YOF3 Driver version: 1.01 
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Installing the Driver 

When you install Studio, all of the communication drivers are installed automatically.  

You must select the driver that is appropriate for the application you are using. 

Use the following steps to select the driver from within the application: 

1. .Select Insert → Driver from the main menu bar to open the Communication drivers dialog (as 
shown in the following figure). 

 

 
 
 

2. Select the YOF3 driver in the Available Drivers list, and then click the Select button.  

3. When the YOF3 driver displays in the Selected Drivers list, click the OK button to close the 

dialog.  

It is not necessary to install any other software on your PC to enable communication between the host 

and the device. However, to download a custom program to the device, you must install one of the 

Yokogawa software programs (such as WideField). Consult your Yokogawa documentation for the 

installation procedure. 

 

Note: You must take special precautions when installing the physical hardware.   
Refer to the hardware manufacturer’s documentation for specific instructions. 
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Configuring the Driver 

After installing and selecting the driver in Studio, you can configure the driver.  
You configure a driver in two stages: 

 Set the communication parameters (only one configuration for the entire driver) 
 Configure communication tables or Driver Worksheets (define communication tags and configure  

communication control) 

Setting Communication Parameters 

When you specify the communication parameters, they are valid for all Driver Worksheets configured in 

the system. Use the following steps to configure the communication parameters for the driver: 

1. From the Studio development environment, click the Comm tab located below the Workspace pane. 

2. From the Workspace pane, expand the Drivers folder. 

3. Right-click on the YOF3 subfolder and when the pop-up menu displays, (as shown in the following 

figure) select the Settings option.  

 
 

The YOF3: Communication Parameters dialog displays as follows: 
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4. Configure the following parameters on the YOF3: Communications Parameters dialog: 

 

Parameters Default Values Valid Values Description 

COM COM2 COM1 to COM8 
PC serial port used to communicate with  
the device 

Baud Rate 9600 110 to 57600bps Communication data rate 

Data Bits 8 5 to 8 Number of data bits used in the protocol 

Stop Bits 1 1or 2 Number of stop bits used in the protocol 

Parity None 
even, odd, none, 
space or mark 

Protocol parity  

Station 0 0 to 31 Computer ID number 

Checksum 0 0 or 1 
 0: Use Checksum 
 1: Do not use Checksum  

Communication - S or T 

 S: Use serial communication between 
Studio  
and the device 

 T: Use Ethernet  communication between 
Studio and the device  

Protocol - A or B 
 A: Bytes in ASCII format 
 B: Bytes in Binary format  

 

Note: These communication parameters must be the same as those configured for the Yokogawa 

device. 
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5. Click the Advanced button in the YOF3: Communication Parameters dialog, to open the  

Advanced settings dialog.   

 

 
 

 

6. Select a value for the Control RTS field using the information in the following table: 

 

Parameter Default Value Valid Values Description 

Control RTS no  no 
 yes 
 yes + echo 

Define if the RTS (Request to Send) 
handshake signal is set before 
communication and if there is an echo in 
the communication.  

 

 

 Important:  

• Using the wrong settings for this field will prevent the driver from working and cause Timeout 

error messages. 

• Although you can configure other serial communication parameters from this dialog, do not 

change any of the default parameters at this time except Control RTS.  

• For additional information about parameters on the Advanced settings dialog, refer to the 

Studio Technical Reference Manual. 

7. Click the OK button to close the dialog box. 
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Configuring a Driver Worksheet 

You can configure multiple driver worksheets. Each worksheet contains a Header and Body section. 

Use the following steps to create a new Standard Driver Worksheet: 

1. From the Studio development environment, select the Comm tab, located below the Workspace 

pane. 

2. In the Workspace pane, expand the Drivers folder and right-click the YOF3 subfolder. 

3. When the pop-up menu displays (as shown in the following figure), select the Insert option. 

 

 
 

 

Note: To optimize communication and ensure better system performance, you must associate the 
tags in different driver sheets to the events used to trigger the communication between each tag 
group and the periodicity for which each tag group must be written or read. Also, we recommend 
configuring communication addresses into sequential blocks.  
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The <drivername>.drv dialog box displays (similar to the following figure). 

 

 
 

 

The fields on a Standard Driver Worksheet are standard for all communications drivers — except the 

Station, Header, and Address fields, which are driver-specific. Consequently, this document just explains 

how to configure the Station, Header, and Address fields.  

For information about the configuring the standard fields review the Studio Technical Reference Manual. 

Configuring the Station and Header Fields 

The Station field specifies the IP address of the target device, and the Header field specifies the type(s) of 
commands will be sent to the device. 

 

Parameter Default Value Valid Values Description 

Station -  

 For serial communication, specify the PLC 
Address (PLC ID).  For example: 2. 

 For TCP/IP communication, specify: 

<PLC IP>:<Communication 

Port>:<Station> 

For example: 192.168.1.200:3001:1 

Header - 
(See next 
table) 

Specify the types of variables to be read to or written 
from the device and which commands will be used by 
the driver, using the following syntax: 

<Data Type>:<Command> 

After you edit the Header field, the system will verify 
the Header’s validity.  

 

Note: You can type a Tag between curly brackets { } into this field, but you must be certain that the 

Tag value is correct and uses the correct syntax, or an Invalid Header error will result. 
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Data Type Syntax Example 
Valid Address Ranges  

per Worksheet 

Input Relays X 256 

Output Relays Y 256 

Internal Relays I 256 

Special Relays M 256 

Timer   Relays T 256 

Data Registers D 64 

File Registers B 64 

Special Registers Z 64 

Shared Registers R 64 

Long Data Registers L 32 

  

Command Syntax Example Valid Address Range 

Bit Read BRD 256 

Bit Write BWR 256 

Word Read WRD 256 

Word Write WWR 256 

 

 Note: The Long Data Registers value reads and writes two-word data in Data Registers. 
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Configuring the Address Field 

You can use the body of a Standard Driver Worksheet to associate each tag to its respective device 
address. Type a tag from your application database into the Tag Name column to receive values from or 
send values to an address on the device.  

The value you enter into the Address field in the Worksheet should be the number you want to reach in  
the device. 

Header Address Device Address 

 I:BRD 1 I00001 

D:WWR 1500 D01500 

B:WRD 350 B00350 

Y:BWR 220 Y00220 

 

Notes:  

 Remember, you cannot specify a data bit range larger than 256 within the same Worksheet. For word 
data cases the maximum data bit range is 64, and for long data the maximum is 32. 

 There are several ways to specify the same variable on the device because the variable value is 
defined by the sum of the initial address reference defined in the Header field, and the offset defined in 
the Address field. 
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Executing the Driver  

After you add the YOF3 driver to a project, Studio sets the project to execute the driver automatically 

when you start the run-time environment.  

To verify that the driver run-time task is enabled and will start correctly, perform the following steps: 

1. Select Project  Status from the main menu bar. 

The Project Status dialog box displays.  

 
 

2. Verify that the Driver Runtime Startup task is set to Automatic. 

 If the setting is correct, click OK to close the dialog box.  

 If the Driver runtime task is not set to Automatic, select the Driver Runtime line and when the Startup 

button becomes active, click the button (a toggle) to set the Startup mode to Automatic.  

3. Start the application to run the driver. 
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Troubleshooting 

If the YOF3 driver fails to communicate with the device, the tag you configured for the Read Status or Write 

Status fields will receive an error code. You can use this error code to identify the type of failure that 

occurred.  

The following table describes the error codes for this driver: 

Error 
Code 

Description Possible Causes Solving the Problem 

0 OK  
Communicating without 
problems 

 

1 Invalid Address 
Typed an invalid address in the 
Driver Configuration Worksheet 

Specify a valid address 

2 Invalid Header 
Typed an invalid header in the 
Driver Configuration Worksheet 

Specify a valid header, with data type and 
command. <Data Type>:<Command> 

3 Invalid Command 
Typed a nonexistent command 
in Header field 

Select BRD, BWR, WRD, or WWR 

6 Setpoint Error 
Specified start point exceeds 
the address range 

Specify a start address within the device’s 
limits 

7 Data out of Range 
Specified bit (or word) count 
exceeds the specification range 

Specify a start address within the device’s 
limits  

9 
Communication 
Error 

 Disconnected cables 

 PLC stopped, turned off, or 
is in error state 

 Wrong RTS/CTS 
configuration settings 

 Verify that all cables are connected. 
 Verify that the device is not in fail state. 
 Verify that there is no interference. 

10 
Timeout Receiving 
Char 

 Disconnected cables 

 PLC stopped, turned off, or 
is in error state 

 Wrong RTS/CTS 
configuration settings 

 Verify that the device is turned on. 
 Verify that there is no interference. 
 Check the cable wiring 
 Verify the Station number 

11 Timeout 

 Disconnected cables 

 PLC stopped, turned off, or 
is in error state 

 Wrong RTS/CTS 
configuration settings 

 Verify that the device is turned on. 
 Verify that there is no interference. 
 Check the cable wiring 
 Verify the Station number 

12 
Invalid 
Communication 

Typed wrong value in 
Communication Settings 

Specify S for Serial or T for TCP/IP 

15 Invalid Command Typed wrong value in Specify A for ASCII or B for Binary 
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Type Communication Settings 

16 Connect Error 

 Disconnected cables 

 PLC stopped 

 Wrong RTS/CTS 
configuration settings 

 Check the cable wiring 
 Check the entire driver and PLC 

configuration. 
 Check for an invalid IP or station 

17 Invalid Station 
Typed wrong station in the 
Driver Communication 
worksheet 

 Specify a valid station 

 For serial cases: Type the PLC Station 
number only. 

 For TCP/IP cases: Type the 
<PLC IP>:<Port>:<Station> 

18 Can’t Write 
Impossible to WRITE with 
specified command 

Use this command for READ only 

 
 

Note: You can verify communication results from the Output window of the Studio development 
environment.  To configure an event log of Field Read commands, Field Write commands, and serial 
communications right-click on the Output window, select the Setting option from the pop-up menu, and 
select these log events. When testing for a Windows CE target, you can enable an event log from the 

CE unit (Tools → Logwin) and verify the celog.txt file created at the target unit. 

 

 

If you are unable to establish communication with the PLC, try to establish communication between the 
PLC Programming Tool and the PLC first. Frequently, communication problems are due to a hardware or 
cable problem, or because you have an error or lack of configuration at the PLC. When the 
communication between the PLC Programming Software and the PLC is working, you can test the 
supervisory again.  
 
When you are ready to test communication with Studio, you should first use the application sample 
provided, instead of using the new application you are creating. 
 
If you must contact technical support, please have the following information available: 
 
 Operating system (type and version): Select Tools → System Information from the main menu bar. 
 Project information: Select Project → Status from the main menu bar.  
 Driver version and communication log: Displays in the Studio Output window when you run the driver. 
 Device model and boards: Refer to hardware manufacturer’s documentation. 
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 Revision History 

  

Version By Date Description of Changes 

1.00 Rafael Tavares 02-October-2002 Initial version 

1.00 Andre Bastos 31-March-2010 
Changes in the documentation only. No 
modifications in the driver 

1.01 Paulo Balbino 30-June-2011 Implemented Header validation 

1.2 Eduardo Castro 28-November-2016 Adjustment in INI configuration file 

 


