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WA982 Communication Driver  

Driver for Serial Communication 
with Watlow Controls Devices Series 981-984 
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Introduction 

The WA982 driver enables communication between the Studio system and some Watlow Controls devices (981-
984 Series), according to the specifications discussed in this document.  

This document will help you to select, configure and execute the WA982 driver, and it is organized as follows: 

 Introduction: This section, which provides an overview of the document. 

 General Information: Identifies all of the hardware and software components required to implement 
communication between the Studio system and the target device.  

 Selecting the Driver: Explains how to select the WA982 driver in the Studio system. 

 Configuring the Device: Describes how the target device must be configured to receive communication from 
the WA982 driver. 

 Configuring the Driver: Explains how to configure the WA982 driver in the Studio system, including how to 
associate database tags with device commands. 

 Executing the Driver: Explains how to execute the WA982 driver during application runtime. 

 Troubleshooting: Lists the most common errors for this driver, their probable causes, and basic procedures 
to resolve them. 

 Revision History: Provides a log of all changes made to the driver and this documentation. 

 

 Notes: 
 This document assumes that you have read the “Development Environment” chapter in Studio’s Technical 

Reference Manual. 

 This document also assumes that you are familiar with the Microsoft Windows NT/2000/XP environment. If 
you are not familiar with Windows, then we suggest using the Help feature (available from the Windows 
desktop Start menu) as you work through this guide.  
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General Information 

This chapter identifies all of the hardware and software components required to implement serial communication 
between the WA982 driver in Studio and a target Watlow Controls device.  

The information is organized into the following sections: 

 Device Specifications 

 Network Specifications 

 Driver Characteristics 

 Conformance Testing 

Device Specifications 

To establish communication, your target device must meet the following specifications: 

 Manufacturer: Watlow Controls 

 Compatible Equipment: 981-984 Series 

Network Specifications 

To establish communication, your device network must meet the following specifications: 

 Physical Protocol: Serial 

Driver Characteristics 

The WA982 driver package consists of the following files, which are automatically installed in the \DRV 

subdirectory of Studio: 

 WA982.INI: Internal driver file. You must not modify this file. 

 WA982.MSG: Internal driver file containing error messages for each error code. You must not modify this 

file.  
 WA982.PDF: This document, which provides detailed information about the WA982 driver. 

 WA982.DLL: Compiled driver. 

 

 Note: 
You must use Adobe Acrobat® Reader™ to view the WA982.PDF document. You can install Acrobat Reader 

from the Studio installation CD, or you can download it from Adobe’s Web site.  

 

 

You can use the WA982 driver on the following operating systems:  

 Windows NT/2000/XP 

 Windows CE  

 



WA982 – Driver Version 2.00 

Doc. Revision F – Sep. 23, 2010 

Page 4/14 

Selecting the Driver 

When you install Studio, all of the communication drivers are automatically installed in the \DRV subdirectory but 

they remain dormant until manually selected for specific applications. To select the WA982 driver for your Studio 
application: 

1. From the main menu bar, select Insert Driver to open the Communication Drivers dialog.  

2. Select the WA982 driver from the Available Drivers list, and then click the Select button.  

 

Communication Drivers Dialog 

3. When the WA982 driver is displayed in the Selected Drivers list, click the OK button to close the dialog. The 
driver is added to the Drivers folder, in the Comm tab of the Workspace. 

 

 Note: 
It is not necessary to install any other software on your computer to enable communication between Studio 
and your target device. However, this communication can only be used by the Studio application; it cannot 
be used to download control logic to the device. For more information, please consult the documentation 
provided by the device manufacturer. 

 
 

 Attention: 
For safety reasons, you must take special precautions when installing any physical hardware. Please 
consult the manufacturer’s documentation for specific instructions. 
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General Information 

Consult your Watlow Controls documentation for information about configuring your device. 

Configuring the Driver  

Once you have selected the WA982 driver in Studio, you must properly configure it to communicate with your 
target device. First, you must set the driver’s communication settings to match the parameters set on the device. 
Then, you must build driver worksheets to associate database tags in your Studio application with the appropriate 
addresses (registers) on the device. 

Configuring the Communication Settings 

The communication settings are described in detail in the “Communication” chapter of the Studio Technical 
Reference Manual, and the same general procedures are used for all drivers. Please review those procedures 
before continuing. 

For the purposes of this document, only WA982 driver-specific settings and procedures will be discussed here. To 
configure the communication settings for the WA982 driver: 

1. In the Workspace pane, select the Comm tab and then expand the Drivers folder. The WA982 driver is 
listed here as a subfolder. 

2. Right-click on the WA982 subfolder and then select the Settings option from the pop-up menu: 

 

Select Settings from the Pop-Up Menu 
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The WA982: Communication Settings dialog is displayed: 

 

WA982: Communication Settings Dialog 
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3. In the Communication Settings dialog, configure the driver settings to enable communication with your 
target device. To ensure error-free communication, the driver settings must exactly match the 
corresponding settings on the device. Please consult the manufacturer’s documentation for instructions 
how to configure the device and for complete descriptions of the settings. 

Depending on your circumstances, you may need to configure the driver before you have configured your 
target device. If this is the case, then take note of the driver settings and have them ready when you later 
configure the device. 

 

Attention: 

For safety reasons, you must take special precautions when connecting and configuring new 

equipment. Please consult the manufacturer’s documentation for specific instructions. 

 

The communication settings and their possible values are described in the following table: 

 

Parameters Default Values Recommended Values Description 

COM COM2 COM2 Serial port of the PC used to communication with the device. 

Baud Rate 9600 9600 Communication rate of data. 

Data Bits 8 8 or 7 Number of data bits used in the protocol. 

Stop Bits 1 1 Number of stop bits used in the protocol. 

Parity None Even, None or Odd Parity of the protocol. 
 

4. If you are using a Data Communication Equipment (DCE) converter (e.g., 232/485) between your PC and 
your target device, then you must also adjust the Control RTS (Request to Send) setting to account for the 
converter. In the Communication Settings dialog, click the Advanced button to open the Advanced Settings dialog: 

 

Advanced Settings Dialog 
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When the dialog is displayed, configure the Control RTS setting using the following information:  

 

Setting Default Values Description 

Control RTS no no Do not set the RTS (Request to Send) handshake signal. IMPORTANT: If you 
are using Windows 95/98 or Windows CE with the correct RS232/RS485 
adapter (i.e. without RTS control), then you must select this option. 

yes Set the RTS (Request to Send) handshake signal before communication. 
IMPORTANT: If you are using Windows NT and the Cutler-Hammer 
RS232/RS485 adapter, then you must select this option. 

yes+echo Set the RTS (Request to Send) handshake signal before communication, and 
echo the signal received from the target device. 

 

 Attention: 

If you incorrectly configure the Control RTS setting, then runtime communication will fail and the driver 

will generate a –15 error. See “Troubleshooting” for more information. 

 

You do not need to change any other advanced settings at this time. You can consult the Studio 
Technical Reference Manual later for more information about configuring these settings. 

5. Click OK to close the Advanced Settings dialog, and then click OK to close the Communication Settings dialog. 
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Configuring the Driver Worksheets 

A selected driver includes one or more driver worksheets, which are used to associate database tags in Studio 
with registers on the target device. Each worksheet is triggered by specific application behavior, so that the tags / 
registers defined on that worksheet are scanned only when necessary – that is, only when the application is doing 
something that requires reading from or writing to those specific tags / registers. Doing this optimizes 
communication and improves system performance. 

To insert a new driver worksheet: 

1. In the Comm tab, open the Drivers folder and locate the WA982 subfolder. 

2. Right-click on the WA982 subfolder, and then select Insert from the pop-up menu: 

 

Inserting a New Worksheet 

A new WA982 driver worksheet is inserted into the WA982 subfolder, and the worksheet is opened for 
configuration: 

  

WA982 Driver Worksheet 

 

 Note: 

Worksheets are numbered by default in order of creation, so the first worksheet is WA982001.drv. 

Header 

Body 
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That numeration may be changed by the user. 

 

Most of the fields on this worksheet are standard for all drivers; see the “Communication” chapter of the 
Technical Reference Manual for more information on configuring these fields. However, the Station, 
Header, and Address fields use syntax that is specific to the WA982 driver. 

3. Configure the Station and Header fields as follows: 

 Station field: This field contains the remote station number (0 to 31). 

You can also specify an indirect tag (e.g. {station}), but the tag that is referenced must follow the 

same syntax and contain a valid value. 

 Header field: This field is not used. 

 

4. The Address field contains the command to be executed in the device.  

The following table contains some of the commands to be used in the Address field: 

 

 

Sample of Commands to be used in the “Address” parameter 
 

Command Command Name Comment 

IN1 Input 1 
Select sensor type for input 1. This selection must match the 
sensor type connected to terminals 8, 9 and 10. 

IN2 Input 2 
Select sensor type for input 2. This selection must match the sensor 

type connected to terminals 18, 19 and 20. 

CF Celsius-Farenheit Select which temperature scale the controller will use. 

DE1 Output 1 Derivative 
Tune the derivative to eliminate overshoot on startup or after the 

set point changes. 

DE2 Output 2 Derivative 
Tune the derivative to eliminate overshoot on startup or after the 

set point changes. 

IT1 Output 1 Integral 
Tune the control action to eliminate the offset or droop between 

the set point and the actual process value for PID output 1. 

IT2 Output 2 Integral 
Tune the control action to eliminate the offset or droop between 

the set point and the actual process value for PID output 2. 

PB1 Output 1 Proportional Band Select the proportional band for PID output 1. 

PB2 Output 2 Proportional Band Select the proportional band for PID output 2. 

RA1 Output 1 Rate 
Tune the rate to eliminate overshoot on startup or after the set 

point changes. 

RA2 Output 2 Rate 
Tune the rate to eliminate overshoot on startup or after the set 

point changes. 

RE1 Output 1 Reset 
Tune the control action to eliminate the offset or droop between 

the set point and the actual process value for PID output 1. 

RE2 Output 2 Reset 
Tune the control action to eliminate the offset or droop between 

the set point and the actual process value for PID output 2. 

CT1 Output 1 Cycle Time Select the time, in seconds, of a complete on/off cycle. 

CT2 Output 2 Cycle Time Select the time, in seconds, of a complete on/off cycle. 

HUNT Hunt 
Set the deadband, as a percentage of output, to keep the valve 

from hunting. 
 
 

For more information about commands and addressing, please consult the manufacturer’s documentation. 
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Executing the Driver  

By default, Studio will automatically execute your selected communication driver(s) during application runtime. 

However, you may verify your application’s runtime execution settings by checking the Project Status dialog. 

To verify that the communication driver(s) will execute correctly: 

1. From the main menu bar, select Project → Status. The Project Status dialog displays: 

 

Project Status Dialog 

2. Verify that the Driver Runtime task is set to Automatic. 

 If the setting is correct, then proceed to step 3 below. 

 If the Driver Runtime task is set to Manual, then select the task and click the Startup button to toggle the 
task’s Startup mode to Automatic.  

3. Click OK to close the Project Status dialog.  

4. Start the application to run the driver. 
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Troubleshooting 

If the WA982 driver fails to communicate with the target device, then the database tag(s) that you configured for 
the Read Status or Write Status fields of the Main Driver Sheet will receive an error code. Use this error code and the 
following table to identify what kind of failure occurred. 

 

Error 

Code 
Description Possible Causes Procedure to Solve 

0 OK  Communication without problems  None 

1 
ERROR ESTABILISHING 
COMMUNICATION LINK 

 Disconnected cables 

 PLC turned off, or in Stop or error mode 

 Wrong Station number 

 Check the cable wiring 

 Check the PLC state (it must be RUN) 

 Check the station number. 

2 READ ERROR  The device sent a invalid message 
 Check if the registry and address configured exist into 

the PLC. 

-15 
Timeout waiting start a 
message. 

 Disconnected cables 

 PLC turned off, or in Stop or error mode 

 Wrong Station number 

 Wrong RTS/CTS control settings 

 Check the cable wiring 

 Check the PLC state (it must be RUN) 

 Check the station number.  

 Check the right configuration. Review the 

Communication Parameters section for valid 

RTS/CTS configurations.  

-17 
Timeout between 
 rx characters. 

 PLC in stop or error mode 

 Wrong station number 

 Wrong parity 

 Wrong RTS/CTS configuration settings 

 Check the cable wiring 

 Check the PLC stat e (it must be RUN) 

 Check the station number 

 Check the configuration. Review the Communication 

Parameters section for valid RTS/CTS configurations.  

 
 

 Tip:  

You can monitor communication status by establishing an event log in Studio’s Output window (LogWin 

module). To establish a log for Field Read Commands, Field Write Commands and Serial Communication, right-click 

in the Output window and select the desired options from the pop-up menu. 

You can also use the LogWin module (Tools  LogWin) to establish an event log on a remote unit that runs 
Windows CE. The log is saved on the unit in the celog.txt file, which can be downloaded later. 

 

If you are unable to establish communication between Studio and the target device, then try instead to establish 
communication using the device’s own programming software. Quite often, communication is interrupted by a 
hardware or cable problem or by a device configuration error. If you can successfully communicate using the 
programming software, then recheck the driver’s communication settings in Studio. 

To test communication between Studio and the device, we recommend using the sample application provided 
rather than your new application. 
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If you must contact us for technical support, please have the following information available: 

 Operating System (type and version): To find this information, select Tools → System Information.  

 Project Information: To find this information, select Project → Status. 

 Driver Version and Communication Log: Displays in the Studio Output window when the driver is running. 

 Device Model and Boards: Consult the hardware manufacturer’s documentation for this information. 
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Revision History 
 

Doc. 

Revision 

Driver 

Version 
Author Date Description of changes 

A 1.01 Luis F. M. Rodas 26-May-1998 Fixed bug with command STP. 

B 1.02 Luis F. M. Rodas 28-May-1998 Fixed bug with command STP when send decimal values. 

C 1.03 Luis F. M. Rodas 01-Jun-1998 Fixed bug with command STP when send negatives values. 

D 1.04 Plínio M. Santana 15-Dec-2006 Made modifications to match with UNICODE requirements. 

E 2.00.1-Beta Plínio M. Santana 09-Jan-2007 Document corrections. 

F 2.00 André Körbes 23-Sep-2010 Fixed document version. 
 


