
STRAT – Driver Version 2.00 

Doc. Revision B – January 20, 2011 

Page 1/15 

STRAT Communication Driver  

Communication Driver with STRATON  
PC Base Control 

 

Contents 

INTRODUCTION ........................................................................................................................................................2 

GENERAL INFORMATION ........................................................................................................................................3 

DEVICE CHARACTERISTICS .....................................................................................................................................3 
DRIVER CHARACTERISTICS .....................................................................................................................................3 
CONFORMANCE TESTING ........................................................................................................................................4 

INSTALLING THE DRIVER .......................................................................................................................................5 

CONFIGURING THE DRIVER ...................................................................................................................................6 

SETTING THE COMMUNICATION PARAMETERS ..........................................................................................................6 
CONFIGURING THE DRIVER WORKSHEETS ...............................................................................................................7 
BROWSING TAGS ....................................................................................................................................................9 

EXECUTING THE DRIVER ..................................................................................................................................... 11 

TROUBLESHOOTING ............................................................................................................................................ 12 

SAMPLE APPLICATION ........................................................................................................................................ 14 

REVISION HISTORY............................................................................................................................................... 15 

 



STRAT – Driver Version 1.00 

Doc. Revision A – December 24, 2004  

Page 2/15 

Introduction 

The STRAT driver enables communication between the Studio system and Straton PC Base Control, according to 

the specifications discussed in this document.  

This document was designed to help you install, configure and execute the STRAT driver to enable 

communication with these devices. The information in this document is organized as follows: 

 Introduction: Provides an overview of the STRAT driver documentation. 

 General Information: Provides information needed to identify all the required components (hardware and 

software) used to implement communication between Studio and the STRAT driver.  

 Installing the Driver: Explains how to install the STRAT driver. 

 Configuring the Driver: Explains how to configure the STRAT driver. 

 Executing the Driver: Explains how to execute the driver to verify that you installed and configured the  

driver correctly.    

 Troubleshooting: Lists the most common error codes for this protocol and explains how to fix these errors. 

 Sample Application: Explains how to use a sample application to test the STRAT driver configuration. 

 Revision History: Provides a log of all modifications made to the driver and the documentation.  

 Notes:  

• This document assumes that you have read the “Development Environment” chapter in the Studio 
Technical Reference Manual. 

• This document also assumes that you are familiar with the Windows NT/2000/XP environment.  
If you are unfamiliar with Windows NT/2000/XP, we suggest using the Help feature (available from the 
Windows desktop Start menu) as you work through this guide.  
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General Information 

This chapter explains how to identify all the hardware and software components used to implement 

communication between the Studio STRAT driver and the OpenControl Monitor.  

The information is organized into the following sections: 

 Device Characteristics 
 Driver Characteristics 

Device Characteristics 

To establish communication, you must use devices with the following specifications:  

 Manufacturer: COPALP S.A. 

For a list of the devices used for conformance testing, see “Conformance Testing” on page 4. 

Driver Characteristics 

The STRAT driver is composed of the following files: 

 STRAT.INI: Internal driver file. You must not modify this file. 

 STRAT.MSG: Internal driver file containing error messages for each error code. You must not modify this file.  

 STRAT.PDF: Document providing detailed information about the STRAT driver. 

 STRAT.DLL: Compiled driver. 

 




Notes:  

• All of the preceding files are installed in the /DRV subdirectory of the Studio installation directory.  

• You must use Adobe Acrobat® Reader™ (provided on the Studio installation CD-ROM) to view  
the STRAT.PDF document. 

 

You can use the STRAT driver on the following operating systems:  

 Windows 2000 

 Windows NT 

 Windows Vista 

 Windows 7 

For a list of the operating systems used for conformance testing, see “Conformance Testing” on page 4.  
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The STRAT driver supports the following data type: 
 

T5 Runtime 

Data Type 

Write Read 

BOOL  

INT  

DINT  

REAL  

LREAL  

STRING  

TIME  

UDINT  

 

Conformance Testing 

The following hardware/software was used for conformance testing: 

 Cable: None 

Driver 

Version 

Studio 

Version 

Operating 

System 

(development) 

Operating 

System 

(runtime) 

Equipment 

1.00 6.1 
Windows XP 

Professional 

Windows XP 

Professional 
Straton Control Unlimited and SoftNC 

2.00 6.1 
Windows XP 

Professional 

Windows XP 

Professional 
SoftNC 
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Installing the Driver 

When you install Studio version 5.1 or higher, all of the communication drivers are installed automatically.  

You must select the driver that is appropriate for the application you are using. 

Perform the following steps to select the driver from within the application: 

1. Open Studio from the Start menu.  

2. From the Studio main menu bar, select File Open Project to open your application. 

3. Select Insert Driver from the main menu bar to open the Communication Drivers dialog.  

4. Select the STRAT driver from the Available Drivers list, and then click the Select button.  

 

Communication Drivers Dialog 

5. When the STRAT driver displays in the Selected Drivers list, click the OK button to close the dialog. 

 

 Note:    

It is necessary to install the StratExe.exe file. It must be located in the \DRV directory on your computer 

to enable communication between the host and the Straton software.  

 

 Attention:    

For safety reasons, you must use special precautions when installing the physical hardware. Consult the 
hardware manufacturer’s documentation for specific instructions in this area. 
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Configuring the Driver  

After opening Studio and selecting the STRAT driver, you must configure the driver. Configuring the STRAT driver 

is done in two parts: 

 Specifying communication parameters 

 Defining tags and controls in the STANDARD DRIVER SHEETs (or Communication tables) 

Worksheets are divided into two sections, a Header and a Body. The fields contained in these two sections 

are standard for all communications drivers — except the Station, Header and Address fields, which are driver-

specific. This document explains how to configure the Station, Header and Address fields only. 

 

 Note:    

For a detailed description of the Studio STANDARD DRIVER SHEETs, and information about configuring 
the standard fields, review the product’s Technical Reference Manual.  

 

Setting the Communication Parameters 

Use the following steps to configure the communication parameters, which are valid for all Driver worksheets 
configured in the system: 

1. From the Studio development environment, select the Comm tab located below the Workspace pane. 

2. Click the Drivers folder in the Workspace pane to expand the folder.  

3. Right-click on the STRAT subfolder. When the pop-up menu displays, select the Settings option: 

 

Select Settings from the Pop-Up Menu 

The STRAT: Communication Parameters dialog displays: 

 

Communication Parameters Dialog 
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4. Specify the custom parameters as noted in the following table: 
 

Parameter Default 
Value 

Description Requirement 

Project Path - Path to the saved Straton Project. Optional 

Project Name - 
Name of the Project, this can be found on the project file inside 
the “<proj>” tag. Example <proj>=Test , in this case the name 
of the Project Name should be Test 

Required 

 
 

 

5. Click the Advanced button on the Communication Parameters dialog to open the Advanced Settings dialog, 

and configure the necessary settings. 
 

 Notes:    

 Do not change any of the other Advanced parameters at this time. You can consult the Studio 
Technical Reference Manual for information about configuring these parameters in the future. 

 Generally, you must change the Advanced parameter settings if you are using a DCE (Data 
Communication Equipment) converter (232/485 for example), modem, and so forth between the  
PC, the driver and the host. You must be familiar with the DCE specifications before adjusting these 
configuration parameters.  

  

Configuring the Driver Worksheets 

This section explains how to configure the STANDARD DRIVER SHEETs (or Communication tables) to associate 

application tags with the device addresses. You can configure multiple Driver worksheets — each of which is 

divided into a Header section and Body section.  

Configuring the STANDARD DRIVER SHEET 

Use the following steps to create a new STANDARD DRIVER SHEET: 

1. From the Studio development environment, select the Comm tab, located below the Workspace pane. 

2. In the Workspace pane, expand the Drivers folder, and right-click the STRAT subfolder.  

3. When the pop-up menu displays, select the Insert option. 

 

Inserting a New Worksheet 

 

 Note:  

To optimize communication and ensure better system performance, you must tie the tags in different 

Driver worksheets to the events that trigger communication between each tag group and the period in 

which each tag group must be read or written. Also, we recommend configuring the communication 

addresses in sequential blocks to improve performance. 
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The STANDARD DRIVER SHEET displays (similar to the following figure): 

 

STANDARD DRIVER SHEET 

In general, all parameters on the Driver worksheet (except the Station, Header and Address fields) are standard 

for all communication drivers, but they will not be discussed in this document. For detailed information about 

configuring the standard parameters, consult the Studio Technical Reference Manual.  

4.   Use the following information to complete the Station, Header and Address fields on this worksheet.  

– Station field: <IP Address>:<Port> 

– Header field: No Header (keep this field blank) 

– Address field: Type here the name of the  Database Tag 

 

Examples Table 

Header Address 

(leave this blank) DISECONDS 

(leave this blank) 

RREAL 
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Browsing Tags 

This feature enable the Indusoft to automatically connect on the T5 runtime and acquire the Tags (Symbols) 
and display it to the customer. 
 
Configuring the Browsing Tag feature 
 

1 - Fill the Station on the Standard Driver Sheet with the correct information. Follow the pattern: 
<IP>:<Port>    Example:   127.0.0.1:1100 

 

Setting the Station 

2 - Click with the right button inside the Address area, a menu should appear. 
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3- The Tag names should appear in a dialog. 

 

4- Select the value and click ok, the Tag name will be placed on the Sheet. 

 
 

 BROWSING TAG  ERRORS:    

If the Station is invalid or if the IP connection could not be succeeded , in the output window a message 
will be shown: 
 

“Unable to Load Symbols” 
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Executing the Driver  

After adding the STRAT driver to a project, Studio sets the project to execute the driver automatically when you 

start the run-time environment.  

To verify that the driver run-time task is enabled and will start correctly, perform the following steps: 

1. Select Project → Status from the main menu bar. 

The Project Status dialog displays: 

 

Project Status Dialog 

2.   Verify that the Driver Runtime task is set to Automatic. 

– If the setting is correct, click OK to close the dialog.  

– If the Driver Runtime task is set to Manual, select the Driver Runtime line. When the Startup button becomes 

active, click the button to toggle the Startup mode to Automatic.  

3.   Click OK to close the Project Status dialog.  

4.   Start the application to run the driver. 
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Troubleshooting 

If the STRAT driver fails to communicate with the device, the tag you configured for the Read Status or Write Status 

fields will receive an error code. Use this error code and the following table to identify the failure that occurred.  

 

Error Code Description Possible Causes Procedure to Solve 

0 OK Communication without problems None required 

2 Communication Error  Disconnected cables 
 PLC is turned off, in stop mode, or in error 

mode. 
 Wrong station number 

 Check cable wiring. 
 Check the PLC state – it must be RUN. 
 Check the station number. 

 

3 Invalid Station Station is invalid Verify the IP and Port typed. 

6 Invalid Tag The tag specified does not exists on the T5 
runtime. 

Use the Browse feature to know what tags the 
currently T5 runtime has. 

 

 

 Tip:  

You can verify communication status using the Studio development environment Output window (LogWin 

module). To establish an event log for Field Read Commands, Field Write Commands and Serial Communication, 

right-click in the Output window. When the pop-up menu displays, select the option to set the log events. If 

you are testing a Windows CE target, you can use the Remote LogWin of Studio (Tools  Remote LogWin) to 

get the log events from the target unit remotely. 

 

If you are unable to establish communication with the PLC, try to establish communication between the PLC 

Programming Tool and the PLC. Quite frequently, communication is not possible because you have a hardware 

or cable problem, or a PLC configuration error. After successfully establishing communication between the 

device’s Programming Tool and the PLC, you can retest the supervisory driver. 

To test communication with Studio, we recommend using the sample application provided rather than your new 

application. 
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If you must contact us for technical support, please have the following information available: 

 Operating System (type and version): To find this information, select Tools → System Information.  

 Studio version: To find this information, select Help → About. 

 Driver Version: To find this information, read the full description of the driver on the Communication Drivers 

dialog. 

 Communication Log: Displays in the Studio Output window (or LogWin window) when the driver is running. Be 

sure to enable the Field Read Commands, Field Write Commands and Serial Communication for the LogWin window. 

 Device Model and Boards: Consult the hardware manufacturer’s documentation for this information. 
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Sample Application 

You will find a sample application for drivers in the /COMMUNICATION EXAMPLES/STRAT directory. We strongly 

recommend that you check for a sample application for this driver and use it to test the driver before configuring 

your customized application, for the following reasons: 

 To better understand the information provided in each section of this document. 

 To verify that your configuration is working satisfactorily. 

 To certify that the hardware used in the test (device, adapter, cable and PC) is working satisfactorily before 
you start configuring your own, customized applications. 

 

Note:  

This application sample is not available for all drivers.  

 

Use the following procedure to perform the test: 

1. Configure the device’s communication parameters using the manufacturer’s documentation. 

2. Open and execute the sample application. 

 Tip:  

You can use the sample application screen as the maintenance screen for your custom applications.  
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Revision History  
 

Doc. 

Revision 

Driver 

Version 
Author Date Description of changes 

A 1.00 Eric Vigiani Dec/24/2004 Initial version 

B 2.00 Paulo RB Jan/20/2011 Changed driver API 
 


