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 Introduction 

The PROT1 driver enables communication between Studio system and the Toshiba Prosec T1 PLC using Serial 

Communication, according to the specifications discussed in this publication.  

This publication was designed to help you install, configure, and execute the PROT1 driver to enable 

communication with the Toshiba devices. The information in this publication is organized as follows: 

 Introduction: Provides an overview of the PROT1 driver documentation. 

 General Information: Provides information needed to identify all the required components (hardware and 

software) used to implement communication between Studio and the PROT1 driver.  

 Installing the Driver: Explains how to install the PROT1 driver. 

 Configuring the Driver: Explains how to configure the communication driver.  

 Executing the Driver: Explains how to execute the driver to verify that you installed and configured the  

driver correctly.    

 Troubleshooting: Lists the most common error codes for this protocol. 

 Sample Application: Explains how to use a sample application to test the driver configuration. 

 Revision History: Provides a log of all modifications made to the driver and the documentation.  

 Notes:  

• This document assumes that you have read the “Development Environment” chapter in the product’s 

Technical Reference Manual. 

• This document also assumes that you are familiar with the Windows NT/2000/XP environment.  

If you are unfamiliar with Windows NT/2000/XP, we suggest using the Help feature (available from the 

Windows desktop Start menu) as you work through this guide.  
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General Information 

This chapter explains how to identify all the hardware and software components used to implement 

communication between the PROT1 driver and Toshiba devices.  

The information is organized into the following sections: 

 Device Characteristics 

 Link Characteristics 

 Driver Characteristics 

 Conformance Testing 

Device Characteristics 

This driver has been tested successfully with the following devices: 

 Manufacturer: Toshiba 

 Compatible Equipment: Any Toshiba Prosec T1 PLC communicating via Serial interface 

Link Characteristics 

To establish communication, you must use links with the following specifications: 

 Physical Protocol:  RS232 

 Logic Protocol: Computer Link 

 Device Runtime Software: None 

 Specific PC Board: None 

Driver Characteristics 

The PROT1 driver is composed of the following files: 

 PROT1.INI: Internal driver file. You must not modify this file. 

 PROT1.MSG: Internal driver file containing error messages for each error code.  

You must not modify this file.  

 PROT1.PDF: Document providing detailed information about the PROT1 driver. 

 PROT1.DLL: Compiled driver. 

 

 Notes:  

• All of the preceding files are installed in the /DRV subdirectory of the Studio installation directory.  

• You must use Adobe Acrobat® Reader™ (provided on the Studio installation CD-ROM) to view  
the PROT1.PDF document.  

You can use the PROT1 driver on the following operating systems:  

 Windows NT/2K/XP 

 Windows CE 
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Conformance Testing 

The following hardware/software was used for conformance testing: 

 

Driver Configuration: 

 COM:  COM1 

 Baud Rate:  9600 

 Data Bits:  8  

 Stop Bits:  1 

 Parity:  ODD  

 

 

Driver 

Version 

Studio 

Version 

Operating 

System 
Equipment 

2.00 2.4 
Windows 

NT 
Prosec-T2E 
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Installing the Driver 

When you install Studio version 5.1 or higher, all of the communication drivers are installed automatically.  

You must select the driver that is appropriate for the application you are using. 

Perform the following steps to select the driver from within the application: 

1. Open Studio from the Start menu.  

2.   From the Studio main menu bar, select File →Open Project to open your application. 

3.   Select Insert →Driver from the main menu bar to open the Communication Drivers dialog.  

4.   Select the PROT1 driver from the Available Drivers list, and then click the Select button: 

 

Communication Drivers Dialog 

5. When the PROT1 driver displays in the Selected Drivers list, click the OK button to close the dialog. 

 

 Attention: 

For safety reasons, you must take precautions when installing the physical hardware. Consult the hardware 

manufacturer’s documentation for specific installation instructions. 
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Configuring the Driver  

After opening Studio and selecting the PROT1 driver, you must configure the driver. Configuring the PROT1 

driver is done in two parts: 

 Specifying communication parameters 

 Defining communication tags and controls in the Communication tables or Driver worksheet 

Worksheets are divided into two sections, a Header and a Body. The fields contained in these two sections 

are standard for all communications drivers — except the Station, Header and Address fields, which are driver-

specific. This document explains how to configure the Station, Header and Address fields only. 

 

 Notes:    

For a detailed description of the Studio Standard Driver Worksheets, and information about configuring the 
standard fields, review the product’s Technical Reference Manual.  

 

Setting the Communication Parameters 

Use the following steps to configure the communication parameters, which are valid for all driver worksheets 
configured in the system: 

1. From the Studio development environment, select the Comm tab located below the Workspace. 

2. Click on the Drivers folder in the Workspace to expand the folder.  

3. Right-click on the PROT1 subfolder, and when the pop-up menu displays, select the Settings option: 

 

Select Settings from the Pop-Up Menu 

 

 

 

 

 

 

 

 

 

 



PROT1 – Driver Version 2.01 

Doc. Revision E – Sep. 23, 2010 

7/14 

 

 

The PROT1: Communication Parameters dialog displays: 

 

PROT1: Communication Parameters Dialog 

4. This driver does not have custom parameters. Specify the parameters as noted in the following table. Click OK 

to close the dialog. 

 

Configuring the Driver Worksheet 

This section explains how to configure a Standard Driver Worksheet (or Communication table) to associate 

application tags with the PLC addresses. You can configure multiple Driver worksheets — each of which is 

divided into a Header section and a Body section.  

Use the following steps to create a new Standard Driver worksheet: 

1. From the Studio development environment, select the Comm tab, located below the Workspace pane. 

2. In the Workspace pane, expand the Drivers folder, and right-click the PROT1 subfolder.  

3. When the pop-up menu displays, select the Insert option: 

 

Inserting a New Worksheet 
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 Note:  

To optimize communication and ensure better system performance, you must tie the tags in different 

driver worksheets to the events that trigger communication between each tag group and the period in 

which each tag group must be read or written. Also, we recommend configuring the communication 

addresses in sequential blocks to improve performance. 

 

The PROT1.drv dialog displays (similar to the following figure): 

 

PROT1 Driver Worksheet 

In general, all parameters on the Driver worksheet (except the Station, Header and Address fields) are standard 

for all communication drivers, and they will not be discussed in this publication. For detailed information about 

configuring the standard parameters, consult the Studio Technical Reference Manual.  

4. Use the following information to complete the Station, Header, and Address fields on this worksheet: 

 Station field: Use this field to specify the PLC ID. This field accepts values 1 to 32. If this field is in blank, 
the driver will assume the ID 1.  

Syntax: 

<PLC ID> 

 

 Header field: Use the information in the following table to define the type of variables that will be read from 
or written to the device and a reference to the initial address.  

These variables must comply with the following syntax: 

 

<Type>:<AddressReference> (for example: RW:1) 

 

Where: 
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– <Type> can be the register type. (XW, YW, SW, RW, T, C and D) or device type (X, Y, S and R)  

 

– <AddressReference> is the initial address (reference) of the configured group. This number 

always refers to the Byte address number (see the following table). 
 

  Address field: Use the information provided in the following table to associate each tag to its respective 
device address.  

Type the tag from your application database into the Tag Name column. This tag will receive values from or 

send values to an address on the device. The address must comply with the following syntax: 

 

<AddressOffset>.<Bit> (for example: 10.2) 

 

Where: 

 <AddressOffset> is a parameter added to the AddressReference parameter (configured in the Header 

field) to compose the group address configured in the Header field. 

 <Bit> is the bit number (from 0 – 32) from the word address. This parameter is optional. 
 
 

Sample Address Configuration 

Address on the Device Header Field  Address Field  

XW (Word 5) XW:0 5 

XW:5 0 

XW:3 2 

RW (Word 6) RW:0 5 

RW:5 0 

RW:1 4 

T (Word 33) T:0 33 

T:30 3 

T:33 0 

 

 

 

Attention:  

You must not configure a range of addresses in the same worksheet that is greater than the maximum 
block size (data buffer length) supported by the protocol. The maximum data buffer length for this driver 
is 61 register in each Standard Driver worksheet.  
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Executing the Driver 

After adding the PROT1 driver to a project, Studio sets the project to execute the driver automatically when you 

start the run-time environment.  

To verify that the driver run-time task is enabled and will start correctly, perform the following steps: 

1. Select Project → Status from the main menu bar. 

The Project Status dialog displays: 

 

Project Status Dialog 

2. Verify that the Driver Runtime task is set to Automatic. 

 If the setting is correct, click OK to close the dialog.  

 If the Driver Runtime task is set to Manual, select the Driver Runtime line. When the Startup button becomes 
active, click the button to toggle the Startup mode to Automatic.  

3. Click OK to close the Project Status dialog.  

4. Start the application to run the driver. 



PROT1 – Driver Version 2.01 

Doc. Revision E – Sep. 23, 2010 

11/14 

 

Troubleshooting 

If the PROT1 driver fails to communicate with the device, the tag you configured for the Read Status or Write Status 
fields will receive an error code. Use this error code and the following table to identify what kind of failure 
occurred.  

 

Error Code Description Possible Causes Procedure to Solve 

0 OK  Communication without problems None required 

1 ERROR PROTOCOL Invalid received message Check driver Communication Parameters. 

2 ERROR BLOCKSIZE Block Size is higher that 61 operands Divide the operands in two worksheets. 

3 ERROR INVALID CR Invalid received message Check driver Communication Parameters. 

4 ERROR INVALID STATION PLC ID is  higher that 32 Check the Station field. 

Put a valid value (1 to 32). 

6 ERROR CHECKSUM Invalid CheckSun received Check driver Communication Parameters. 

20 ERROR INVALID ADDRESS Address is higher than 65535 Check the Address field. 

Put a valid value (0 to 65535) 

30 ERROR INVALID HEADER The header value is not valid. Check the Header field. 

40 ERROR COMMAND Register does  not exist into PLC Check if the register exists into PLC. 

41 ERROR FORMAT The received message is wrong format.  Check driver Communication Parameters. 

42 ERROR COMMUNICATION BUSY Error because the communication is busy Check driver Communication Parameters. 

43 ERROR PASSWORD PROTECT Invalid Password Protect Check what the right password into the PLC is. 

44 ERROR MODE MISMATCH PLC is in wrong mode Check the PLC state – it must be RUN. 

45 ERROR REGISTER ADDRESS SIZE Invalid Register Size Check if the registers are valid into PLC. 

46 ERROR ON WRITING Invalid Write Command Check if the Register accepts write command 

47 ERROR T1 NOT RUNNING PLC is not running Check the PLC state – it must be RUN. 

-15 Timeout Start Message Disconnected cables 
PLC is turned off, in stop mode, or in error 

mode 
Wrong station number 
Wrong RTS/CTS control settings 

Check cable wiring. 
Check the PLC state – it must be RUN. 
Check the station number. 
Check the RTS/CTS configuration (see Studio 

Technical Reference Manual for valid 

configurations). 

-17 Timeout between rx char PLC in stop mode or in error mode 
Wrong station number 
Wrong parity 
Wrong RTS/CTS configuration settings 

Check cable wiring. 
Check the PLC state – it must be RUN. 
Check the station number. 
Check the RTS/CTS configuration (see “Error! 

Reference source not found.” for valid 
RTS/CTS configurations).  
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 Tip:  

You can verify communication status using the Studio development environment Output window (LogWin 

module). To establish an event log for Field Read Commands, Field Write Commands, and Serial Communication, 

right-click in the Output window. When the pop-up menu displays, select the option to set the log events. If 

you are testing a Windows CE target, you can enable the log at the unit (Tools  LogWin) and verify the 
celog.txt file created at the target unit.  
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If you are unable to establish communication with the PLC, try to establish communication between the PLC 

Programming Tool and the PLC. Quite frequently, communication is not possible because you have a hardware 

or cable problem, or a PLC configuration error. After successfully establishing communication between the 

device’s Programming Tool and the PLC, you can retest the supervisory driver. 

If you must contact us for technical support, please have the following information available: 

 Operating system (type and version): To find this information, select Tools → System Information.  

 Project Information: To find this information, select Project → Status. 

 Driver version and communication log: Displays in the Studio Output window when the driver is running. 

 Device model and boards: Consult the hardware manufacturer’s documentation for this information. 
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Revision History  

 

Doc. 

Revision 

Driver 

Version 

Author Date Description of Changes 

A 1.00 Roberto V. Junior 03 Mar 99  First version 

B 1.01 Roberto V. Junior 05 Mar 99 Fixed bugs in the first tests with equipments 

C 1.02 Roberto V. Junior 16 Mar 99 Modified the treatment of the X and Y registers 

D 2.00 Roberto V. Junior 29 Nov 99 Driver available for Windows CE 

E 2.01 Paulo Balbino 23 Sep 10 Driver supports setting the IP on each driver sheet on the station field if 

using serial encapsulation for TCP/IP or UDP/IP. 

 
 
 


