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Introduction 

The MEMP driver enables serial communication between the Studio system and remote devices using the 
MEMPs protocol, according to the specifications discussed in this document.  

This document will help you to select, configure and execute the MEMP driver, and it is organized as follows: 

 Introduction: This section, which provides an overview of the document. 

 General Information: Identifies all of the hardware and software components required to implement 
communication between the Studio system and the target device.  

 Selecting the Driver: Explains how to select the MEMP driver in the Studio system. 

 Configuring the Device: Describes how the target device must be configured to receive communication from 
the MEMP driver. 

 Configuring the Driver: Explains how to configure the MEMP driver in the Studio system, including how to 
associate database tags with device registers. 

 Executing the Driver: Explains how to execute the MEMP driver during application runtime. 

 Troubleshooting: Lists the most common errors for this driver, their probable causes, and basic procedures 
to resolve them. 

 Sample Application: Explains how to use a sample application to test the MEMP driver configuration 

 Revision History: Provides a log of all changes made to the driver and this documentation. 

 

 Notes: 
 This document assumes that you have read the “Development Environment” chapter in Studio’s Technical 

Reference Manual. 

 This document also assumes that you are familiar with the Microsoft Windows NT/2000/XP environment. If 
you are not familiar with Windows, then we suggest using the Help feature (available from the Windows 
desktop Start menu) as you work through this guide.  
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General Information 

This chapter identifies all of the hardware and software components required to implement serial communication 
between the MEMP driver in Studio and remote devices using the MEMPs protocol.  

The information is organized into the following sections: 

 Device Specifications 

 Network Specifications 

 Driver Characteristics 

 Conformance Testing 

Device Specifications 

To establish serial communication, your target device must meet the following specifications: 

 Manufacturer: CEMIG 

 Device Runtime Software: None 

Network Specifications 

To establish communication, your device network must meet the following specifications: 

 Device Communication Port: Serial COM Port  

 Device Runtime Software: None 

 Specific PC Board: None 

 

Driver Characteristics 

The MEMP driver package consists of the following files, which are automatically installed in the \DRV 

subdirectory of Studio: 

 MEMP.INI: Internal driver file. You must not modify this file. 

 MEMP.MSG: Internal driver file containing error messages for each error code. You must not modify this 

file.  
 MEMP.PDF: This document, which provides detailed information about the MEMP driver. 

 MEMP.DLL: Compiled driver. 

 

 Note: 
You must use Adobe Acrobat® Reader™ to view the MEMP.PDF document. You can install Acrobat Reader 

from the Studio installation CD, or you can download it from Adobe’s Web site.  

 

You can use the MEMP driver on the following operating systems:  

 Windows NT/2000/XP 
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Conformance Testing 

The following hardware/software was used for conformance testing: 

 Configuration: 

 MEMPs Port: 1 

 Baud Rate: 9600 

 Protocol: RTU 

 Data Bits: 8 

 Stop Bits: 1 

 Com Port: COM1 

 

 
 

Driver 

Version 

Studio 

Version 

Operating System 

(development) 

Operating System 

(target) 

2.21 6.1 Windows XP Windows XP 
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Selecting the Driver 

When you install Studio, all of the communication drivers are automatically installed in the \DRV subdirectory but 

they remain dormant until manually selected for specific applications. To select the MEMP driver for your Studio 
application: 

1. From the main menu bar, select Insert Driver to open the Communication Drivers dialog.  

2. Select the MEMP driver from the Available Drivers list, and then click the Select button.  

 

Communication Drivers Dialog 

3. When the MEMP driver is displayed in the Selected Drivers list, click the OK button to close the dialog. The 
driver is added to the Drivers folder, in the Comm tab of the Workspace. 

 
 
 

 Attention: 
For safety reasons, you must take special precautions when installing any physical hardware. Please 
consult the manufacturer’s documentation for specific instructions. 
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Configuring the Device 

Because there are several brands of equipment that use the MEMPs protocol, it is impossible to define a standard 
device configuration. Therefore, we suggest using the following default configuration: 

 Protocol: RTU 

 Baud Rate: 9600 

 Data Bits: 8 

 Stop Bits: 1 

 Parity: None 

Configuring the Driver  

Once you have selected the MEMP driver in Studio, you must properly configure it to communicate with your 
target device. First, you must set the driver’s communication settings to match the parameters set on the device. 
Then, you must build driver worksheets to associate database tags in your Studio application with the appropriate 
addresses (registers) on the device. 

Configuring the Communication Settings 

The communication settings are described in detail in the “Communication” chapter of the Studio Technical 
Reference Manual, and the same general procedures are used for all drivers. Please review those procedures 
before continuing. For the purposes of this document, only MEMP driver-specific settings and procedures will be 
discussed here. To configure the communication settings for the MEMP driver: 

1. In the Workspace pane, select the Comm tab and then expand the Drivers folder. The MEMP driver is 
listed here as a subfolder. 

2. Right-click on the MEMP subfolder and then select the Settings option from the pop-up menu. The MEMP: 
Communication Parameters dialog is displayed: 

   

 Select Settings from the Pop-Up Menu MEMP: Communication Parameters Dialog 
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3. Verify the Serial Port settings, and change them if necessary. 

 
 

4. If you are using a Data Communication Equipment (DCE) converter (e.g., 232/485) between your PC and 
your target device, then you must also adjust the Control RTS (Request to Send) setting to account for the 
converter. In the Communication Settings dialog, click the Advanced button to open the Advanced Settings dialog: 

 

Advanced Settings Dialog 

When the dialog is displayed, configure the Control RTS setting using the following information:  

 

Setting Default Values Description 

Control RTS no no Do not set the RTS (Request to Send) handshake signal. IMPORTANT: If you 
are using Windows 95/98 or Windows CE with the correct RS232/RS485 
adapter (i.e. without RTS control), then you must select this option. 

Yes Set the RTS (Request to Send) handshake signal before communication. 
IMPORTANT: If you are using Windows NT and the Cutler-Hammer 
RS232/RS485 adapter, then you must select this option. 

Yes+echo Set the RTS (Request to Send) handshake signal before communication, and 
echo the signal received from the target device. 

 
 

 Attention: 

If you incorrectly configure the Control RTS setting, then runtime communication will fail and the driver 

will generate a –15 error. See “Troubleshooting” for more information. 

 

You do not need to change any other advanced settings at this time. You can consult the Studio 
Technical Reference Manual later for more information about configuring these settings. 

5. Click OK to close the Advanced Settings dialog, and then click OK to close the Communication Settings dialog. 
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Configuring the Driver Worksheets 

Each selected driver includes a Main Driver Sheet and one or more Standard Driver Worksheets. The Main Driver 
Sheet is used to define tag/register associations and driver parameters that are in effect at all times, regardless of 
application behavior. In contrast, Standard Driver Worksheets can be inserted to define additional tag/register 
associations that are triggered by specific application behaviors. 

The configuration of these worksheets is described in detail in the “Communication” chapter of the Studio 
Technical Reference Manual, and the same general procedures are used for all drivers. Please review those 
procedures before continuing. 

For the purposes of this document, only MEMP driver-specific parameters and procedures are discussed here. 

MAIN DRIVER SHEET 

The MEMP driver only uses Standard Driver Sheet for a while. 

 

STANDARD DRIVER WORKSHEET 

When you select the MEMP driver and add it to your application, it has only a Main Driver Sheet by default (see 
previous section). However, you may insert additional Standard Driver Worksheets to define tag/register 
associations that are triggered by specific application behaviors. Doing this will optimize communication and 
improve system performance by ensuring that tags/registers are scanned only when necessary – that is, only 
when the application is performing an action that requires reading or writing to those specific tags/registers. 

 

 Note: 

We recommend configuring device registers in sequential blocks in order to maximize performance. 

 

To insert a new Standard Driver Worksheet: 

1. In the Comm tab, open the Drivers folder and locate the MEMP subfolder. 

2. Right-click on the MEMP subfolder, and then select Insert from the pop-up menu: 

 

Inserting a New Worksheet 

A new MEMP driver worksheet is inserted into the MEMP subfolder, and the worksheet is opened for 
configuration: 
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MEMP Driver Worksheet 

 

 Note: 

Worksheets are numbered in order of creation, so the first worksheet is MEMP001.drv. 

 

Most of the fields on this worksheet are standard for all drivers; see the “Communication” chapter of the 
Technical Reference Manual for more information on configuring these fields. However, the Header field 
uses syntax that is specific to the MEMP driver. 

3. Configure the Header fields as follows: 

Header field: The only value accepted by the header field is “MEMP”. 

 

4. Address field: 

 

 The Address field doesn’t need any configuration. Each tag has the following meanings: 

 

 

 

 

 

 

 

 

Header 

Body 
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Tag Position Meaning 

First Tag Number of seconds 

Second Tag Tax indicator 

Third Tag Reactive gap indicator 

Fourth Tag Calculation of capacitative energy 

Fifth Tag Calculation of reactive energy 

Sixth Tag Second (hour – annual). 

Seventh Tag Kind of tax 

Eighth Tag Tax of reactive ones actuated 

Ninth Tag Active energy 

Tenth Tag Reactive energy 

 

 

First Tag – Number of seconds. 

Second Tag – Tax indicator. 

Third Tag – Reactive gap indicator. 

Fourth Tag – Calculation of capacitative energy. 

Fifth Tag – Calculation of reactive energy. 

Sixth Tag – Second (hour – annual).  

Seventh Tag – Kind of tax. 

Eighth Tag – Tax of reactive ones actuated. 

Ninth Tag – Active energy. 

Tenth Tag – Reactive energy. 

 

 

 Note: 

You should create the maximum of 10 tags in each Worksheet to receive the data from the CEMIG 
device.  
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For more information about the device registers and addressing, please consult the manufacturer’s 
documentation. 
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Executing the Driver  

By default, Studio will automatically execute your selected communication driver(s) during application runtime. 

However, you may verify your application’s runtime execution settings by checking the Project Status dialog. 

To verify that the the communication driver(s) will execute correctly: 

1. From the main menu bar, select Project → Status. The Project Status dialog displays: 

 

Project Status Dialog 

2. Verify that the Driver Runtime task is set to Automatic. 

 If the setting is correct, then proceed to step 3 below. 

 If the Driver Runtime task is set to Manual, then select the task and click the Startup button to toggle the 
task’s Startup mode to Automatic.  

3. Click OK to close the Project Status dialog.  

4. Start the application to run the driver. 
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Troubleshooting 

Use this error code and the following table to identify what kind of failure occurred. 

 

Error Code Description Possible Causes Procedure to Solve 

 0 OK  Communication without problems None required 

 2 Invalid Header Invalid header typed in Driver worksheet Type MEMP in the header field. 

3 Invalid Address field Invalid Address  Check the initial address in the Driver worksheet. 

 Check the Holding register in the Driver worksheet with bit 

configuration. This parameter cannot execute write triggers—it 

executes “Write on Tag Change” only. 

 Retype the address in the Driver worksheet. 

4 Invalid Block size Offset is greater than the maximum 
allowed. The maximum offset is usually 64. 

Specify a valid offset or create a new Driver worksheet. 

5 Protocol Error The driver is not following the protocol 
standards. 

Check the protocol documentation and the buffers sent to the 
devices.  

6 Checksum Error The driver is receiving buffers with wrong 
sizes. 

Check the protocol documentation and the buffers received from 
the devices. 

7 Answer Error The driver is receiving buffers with wrong 
sizes. 

Check the protocol documentation and the buffers sent and 
received from the devices. 

8 Maximum Line on 
Address Field. 

Maximum lines available in TAG NAME for 
communication sheet 

Create another sheet and reduce the tags amount from the 
current sheet.  

 
 

 Tip:  

You can monitor communication status by establishing an event log in Studio’s Output window (LogWin 

module). To establish a log for Field Read Commands, Field Write Commands and Serial Communication, right-click 

in the Output window and select the desired options from the pop-up menu. 

 

If you are unable to establish communication between Studio and the target device, then try instead to establish 
communication using the device’s own programming software. Quite often, communication is interrupted by a 
hardware or cable problem or by a device configuration error. If you can successfully communicate using the 
programming software, then recheck the driver’s communication settings in Studio. 

If you must contact us for technical support, please have the following information available: 

 Operating System (type and version): To find this information, select Tools → System Information.  

 Project Information: To find this information, select Project → Status. 

 Driver Version and Communication Log: Displays in the Studio Output window when the driver is running. 

 Device Model and Boards: Consult the hardware manufacturer’s documentation for this information. 
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Sample Application 

A sample application that employs the MEMP driver is provided on the Studio installation CD. We strongly 
recommend that you use this sample application to test the driver before you develop your own applications, for 
the following reasons: 

 To better understand the information and instructions provided in this document; 

 To verify that your driver configuration is working satisfactorily with the target device; and 

 To ensure that the all of hardware used in the test (i.e. the device, adapter, cable, and PC) is functioning 
safely and correctly. 

 

Note:  

The following instructions assume that you are familiar with developing project applications in Studio. If you 

are not, then please review the relevant chapters of the Studio Technical Reference Manual before 

proceeding. 

 

To use the sample application: 

1. Configure the device’s communication settings according to the manufacturer’s documentation. 

2. Run Studio. 

3. From the main menu bar, select File  Open Project. 

4. Insert the Studio installation CD and browse it to find the sample application. It should be located in the 
directory \COMMUNICATION EXAMPLES\MEMP. 

5. Select and open the sample application. 

6. Configure and test the driver, as described in the rest of this document. 

When you have thoroughly tested the driver with your target device, you may proceed with developing your own 
Studio application projects. 

 

 Tip:  

You can use the sample application screen as the maintenance screen for your own applications.  
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