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Introduction 

The FPACV driver enables communication between Studio and FlashPoint ControlView Run-Time for Windows CE 
using the IXL API provided with the files “IsaIXL.dll” and “IsaSys.dll,” in accordance with the characteristics 

covered in this document. 
 
This document contains eight parts, as follows: 

 Introduction: Provides an overview of the driver documentation. 

 General Information: Provides information necessary to identify all the required components (hardware and 
software) necessary to implement the communication and global characteristics about the communication. 

 Installation: Explains the procedures that must be followed to install the software and hardware required for the 
communication. 

 Driver Configuration: Provides the required information to configure the communication driver, such as the 
different permutations for configuration and its default values. 

 Execution: Explains the steps to test whether the driver was correctly installed and configured.   

 Troubleshooting: Lists the most common error codes for this protocol and the procedures to fix them.   

 Application Sample: Provides a sample application for testing the configuration of the driver. 

 History of Versions: Provides a log of all the modifications made to the driver. 

 Notes:  

 This document assumes that you have read the “Driver Configuration” chapter in the product’s Technical 
Reference Manual. 

 This document also assumes that you are familiar with the Windows NT/2000/XP environment.  
If you are unfamiliar with Windows NT/2000/XP, we suggest using the Help feature (available from the Windows 
desktop Start menu) as you work through this guide.  
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General Information 

This chapter explains how to identify all the hardware and software components used to implement serial 

communication between Studio and FlashPoint ControlView Run-Time for Windows CE using the IXL API.  

The information is organized into the following sections: 

 Device Characteristics 

 Link Characteristics 

 Driver Characteristics 

Device Characteristics 

To establish serial communication, you must use devices with the following specifications:  

 Manufacturer: FlashPoint 

 Compatible Equipment: WinCE device or Win2K/XP PC compatible with FlashPoint ControlView 

For a list of the devices used for conformance testing, see “Conformance Testing” on page 4. 

Link Characteristics 

To establish serial communication, you must use links with the following specifications: 

 Device Communication Port: Ethernet adapter 

 Physical Protocol: TCP/IP over Ethernet 

 Logic Protocol: Proprietary  

 Device Runtime Software: FlashPoint ControlView runtime 

 Specific PC Board: None 

 Link cable scheme: Ethernet cable 

 

 Tip:  

Please refer to the “Conformance Testing” section to see the equipment used in the standard conformance 
tests for this driver. 

Driver Characteristics 

The FPACV driver is composed of the following files: 

 FPACV.INI: Internal driver file. You must not modify this file. 

 FPACV.MSG: Internal driver file containing error messages for each error code. You must not modify this file.  

 FPACV.PDF: Document providing detailed information about the driver. 

 FPACV.DLL: Compiled driver. 

 Notes:  

 All of the preceding files are installed in the /DRV subdirectory of the Studio installation directory.  

 You must use Adobe Acrobat® Reader™ (provided on the Studio installation CD-ROM) to view the 
FPACV.PDF document. 
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You can use the FPACV driver on the following operating systems:  

 Windows NT/2000/XP 

 Windows CE (ARM) 

For a list of the operating systems used for conformance testing, see the “Conformance Testing” section. 

The FPACV driver supports communication with the tags configured in FlashPoint ControlView. 

Conformance Testing 

The following hardware/software was used for conformance testing: 

 Equipment: Windows CE HMI with Arm processor, Pentium with Windows 2000/NT/XP 

 Cable: Use specifications described in the “Link Characteristics” section 

 Configuration: FlashPoint ControlView standard project linked locally (host system driver) or remotely via TCP/IP 

 Operating System (development): Windows NT/2000/XP  

 Operating System (target):  

– Windows NT/2000/XP 

– Windows CE v3.00 

 Studio Version: 5.1 

 Driver Version: 1.00 
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Installing the Driver 

When you install Studio version 5.1 or higher, all of the communication drivers are installed automatically.  

You must select the driver that is appropriate for the application you are using. 

Perform the following steps to select the driver from within the application: 

1. Open Studio from the Start menu.  

2. From the Studio main menu bar, select File → Open Project to open your application. 

3. Select Insert → Driver from the main menu bar to open the Communication Drivers dialog.  

4. Select the FPACV driver from the Available Drivers list, and then click the Select button. 

5. When the FPACV driver displays in the Selected drivers list, click the OK button to close the dialog. 

 

Communication Drivers Dialog 

Other Software Requirements 

You must: 

1. Install the FlashPoint ControlView (IsaGraf.exe, IsaIXD.exe, IsaRSI.exe, IsaVM.exe). The symbols file 

(generated by the FlashPoint ControlView Workbench when the target is downloaded) must be in the same folder. 

2. Copy the files “IsaIXL.dll” and “IsaSys.dll” to the \Bin sub-folder of Studio. 

3. Copy the symbols file to the \Bin sub-folder of Studio, or set the path of the file at the Header field of the Driver 

worksheet. 

 

 AttentionFor safety reasons, you must use special precautions when installing the physical hardware. Consult 
the hardware manufacturer’s documentation for specific instructions in this area. 
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Configuring the Device 

FlashPoint ControlView software should be used to configure the PC-Based Control application. Refer the 
manufacturer’s documentation for further details. 

Configuring the Driver  

After opening Studio and selecting the FPACV driver, you must configure the driver. Configuring the driver is done in 

two parts: 

 Specifying settings or communication parameters (there is only one configuration to the driver). 

 Defining communication tags and controls in the Communication tables or Driver worksheet. There are two types 

of communication tables: STANDARD TABLES and the MAIN DRIVER SHEET. This driver version uses only the 

Standard Tables. 

Worksheets are divided into two sections, a Header and a Body. The fields contained in these two sections are 

standard for all communications drivers — except the Station, Header, and Address fields, which are driver-specific. 

This document explains how to configure the Station, Header, and Address fields only. 

 Note:    

For a detailed description of the Studio Standard and Main Driver worksheets, and information about 
configuring the standard fields, review the product’s Technical Reference Manual.  

Setting the Communication Parameters 

Use the following steps to configure the Communication parameters, which are valid for all driver worksheets 
configured in the system): 

1. From the Studio development environment, select the Comm tab located below the Workspace. 

2. Click on the Drivers folder in the Workspace to expand the folder. 

3. Right-click on the FPACV subfolder and when the pop-up menu displays, select the Settings option. 

 

Select Settings from the Pop-Up Menu 
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The FPACV: Communications Parameters dialog displays: 

 

FPACV: Communication Parameters Dialog 

4. Specify the parameters as noted in the following table: 

 Parameter Default Value Valid values Description 

Driver Type HSD HSD - ETCP HSD – client with host system driver 

ETCP – implements the TCP/IP protocol, and acts as 
a server 

 

Configuring the Standard Driver Worksheet 

This section explains how to configure a Standard Driver Worksheet (or communication table) to associate application 

tags with the PLC addresses. You can configure multiple Driver Worksheets — each of which is divided into a Header 

and Body section.  

Use the following steps to create a new Standard Driver Worksheet: 

1. From the Studio development environment, select the Comm tab, located below the Workspace pane. 

2. In the Workspace pane, expand the Drivers folder and right-click the FPACV subfolder.  

3. When the pop-up menu displays, select the Insert option. 

 

Inserting a New Worksheet 
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 Note:  

To optimize communication and ensure better system performance, you must tie the tags in different driver 
worksheets to the events that trigger communication between each tag group and the period in which each 
tag group must be read or written. Also, we recommend configuring the communication addresses in 
sequential blocks to improve performance. 

 

The <drivername>.drv dialog displays: 

 

FPACV Driver Worksheet 
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Configuring the Station and Header 

The following table lists all of the data types and address ranges that are valid for the Header field.  
 

Parameter 
Default 
Value 

Valid values Description 

Station – 
1 to 255 or a valid  

IP Address: 1 to 255 

If Driver Type is set as HSD: FlashPoint ControlView Resource Number. 

If Driver Type is set as ETCP: IP Address:Resource Number of the computer where 
FlashPoint ControlView is running. 

Header – – 
Path and name of the symbols file. The symbols file is generated by FlashPoint 
ControlView when the target is downloaded. 

 

Configuring the Address 

The body of the driver worksheet allows you to associate each tag to its respective address in the device. In the Tag 

Name column, you must type the tag from your application database.  This tag will receive or send values from or to an 

address on the device. The address cells should be filled with FlashPoint ControlView Run-Time tag names configured 

on its workbench. 
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Executing the Driver 

After adding the FPACV driver to a project, Studio sets the project to execute the driver automatically when you start 

the Runtime Environment.  

To verify that the driver run-time task is enabled and will start correctly, perform the following steps: 

1. Select Project → Status from the main menu bar. 

The Project Status dialog displays: 

 

Project Status Dialog 

2. Verify that the Driver Runtime task is set to Automatic. 

– If the setting is correct, click OK to close the dialog.  

– If the Driver Runtime task is set to Manual, select the Driver Runtime line. When the Startup button becomes active, 

click the button to toggle the Startup mode to Automatic.  

3. Click OK to close the Project Status dialog.  

4. Start the application to run the driver. 
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Troubleshooting 

After each attempt to communicate using this driver, the tag configured in the field Read Status or Write Status will 
receive the error code regarding the kind of failure that occurred. The error messages are: 
 

Error Code Description Possible causes Procedure to solve 

0 OK Communication without problems None 

2 Invalid Station Typed an IP Address:resource at the 
station field when the driver type is ETCP, 
or typed only the resource number when 
the driver type is HSD. 

See “Configuring the Station and Header” for some 
samples of valid Station. 

3 Invalid Address The address field is empty. Use workbench to check the tag and create it if 
necessary. 

4 Invalid Connection If the driver type is HSD, wrong station 
number. 

If the driver type is ETCP, wrong IP 
Address. 

Use the workbench to check the resource number and IP 
Address is correct. 

5 Driver Type Driver type must be HSD or ETCP. Check that the driver type is typed correctly. 

6 Couldn’t load symbol table Couldn’t find the symbols file. Check that the path and the name of the symbols file is 
typed correctly, or that it is placed in the correct folder. 

7 Resource Info Invalid resource number. Check that the station field is filled with a valid resource 
number. 

8 Error check CRC Protocol error. Contact your Studio technical support representative. 

9 Symbol table does not match The symbol table changed after you started 
the driver. 

Download the symbol table to the target again, and 
check the name of the symbols file is typed correctly, or 
that it is placed in the correct folder. 

10 Error getting info from name Typed the tag incorrectly. Check the tag name. 

11 Error read Protocol error. Contact your Studio technical support representative. 

12 Error writing Protocol error. Contact your Studio technical support representative. 

13 Error start dialog Protocol error. Contact your Studio technical support representative. 

14 Error get resource Protocol error. Contact your Studio technical support representative. 

 

 Tip:  

You can verify communication status using the Studio development environment Output window (LogWin module). 
To establish an event log for Field Read Commands, Field Write Commands, and Serial Communication, right-click in the 
Output window. When the pop-up menu displays, select the option to set the log events. If you are testing a 
Windows CE target, you can enable the log at the unit (Tools → Logwin) and verify the celog.txt file created at 

the target unit.  

 

If you are unable to establish communication with the PLC, try to establish communication between the PLC 

Programming Tool and the PLC. Quite frequently, communication is not possible because you have a hardware or 

cable problem, or a PLC configuration error. After successfully establishing communication between the device’s 

Programming Tool and the PLC, you can retest the supervisory driver. 

To test communication with Studio, we recommend using the sample application provided rather than your new 

application. 

If you must contact us for technical support, please have the following information available: 

 Operating System (type and version): To find this information, select Tools → System Information.  
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 Project Information: To find this information, select Project → Status. 

 Driver Version and Communication Log: Displays in the Studio Output window when the driver is running. 

 Device Model and Boards: Consult the hardware manufacturer’s documentation for this information. 
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Application Sample 

You will find a sample application in the /COMMUNICATION EXAMPLES/FPACV directory. We strongly recommend 

that you use this sample application to test the FPACV driver before configuring your own customized application, for 

the following reasons: 

 To better understand the information provided in the “Installing the Driver” section of this document. 

 To verify that your configuration is working satisfactorily. 

 To certify that the hardware used in the test (device, adapter, cable, and PC) is working satisfactorily before you 

start configuring your own, customized applications. 

 

Note:  

This application sample is not available for all drivers.  

 

Use the following procedure to perform the test: 

1. Configure the device’s communication parameters using the manufacturer’s documentation. 

2. Open and execute the sample application. 

3. Execute the Viewer module in Studio to display information about the driver communication. 

 Tip:  

You can use the sample application screen as the maintenance screen for your custom applications.  

Revision History  

Revision Version By Date Description of changes 

A 1.00 Lidiane A. Moreira 17-Aug-2003  First driver version 

B 1.01 Lidiane A. Moreira 18-Aug-2003  Changed log infomation 

 


