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CATIU Communication Driver  

CAT-ISO Warehouse Systems 
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Introduction 

The CATIU driver enables communication between the Studio and 3S controllers through the CAT-ISO protocol 
over UDP/IP. Acting as a slave, receiving from all 3s controllers and staying with the last message received from 
each 3S controller. 

This document will help you to select, configure and execute the CATIU driver, and it is organized as follows: 

 Introduction: This section, which provides an overview of the document. 

 General Information: Identifies all of the hardware and software components required to implement 
communication between the Studio system and the target device.  

 Selecting the Driver: Explains how to select the CATIU driver in the Studio system. 

 Configuring the Driver: Explains how to configure the CATIU driver in the Studio system, including how to 
associate database tags with device registers. 

 Executing the Driver: Explains how to execute the CATIU driver during application runtime. 

 Troubleshooting: Lists the most common errors for this driver, their probable causes, and basic procedures 
to resolve them. 

 Sample Application: Explains how to use a sample application to test the CATIU driver configuration 

 Revision History: Provides a log of all changes made to the driver and this documentation. 

 

 Notes: 
 This document assumes that you have read the “Development Environment” chapter in Studio’s Technical 

Reference Manual. 

 This document also assumes that you are familiar with the Microsoft Windows XP/Vista/7 environment. If 
you are not familiar with Windows, then we suggest using the Help feature (available from the Windows 
desktop Start menu) as you work through this guide.  
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General Information 

This chapter identifies all of the hardware and software components required to implement communication 
between the CATIU driver in Studio and remote devices.  

The information is organized into the following sections: 

 Device Specifications 

 Network Specifications 

 Driver Characteristics 

 Conformance Testing 

Device Specifications 

You can use this driver to communicate with any device using a simple ASCII protocol. (The devices used for 
conformance testing are listed on the next page.) 

Network Specifications 

To establish communication, your device network must meet the following specifications: 

 Device Communication Port: Ethernet port 

 Physical Protocol: Ethernet - UDP/IP 

 Logic Protocol: CAT-ISO - ASCII 

 Device Runtime Software: None 

 Specific PC Board: None 

 Adapters/Converters: None 

 Cable Wiring Scheme: None 

Driver Characteristics 

The CATIU driver package consists of the following files, which are automatically installed in the \DRV 

subdirectory of Studio: 

 CATIU.INI: Internal driver file. You must not modify this file. 

 CATIU.MSG: Internal driver file containing error messages for each error code. You must not modify this 

file.  
 CATIU.PDF: This document, which provides detailed information about the CATIU driver. 

 CATIU.DLL: Compiled driver. 

 

 Note: 

You must use Adobe Acrobat® Reader™ to view the CATIU.PDF document. You can install Acrobat Reader 

from the Studio installation CD, or you can download it from Adobe’s Web site.  

 

You can use the CATIU driver on the following operating systems:  

 Windows NT/2000/XP/Vista 

 Windows CE 4.x, 5.x, 6.x 

For a description of the operating systems used to test driver conformance, see “Conformance Testing” below. 
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Conformance Testing 

The following hardware/software was used for conformance testing: 

 Driver Configuration (a): 

– PLC Program: None 
– Baud Rate: Not used 
– Protocol: ASCII 
– Data Bits: Not used 
– Stop Bits: Not used 
– Parity: Not used 
– COM Port: Not used 
– UDP/IP Port: 1010 
– Cable: Ethernet Cable 

 

Driver 

Version 

Studio 

Version 

Operating 

System 
Equipment 

1.0 6.1+SP6 Windows XP 
– Two PCs connected with a Ethernet connection, one of them 

running the CAT_ISO-UDP Simulation software 
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Selecting the Driver 

When you install Studio, all of the communication drivers are automatically installed in the \DRV subdirectory but 

they remain dormant until manually selected for specific applications. To select the CATIU driver for your Studio 
application: 

1. From the main menu bar, select Insert Driver to open the Communication Drivers dialog.  

2. Select the CATIU driver from the Available Drivers list, and then click the Select button.  

 

Communication Drivers Dialog 

3. When the CATIU driver is displayed in the Selected Drivers list, click the OK button to close the dialog. The 
driver is added to the Drivers folder, in the Comm tab of the Workspace. 

 

 Note:  

CATIU driver is used as an server, to enable connections it is necessary to install a external software that 

uses the CATIU protocol and make it connect to Studio. 

 
 

 Attention: 
For safety reasons, you must take special precautions when installing any physical hardware. Please 
consult the manufacturer’s documentation for specific instructions. 
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Configuring the Driver  

Once you have selected the CATIU driver in Studio, you must properly configure it to communicate with your 
target device.  

Configuring the Communication Settings 

The communication settings are described in detail in the “Communication” chapter of the Studio Technical 
Reference Manual, and the same general procedures are used for all drivers. Please review those procedures 
before continuing. 

For the purposes of this document, only CATIU driver-specific settings and procedures will be discussed here. To 
configure the communication settings for the CATIU driver: 

1. In the Workspace pane, select the Comm tab and then expand the Drivers folder. The CATIU driver is 
listed here as a subfolder. 

2. Right-click on the CATIU subfolder and then select the Settings option from the pop-up menu. The CATIU: 
Communication Parameters dialog is displayed: 

   

 Select Settings from the Pop-Up Menu CATIU: Communication Parameters Dialog 
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3. Configure the additional driver-specific settings, as described in the following table: 

 

Setting Default Value Valid Values Description 

UDP Port 1010 Integer value 
UDP port number used to receive messages from other 
3S controllers. 

 
 
 
 
 

4. Click OK to close the Communication Settings dialog. 

Configuring the Driver Worksheets 

A selected driver includes one or more driver worksheets, which are used to associate database tags in Studio 
with operands on the target device. Each worksheet is triggered by specific application behavior, so that the tags / 
operands defined on that worksheet are scanned only when necessary – that is, only when the application is 
doing something that requires reading from or writing to those specific tags / operands. Doing this optimizes 
communication and improves system performance. 

The configuration of these worksheets is described in detail in the “Communication” chapter of the Studio 
Technical Reference Manual, and the same general procedures are used for all drivers. Please review those 
procedures before continuing. 

To insert a new driver worksheet: 

1. In the Comm tab, open the Drivers folder and locate the CATIU subfolder. 

2. Right-click on the CATIU subfolder, and then select Insert from the pop-up menu: 

 

Inserting a New Worksheet 

A new CATIU driver worksheet is inserted into the CATIU subfolder, and the worksheet is opened for 
configuration: 
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CATIU Driver Worksheet 

 

 Note: 

Worksheets are numbered in order of creation, so the first worksheet is CATIU001.drv. 

 

Most of the fields on this worksheet are standard for all drivers; see the “Communication” chapter of the 
Technical Reference Manual for more information on configuring these fields. However Header, and 
Address fields use syntax that is specific to the CATIU driver. 

3. Configure the Header fields as follows: 

 Station field (not used) 

 Header field: Define the specific building for sending the door status 

Type of Header: 

 U:<Unsolicited Message> : Specify the number of the byte to read. 

 

 Note:  
Station is used for specifying the 3S node number that will be received. 

 

 
 
 
 
 
 
 
 

Header 

Body 
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 Sample of configuration 

 

 

 

 

 
 
 
 

 

Sample of configuration 

 

 Note:  
This example read at each second 

 

Header Field  Address Field  

U 1 

U 10 

U 142 

U 999 
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Executing the Driver  

By default, Studio will automatically execute your selected communication driver(s) during application runtime. 

However, you may verify your application’s runtime execution settings by checking the Project Status dialog. 

To verify that the communication driver(s) will execute correctly: 

1. From the main menu bar, select Project → Status. The Project Status dialog displays: 

 

Project Status Dialog 

2. Verify that the Driver Runtime task is set to Automatic. 

 If the setting is correct, then proceed to step 3 below. 

 If the Driver Runtime task is set to Manual, then select the task and click the Startup button to toggle the 
task’s Startup mode to Automatic.  

3. Click OK to close the Project Status dialog.  

4. Start the application to run the driver. 
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Troubleshooting 

If the CATIU driver fails to communicate with the target device, then the database tag(s) that you configured for 
the Read Status or Write Status fields of the Standard Driver Sheet will receive an error code. Use this error code 
and the following table to identify what kind of failure occurred. 

 

Error Code Description Possible Causes Procedure to Solve 

0 OK Communicating without  problems Not required 

11 No connection No client connected 
Make a connection with the client, check the port 
configuration on the client and on Studio. 

 
 

 Tip:  

You can monitor communication status by establishing an event log in Studio’s Output window (LogWin 

module). To establish a log for Field Read Commands, Field Write Commands and Protocol Analizer, right-click in 

the Output window and select the desired options from the pop-up menu. 

You can also use the LogWin module (Tools  LogWin) to establish an event log on a remote unit that runs 

Windows CE. The log is saved on the unit in the celog.txt file, which can be downloaded later. 

 

If you are unable to establish communication between Studio and the target device, then try instead to establish 
communication using the device’s own programming software. Quite often, communication is interrupted by a 
hardware or cable problem or by a device configuration error. If you can successfully communicate using the 
programming software, then recheck the driver’s communication settings in Studio. 

If you must contact us for technical support, please have the following information available: 

 Operating System (type and version): To find this information, select Tools → System Information.  

 Project Information: To find this information, select Project → Status. 

 Driver Version and Communication Log: Displays in the Studio Output window when the driver is running. 

 Device Model and Boards: Consult the hardware manufacturer’s documentation for this information. 
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Sample Application 

A sample application that employs the CATIU driver is provided on the Studio installation CD. We strongly 
recommend that you use this sample application to test the driver before you develop your own applications, for 
the following reasons: 

 To better understand the information and instructions provided in this document; 

 To verify that your driver configuration is working satisfactorily with the target device; and 

 To ensure that the all of hardware used in the test (i.e. the device, adapter, cable, and PC) is functioning 
safely and correctly. 

 

Note:  

The following instructions assume that you are familiar with developing project applications in Studio. If you 

are not, then please review the relevant chapters of the Studio Technical Reference Manual before 

proceeding. 

 

To use the sample application: 

1. Configure the device’s communication settings according to the manufacturer’s documentation. 

2. Run Studio. 

3. From the main menu bar, select File  Open Project. 

4. Insert the Studio installation CD and browse it to find the sample application. It should be located in the 
directory \COMMUNICATION EXAMPLES\CATIU. 

5. Select and open the sample application. 

6. Configure and test the driver, as described in the rest of this document. 

When you have thoroughly tested the driver with your target device, you may proceed with developing your own 
Studio application projects. 

 

 Tip:  

You can use the sample application screen as the maintenance screen for your own applications.  
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Revision History  
 

Doc. 
Revision 

Driver 
Version 

Author Date Description of Changes 

A 1.00 Paulo R. Balbino 3 Feb 2010 Initial version 

 


