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Introduction 

The AWID driver enables read only communication between the Studio system and devices using the AWID RFID 
TCP/IP Interface’s Protocol (RTIP), according to the specifications discussed in this document.  

This document will help you to select, configure and execute the AWID driver, and it is organized as follows: 

 Introduction: This section, which provides an overview of the document. 

 General Information: Identifies all of the hardware and software components required to implement 
communication between the Studio system and the target device.  

 Selecting the Driver: Explains how to select the AWID driver in the Studio system. 

 Configuring the Device: Describes how the target device must be configured to receive communication from 
the AWID driver. 

 Configuring the Driver: Explains how to configure the AWID driver in the Studio system, including how to 
associate database tags with device registers. 

 Executing the Driver: Explains how to execute the AWID driver during application runtime. 

 Troubleshooting: Lists the most common errors for this driver, their probable causes, and basic procedures 
to resolve them. 

 Sample Application: Explains how to use a sample application to test the AWID driver configuration 

 Revision History: Provides a log of all changes made to the driver and this documentation. 

 

 Notes: 
 This document assumes that you have read the “Development Environment” chapter in Studio Technical 

Reference Manual. 

 This document also assumes that you are familiar with the Microsoft Windows 2000/XP/Vista environment. 
If you are not familiar with Windows, then we suggest using the Help feature (available from the Windows 
desktop Start menu) as you work through this guide.  
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General Information 

This chapter identifies all of the hardware and software components required to implement communication 
between the AWID driver in Studio and a target device using the RTIP over TCP/IP.  

The information is organized into the following sections: 

 Device Specifications 

 Network Specifications 

 Driver Characteristics 

 Conformance Testing 

Device Specifications 

To establish communication, your target device must meet the following specifications: 

 Manufacturer: AWID(or any device using the RTIP communicating over TCP/IP) 

 Compatible Equipment:  MPR 2010 series 

 AWID driver reads tags of the following types: 

 • ISO-18000-6 Type B (U-Code, HSL) 

 • EPC Class 1 Gen 2 

 Device Runtime Software: None 

For a description of the device(s) used to test driver conformance, see “Conformance Testing” on the next page. 

Network Specifications 

To establish communication, your device network must meet the following specifications: 

 Device Communication Port: Ethernet Port 

 Physical Protocol: Ethernet/TCP-IP 

 Logic Protocol: RTIP  

 Specific PC Board: Any TCP/IP Adapter (Ethernet board) 

Driver Characteristics 

The AWID driver package consists of the following files, which are automatically installed in the /DRV subdirectory 

of Studio: 

 AWID.INI: Internal driver file. You must not modify this file. 

 AWID.MSG: Internal driver file containing error messages for each error code. You must not modify this file.  

 AWID.PDF: This document, which provides detailed information about the AWID driver. 

 AWID.DLL: Compiled driver. 

 

 Note: 

You must use Adobe Acrobat® Reader™ to view the AWID.PDF document. You can install Acrobat Reader 

from the Studio installation CD, or you can download it from Adobe’s Web site.  
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You can use the AWID driver on the following operating systems:  

 Windows 2000/XP/Vista 

For a description of the operating systems used to test driver conformance, see “Conformance Testing” 
below. 

 

Conformance Testing 

The following hardware/software was used for conformance testing: 

 Driver Configuration: 

– Operation System (development): Windows XP SP2 

– Operation System (target): Windows XP  

– Studio Version: 6.1 SP4 

– Driver Version:  1.00 

– Cable: Ethernet Cable 
 
 

Driver 

Version 

Studio 

Version 

Operating 

System 

(development) 

Operating 

System 

(runtime) 

Equipment 

1.00 6.1 + SP4 Win XP + SP2  Win XP+SP2  MPR 1020 BN 
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Selecting the Driver 

When you install Studio, all of the communication drivers are automatically installed in the \DRV subdirectory but 

they remain dormant until manually selected for specific applications. To select the AWID driver for your Studio 
application: 

1. From the main menu bar, select Insert Driver to open the Communication Drivers dialog.  

2. Select the AWID driver from the Available Drivers list, and then click the Select button.  

 

Communication Drivers Dialog 

 

3. When the AWID driver is displayed in the Selected Drivers list, click the OK button to close the dialog. The 
driver is added to the Drivers folder, in the Comm tab of the Workspace. 

 

 Note: 
It is not necessary to install any other software on your computer to enable communication between Studio 
and your target device. However, this communication can only be used by the Studio application; it cannot 
be used to download control logic to the device.  

 
 

 Attention: 
For safety reasons, you must take special precautions when installing any physical hardware. Please 
consult the manufacturer’s documentation for specific instructions. 
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Configuring the Device 

Once the selected driver and the target device are both properly configured, it is not necessary to install any other 
software on your computer to enable communication between the host and the device. All runtime communication 
is handled within your Studio application project. However, programming the device itself — that is, developing 
control logic and downloading it to the device — still requires using the device’s own programming tool. 

Configuring the Driver  

Once you have selected the AWID driver in Studio, you must properly configure it to communicate with your target 
device. First, you must set the driver’s communication settings to match the parameters set on the device. Then, 
you must build driver worksheets to associate database tags in your Studio application with the appropriate 
addresses (registers) on the device. 

Configuring the Communication Settings 

The communication settings are described in detail in the “Communication” chapter of the Studio Technical 
Reference Manual, and the same general procedures are used for all drivers. Please review those procedures 
before continuing. 

For the purposes of this document, only AWID driver-specific settings and procedures will be discussed here. To 
configure the communication settings for the AWID driver: 

1. In the Workspace pane, select the Comm tab and then expand the Drivers folder. The AWID driver is 
listed here as a subfolder. 

2. Right-click on the AWID subfolder and then select the Settings option from the pop-up menu: 

 

Select Settings from the Pop-Up Menu 
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The AWID: Communication Settings dialog is displayed: 

 

AWID: Communication Settings Dialog 
 

3. In the Communication Settings dialog, configure the driver settings to enable communication with your 
target device. To ensure error-free communication, the driver settings must exactly match the 
corresponding settings on the device. Please consult the manufacturer’s documentation for instructions 
how to configure the device and for complete descriptions of the settings. 

Depending on your circumstances, you may need to configure the driver before you have configured your 
target device. If this is the case, then take note of the driver settings and have them ready when you later 
configure the device. 

 

Attention: 

For safety reasons, you must take special precautions when connecting and configuring new 

equipment. Please consult the manufacturer’s documentation for specific instructions. 
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Advanced Settings Dialog 

 
 
 

You do not need to change any other advanced settings at this time. You can consult the Studio 
Technical Reference Manual later for more information about configuring these settings. 

4. Click OK to close the Advanced Settings dialog, and then click OK to close the Communication Settings 

dialog. 
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Configuring the Driver Worksheets 

Each selected driver includes a one or more Standard Driver Worksheets.  Standard Driver Worksheets can be 
inserted to define additional tag/register associations that are triggered by specific application behaviors. 

The configuration of these worksheets is described in detail in the “Communication” chapter of the Studio 
Technical Reference Manual, and the same general procedures are used for all drivers. Please review those 
procedures before continuing. 

For the purposes of this document, only AWID driver-specific parameters and procedures are discussed here. 



AWID – Driver Version 1.01 

Doc. Revision C – March 31, 2008 

 

Page 10/16 

STANDARD DRIVER WORKSHEET 

When you select the AWID driver, you may insert Standard Driver Worksheets to define tag/register associations 
that are triggered by specific application behaviors. Doing this will optimize communication and improve system 
performance by ensuring that tags/registers are scanned only when necessary – that is, only when the application 
is performing an action that requires reading or writing to those specific tags/registers. 

 

To insert a new Standard Driver Worksheet: 

1. In the Comm tab, open the Drivers folder and locate the AWID subfolder. 

2. Right-click on the AWID subfolder, and then select Insert from the pop-up menu: 

 

Inserting a New Worksheet 

A new AWID driver worksheet is inserted into the AWID subfolder, and the worksheet is opened for 
configuration: 

 

AWID Driver Worksheet 

 
 

Most of the fields on this worksheet are standard for all drivers; see the “Communication” chapter of the 
Technical Reference Manual for more information on configuring these fields. However, the Station, 
Header, and Address fields use syntax that is specific to the AWID driver. 

 

Header 

Body 
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3. Configure the Station and Header fields as follows: 

 Station field: Specify the IP Address of the device and the slot number, using the following syntax: 

<IP Address>:[Port Number] 

Example — 192.168.125.31:4000 

Where: 

– <IP Address> is the device’s IP address on the TCP/IP network; 

– [Port Number] is the port number for the AWID TCP protocol. This is an optional parameter. If 

the parameter is omitted, then the driver assumes 4000;  

You can also specify an indirect tag (e.g. {station}), but the tag that is referenced must follow the 

same syntax and contain a valid value. 

 

Attention:  

• You must use a non-zero value in the Station field, and you cannot leave the field blank. 

 

 

 Header field: Specify the Type of RFID tag to be read by the work sheet with an optional try times 
preceded by a colon. 

The Header field uses the following syntax: 

<Type>:[TryTimes] 

Example — GEN2:30 

Where: 

– <Type> is the RFID tag type (GEN2 or ISOB). 

– [TryTimes] is the initial address (reference) of the configured type. This is an optional 

parameter. If this parameter is omitted, then the driver assumes 50. 

 

After you edit the Header field, Studio checks the syntax to determine if it is valid. If the syntax is 

invalid, then Studio automatically inserts a default value of GEN2 

You can also specify an indirect tag (e.g. {RFIDTag}), but the tag that is referenced must follow the 

same syntax and contain a valid value. 
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 Address field: For each table row (i.e., each tag/register association), configure the Address field using 
DATA, BIN, STATE, SITE or ID.   

 
 

Address Tag Type Description 

DATA String ASCII interpretation of the data 

BIN String Binary data converted to Hexadecimal  

STATE Boolean 1 if an RFID tag is present.0 if the RFID is not present. 

SITE Integer Wiegand interpretation of the Site data 

ID Integer Wiegand interpretation of the ID data 

  

Attentions:  

 Reading from the DATA row information that is not ASCII formatted can cause the data to be truncated 

 Configuring too many address rows will return an Invalid Block Size error. 

 

 Note: 
 

 SITE and ID data are Wiegand format interpretations of the data using Wiegand 26 bit format left 

justified within the data packet. 

 
 
 
 
 
 
 


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Executing the Driver  

By default, Studio will automatically execute your selected communication driver(s) during application runtime. 

However, you may verify your application’s runtime execution settings by checking the Project Status dialog. 

To verify that the communication driver(s) will execute correctly: 

1. From the main menu bar, select Project → Status. The Project Status dialog displays: 

 

Project Status Dialog 

2. Verify that the Driver Runtime task is set to Automatic. 

 If the setting is correct, then proceed to step 3 below. 

 If the Driver Runtime task is set to Manual, then select the task and click the Startup button to toggle the 
task’s Startup mode to Automatic.  

3. Click OK to close the Project Status dialog.  

4. Start the application to run the driver. 
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Troubleshooting 

If the AWID driver fails to communicate with the target device, then the database tag(s) that you configured for the 
Read Status or Write Status fields of the Driver Sheet will receive an error code. Use this error code and the following 
table to identify what kind of failure occurred. 

 

Error Code Description Possible Causes Procedure to Solve 

0 OK Communication without problems None required 

1 Invalid Protocol The message received is out  of specification for the 
protocol  

The device may not be compatible of may require a 
different firmware version  

2 Invalid Command The device did not receive the command properly The device may not be compatible of may require a 
different firmware version 
The connection may have excessive noise 

 

3 Invalid Block Size The data sent by AWID device is too long  Check the worksheet body configuration 

4 Error Connecting The driver is unable to create a connection to the device  Check the cabling 
 Check the IP address and port are correct 
 Ping the device 

1005 Timeout Error The time answer from the equipment was higher than the 
expected. 

Check cable wiring. 
Check the PLC state – it must be RUN. 
Check the configuration. 
Check the configuration. See Studio Technical 
Reference Manual for information about valid RTS/CTS 
configurations. 

 
 

 Tip:  

You can monitor communication status by establishing an event log in Studio’s Output window (LogWin 

module). To establish a log for Field Read Commands, Field Write Commands and Serial Communication, right-click 

in the Output window and select the desired options from the pop-up menu. 

You can also use the LogWin module (Tools  LogWin) to establish an event log on a remote unit that runs 
Windows CE. The log is saved on the unit in the celog.txt file, which can be downloaded later. 

 

If you are unable to establish communication between Studio and the target device, then try instead to establish 
communication using the device’s own programming software.  Quite often, communication is interrupted by a 
hardware or cable problem or by a device configuration error. If you can successfully communicate using the 
programming software, then recheck the driver’s communication settings in Studio. 

To test communication between Studio and the device, we recommend using the sample application provided 
rather than your new application. 

If you must contact us for technical support, please have the following information available: 

 Operating System (type and version): To find this information, select Tools → System Information.  

 Project Information: To find this information, select Project → Status. 

 Driver Version and Communication Log: Displays in the Studio Output window when the driver is running. 

 Device Model and Boards: Consult the hardware manufacturer’s documentation for this information. 
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Sample Application 

 
There was not an official sample application available for this driver by the timer that this document was written. 
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Revision History  

Doc. 

Revision 

Driver 

Version 
Author Date Description of changes 

A 1.00 Mark Duren Feb/11/2008 Initial release 

B 1.01 Eric Vigiani Feb/15/2008 Driver revision 

C 1.01 Eric Vigiani Mar/31/2008 Doc. revision 
 


