VCE Pro Quick Start Manual

Virtual CE Pro

Quick Start Manual
[Version 4.2]

Date: Jun-17 2011 v4.2.0.9



VCE Pro Quick Start Manual 2

Warranty

All products manufactured by ICP DAS Inc. are warranted against defective
materials for a period of one year from the date of delivery to the original

purchaser.
Warning

ICP DAS Inc. assumes no liability for damages consequent to the use of this
product. ICP DAS Inc. reserves the right to change this manual at any time
without notice. The information furnished by ICP DAS Inc. is believed to be
accurate and reliable. However, no responsibility is assumed by ICP DAS Inc. for
its use, or for any infringements of patents or other rights of third parties resulting

from its use.
Copyright

Copyright 1998-2006 by ICP DAS Inc., LTD. All rights reserved worldwide.
Trademark

The names used for identification only maybe registered trademarks of their

respective companies.
License

The user can use, modify and backup this software on a single machine. The
user may not reproduce, transfer or distribute this software, or any copy, in whole

or in part.
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About This Manual

The manual is divided into four parts. The first part, ‘Introduction’, describes basic
function and infrastructure of VCEP. The second part, ‘Getting Started’, describes
installation, registration and running procedures step by step. The third part,
‘Function Overview’, describes all functions of VCEP. The fourth part, ‘Application’,
describes different VCEP scenario in different application.

1. Introduction

Manage Your WinCon From Anywhere

VCEP is designed for managing your WinPAC/XPAC anywhere. No matter
where you are, VCEP provides a convenient environment on the Desktop PC and
lets you control your WinPAC/XPAC remotely.

Virtual CE is composed of two main components: The ‘Server’ which runs on
WIiInPAC/XPAC and the ‘Client’ which runs on a Desktop PC. Once a connection is
established between the client and server (initiated by the client), the client will
periodically send requests for screen updates and send mouse/key click
information to the server to simulate. Each video frame is inter-compressed
against the previous frame and then intra-compressed with a modified LZW
scheme to minimize the amount of data transmitted from server to client.

HARDWARE REQUIREMENTS

Device Minimum Recommended
IBM compatible PC with Pentium Il Pentium IlI
Pentium processor 350 MHz 500 MHz
System RAM 64 MB 128 MB

Hard disk 100 MB free memory space

SOFTWARE REQUIREMENTS
Microsoft Windows 2000 SP2 or Windows XP
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MAIN FEATURES

VVVVVVVVY VVVVVVVYVY VVVVYY

Save compressed AVI files

Rotate the display to any angle in 90 degree increments

Screen captures saved to BMP, GIF or JPG

Copy clipboard contents to CE and back to PC

Rapid data entry from your more comfortable PC mouse and keyboard
1-18 frames per second capture speed (depending on device and
communication conduit)

Support serial, Ethernet communications

Minimal impact on target device CPU while capturing
Auto-discovery of the target device on a LAN

Works across the internet

Capture screen shots to a BMP file or the clipboard

Supports 2 + 4-bit monochrome and 8 + 16-bit color displays
Scale image 1-4X

Multiple instances of VCEP can run on the same PC allowing multiple
devices to be controlled simultaneously

One-click capture of screen shots to BMP files with auto-naming
Capture session to a standard AVI file for distribution

Capture session keys/clicks for later playback

Toggle toolbar display

Toggle 'always-on-top' window feature

Paste text from the PC clipboard to the CE device

Actively connect from Server to Client

Watchdog auditing

Record/Play script events

Date: Jun-17 2011 v4.2.0.9
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2. Getting Started
2-1 Installation

Step 1: Copy v_remote.exe and WatchVCEP.exe from CD:\\WCEP_4.2 folder to
\CompactFlash\VCEP of WinPAC/XPAC.

Step 2: Execute v_remote.exe in WinPAC/XPAC and configure it as below then

click OK. After setting password, don’t forget to press ‘Save an Reboot’
button in WinPAC/XPAC Utility.

oy %
Vintusl CE U
ILAN =]
comport: [t |+

Require a password for LAN

Password: icpdad

[~ Connect to client

Primary Client IP |6l 62.70.78 Port (1901
Secondary Clent 1p[59.125.116.157  Port [1901
Retry Cycle |5 sec.

[ Activate Watchdog

[ ]

Step 3: Execute VCEP_4.2.x.x.exe in CD:\\VCEP_4.2 folder to install VCEP
Client to Desktop PC.

e
1

=1
Virtual CE Pro Client - InstallShield Wizard

Welcome to the InstallShield Wizard for Virtual CE Pro Client

The InstallShieldR WWizard will install Yirtual CE Pro Client on your computer. To continue, click
Next.
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Step 4: After that, you will find out Virtual CE Pro Client at ‘Program File’ as below.

) Iepdas »|7) WCEP4208 ¥ [H) Uninstall Virtual CE Pro Client
| v |B] Virtoal CE Pro Client

2-2 Registration
If your VCEP version is ‘License Free Version’, please skip this section.

Step 1: Click [File]->[Register] on WIinPAC/XPAC for register as below.

Help
Configure..
Disconnect
Stop ActiveSync Virtunal CE
Register
Ezit

Step2: Enter ‘Register Code’ of License into Register dialog and press OK.
ATTENTION! One Register Code only can be used in one WinPAC/XPAC

2-3 Running
Step 1: Make sure the v_remote.exe is executed in WinPAC/XPAC

Step 2: Select “Virtual CE Pro Client” from [Start]->[DAQPro]->[VCEP_4.2] or
execute "C:\DAQPro\VCE_Pro\v_ppc.exe"

-

(=] __Virtual CEPro (=] ®
- <
File Connection Script Window Help
Connections Scripts

Mame Type

Part Status
L WA Idle

MName Status
N Tdle

4

Date: Jun-17 2011 v4.2.0.9



VCE Pro Quick Start Manual

Step 3: Configure some basic settings at [File]->[Default Settings].

-

>
(] . Default Settings | =]
: ———
Refresh Rate  |{ilifps | Scale  [1x |
© ShowSkin  Skin: | [
" 1B6-color mode (reduces data by 50%)
" Queue events [reduces LAN traffic)
@ Accept inbound connections on port:
' Screen Capture |
& File " Clipboard " One Click
Image file format [one click): BMP
' Recording Method ;
@ Scriptevents AVl video @ Show Cursor |
Scipt Dir: | C:\DAQP1oWCE_Pro\RECORD)
= =
Step 4: Create a new connection.
= . =
(=] . New Connection } - i
K arme: lWinCon-B? l Window Background Color
Connection Type: -
Target IP Address: l 0.0 .0.0 " Open Maximized
Port: I:] Refresh Rate: |10 qu'd ) Automatically connect at startup
Skin: | ) Scale: |1X " Low color mode
Screen Capture 'O Ruus Events
@ File " Clipboard " One Click
Image file format (one click): EMP ]
Recording Method f
© Script events AW video © Show Mouse Cursor
- >
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Step 5: Press ‘Connect’ button. VCEP will automatically scan the available device

within LAN.
= - = ——
g = {_Virtual CEPro_J s L=
f File Connection Script Window Help |
Cony” ® _ LAN (Auto Discovery) @ pts
 Mame 1 — e Btatus
ISR Select one or more devices to connect to
Device Name 1P Address
WindowsCE 10.0.0.67
L J >

Scanning for devices...

~Gonnect Gance]

1
D D D)

Step 6: Enter your password and press ‘OK’ button.
£ =) _ LAN (Auto Discovery) g =)

The selected device requires a password;
please enter it in the space below.

| icpdas l

" Hide Password

%

Gonnect zarncel
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Step 7: After that, you will see the screen of target device.

(=) WinCon-67 - ICPDAS Device J L

~
File Edit Tools View Help

Aae Neng@

x]
Virtual CE

Connected
LAN Ready
Prirnary IP = 10.0.0.68

Wideo=GDI

wywwy icpdas.com

#start ||V virtual ce [L 152 5 508 P @
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3. Function Overview

VCEP function is divided into three parts. The first part describes functions on
Client site. The second part describes functions on Server site. The third part
describes functions when connecting.

3-1 Functions on Client (PC)
All functions and settings at this section are on Client(PC) site.
3-1-1 Default Settings
[File]->[Default Settings]
E (=) { Pe_fag!t_Se_!!ings J & 3
- ,

Refresh Rate Scale |1x

© ShowSkin  Skin: |
16-color mode [reduces data by 50%)

Queue events [reduces LAN traffic)

@ Accept inbound connections on port: | 13901
| Screen Capture |

“ File * Clipboard ¢ One Click

Image file format [one click): BMP '

Recording Method |
© Script events AVl video @ Show Cursor

Script Dir: | C:\DAQProAWCE_ProA\RECORD

—Of

LS -

Refresh Rate: High refresh rate requires high LAN traffic. 1fps ~18fps for option
Scale: Display scale. 1x / 2x / 3x / 4x for option

16-color mode: Choosing this option can reduce data by 50%

Queue events: Choosing this option can reduce LAN traffic

Screen Capture: Choosing the method to capture screen and the format
(BMP/BMP24/GIF/JPEG) to store

Recording Method: Choosing the method (Script/AVI) to record and showing
cursor or not

Script Dir: The location to save script
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3-1-2 New Connection
[Connection]->[New]

[2 X
[&5) New Connection | (&5]

Name: iNeowneptpﬂ ‘ Window Backaround Color

Connection Type: i IRDA [ -

Target IP Address: I 0 Rl ’ Open Maximized

Port: Refresh Rate: { 10 fps Automatically connect at startup

Skin: | 10 Scale: 1% | Low color mode

Screen Capture Queue Events
@ File Clipboard One Click
Image file format [one click): ’EMP
Recording Method O
8 i | = Show Mouse Curso
Script events &Y video how Mou ursor

g &

Name: Any name

Connection Type: Choosing the type of connection (WAN / LAN / Connect From
Server)

Target Address: The IP address of Server should be entered if choosing the type
of ‘WAN’

Port: Port means IP port which is the same with server if choosing the type of
‘Connect From Server’

Refresh Rate: High refresh rate requires high LAN traffic. 1fps ~18fps for option.
Scale: Display scale. 1x / 2x / 3x / 4x for option

Windows Background Color: Windows’ background color

Open Maximized: Maximize the display when connecting

Automatically connect at startup: Connect to server automatically when startup
Low color mode: Choosing this option can reduce data by 50%

Queue Events: Choosing this option can reduce LAN traffic

Screen Capture: Choosing the method to capture screen and the format
(BMP/BMP24/GIF/JPEG) to store

Recording Method: Choosing the method (Script/AVI) to record and showing
cursor or not
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3-1-3 Connection Edit

New: See ‘3-1-2 New Connection’

Delete: Delete the connection in the list

Edit: Edit old connection. See ‘3-1-2 New Connection’
Connect: Start connecting to WinPAC/XPAC

3-1-4 New Scenario
[Script]->[New]

¥ B

(=] _ New Scenario } -
( :

INEW enara I
| Log Results | l

Scenario Loop Count: |1 Loop Delay [seconds): D
o

| Script Loop Count:

Scenario Name:

Script Loop Delay:

Suspend device when complete

_ . | e |
. Reset device when complete

" Disable video update (e.q. slow connection]

:

= J

Scenario Name: Any name

Log Results: Log the results of scenario operating

Scenario Loop Count: The times of playing scenario

Loop Delay: The delay time between scenario and scenario

Add: Add a script

Remove: remove a script

Up: push a script up

Down: pull a script down

Script Loop Count: The times of playing scripts in scenario:

Script Loop Delay: The delay time between script and script in scenario
Disable video update: No update on Client site for reducing traffic load
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3-1-5 Script Edit

T G

New: See ‘3-1-4 New Scenario’

Edit: See ‘3-1-4 New Scenario’

Delete: Delete the scenario in the list
Play/Pause: Play/Pause the scenario in the list
Stop: Stop playing the scenario in the list

3-1-6 About
[Help]->[About VCE...] Show version message.

v . B
&  About Virtual CE [S]

7

| Virtual CE Pro

Version 4.2
Copyright (c] 2006 ICP DAS Inc.

Built: Oct 3 2006

%
: -
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3-2 Functions on Server (WinPAC/XPAC)

All functions and settings at this section are on WinPAC/XPAC.
3-2-1 Configure
[File]->[Configure...]

|LAN E

COM Port: | Copal,

IZ! Require a password for LAN

Password: icpdas

D Connect to client

Primary Client IP [61.62.70.78 Port [1901

Secondary Client P [59.125.116.157  Part {1901

Retry Cycle |5 sec.

Connection Type: Choosing an appropriate ‘Connection Type’ (LAN / WAN)
depends on WIinPAC/XPAC's real situation

COM Port: COM port number if choosing connection type of ‘Serial’

Require a password for LAN: Password for Ethernet connection from Client
Connect to client: When WIinPAC/XPAC is in LAN and Client is in WAN with
public IP, you can check this and assign two Client IP for active connection from
WInPAC/XPAC. If the first Client IP can not be connected to, VCEP will connect to
second Client IP automatically. If the connection of the first Client IP restore, you
have to disconnect the second connection manually to connect to the first one.
The ‘Retry Cycle’ means the time between two connections

Active Watchdog: This function can let VCEP restore automatically if VCEP
crash for un-known reason
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3-2-2 Disconnect

[File]->[Disconnect] Disconnect the connection from server site.

File
Disconnect

Stop ActiveSync
Register

Exit

3-2-3 Register

[File]->[Register] Register dialog for registration. If you don’t register, VCEP

works under trial version of 5 minutes.

3-2-4 About
[Help]->[About...] Show version message.

Version 4.2

W icpdas.com

Copyright (c) 2006 ICP DAS, Inc.

About Virtual CE Pro

3-3 Functions when Connecting

When connecting, you can see some functions upper the window. These

function descriptions are as below.

File Edit Tools Yiew

A@e Neng@®
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3-3-1 Configure
[File]->[Configure...] See ‘3-1-1 Default Settings’

pre ™
=) . Configure (=)
- x_—)_ =
Refresh Rate Scale |1z |©
® ShowSkin  Skin: | ®

" 16-color mode [reduces data by 50%)

" Queue events [reduces LAN traffic)

) Accept inbound connections on port: l:

' Screen Capture |
& File " Clipboard " One Click
Image file format [one click]: BMP
' Recording Method j
@ Scriptevents AVl video  Show Cursor

Script Dir: I |
Cance
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3-3-2 File Explorer
[File]->[File Explorer]

= =9
- JCE Eila ExploracJCRDAS Device_d 1
>
My Computer v | Name v o> |Mv Device ¥ | Name ¥
Mame Size Date Mame Size Date
wC) . | (£ CompactFlash
@D\ [E23My Documents
CAFA 2 Il:ﬁNetwark
<R\ [y profiles
[E3)Programs
q-? [E3)Program Files
[ Recycled
X | [E) Temp
) Windows
? | [ Control Panel Ink 238
@ DCONCE.dlL 100.0K
(=) Wineon a1 52.0K
= =

Left side of window shows the file tree on PC. Right side of window shows the file
tree on WIinPAC/XPAC. You can transfer files by clicking the buttons between two
windows.

3-3-3 Edit
[Edit]
Edit Tools ¥iew
Paste to device
Capture to Clipboard
Capture to File...
Capture (One Click)

Paste to device: This function allows you paste text from PC to WinPAC/XPAC
Capture to Clipboard: Capture the screen and save it into clipboard. After
capturing to clipboard, you can paste the image to any application program
Capture to File...: Capture the screen and save in file

Capture (One Click): Capture the screen to be file in ‘Script Dir’ folder
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3-3-4 Tools
[Tools]
Tools ¥iew
Start Recording
Stop Recording
Soft Reset
Suspend

Start Recording: Start recording according to the settings in ‘3-1-1 Default
Settings’

Stop Recording: Stop recording according to the settings in ‘3-1-1 Default
Settings’

Soft Reset: Soft-reset WinPAC/XPAC

3-3-5 View
[View]
View
i« Device Info...
Process Info...

Connection Status

Refresh Display
Scale 4
Rotate 4
Togzele Skin

Togzle Flip State

Device Info...: Show WinPAC/XPAC information

Process Info...: Show process information of WinPAC/XPAC
Refresh Display: Refresh display once when using this function
Scale: Change the display scale (1x / 2x / 3x / 4x)

Rotate: Rotate display (0O° /90° /180° /270° )

4. Application

This section describes how to set VCEP in different scenario step by step.
4-1 General Remote Control from Client

Generally speaking, VCEP will be applied when PC and WIinPAC/XPAC are
all in LAN (See Figure 1) or in WAN (See Figure 2). This section highlights some
important settings and reminds you of functions in common use.
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Private IP:

10.0.0.103

Private IP:
10.0.0.102

Public IP:
31.32.7.11

Public IP:
61.62.5.40

Private IP: Public IP:
10.0.0.100 59.125.116.158
Figure 1 Figure 2

Step 1: Refer to ‘2-2 Running’ and connect PC and WInPAC/XPAC. The setting of
‘Connection Type’ in ‘2-2 Running’ depends on the real situation. If PC and
WInPAC/XPAC are all in WAN, you have to set IP address

Step 2: You can adjust ‘Color Mode’, ‘Queue Events’ and ‘Refresh Rate’ to reduce
traffic load.

Step3: You can check ‘Active Watchdog’ in ‘3-2-1 Configure’. This function can let
VCEP restore automatically if VCEP crash for un-known reason.

Step4: Though WIinPAC/XPAC supports FTP itself, you can use ‘3-3-2 File
Explorer’ function of VCEP to transfer files between PC and WIinPAC/XPAC as
well.

Step5: Finally, don’t forget these convenient functions of ‘Screen Capture’ of
‘3-3-3 Edit’ and ‘Recording Script/AVI’ of ‘3-3-4 Tools’.

4-2 Active Connection from Server

In some situation, WinPAC/XPAC only has private IP in LAN, but has to
communicate with PC in WAN (See Figure 3). At this kind of situation, you have to
use ‘Connect to client’ in ‘3-2-1 Configure’. You can check this and assign two
‘Client IP’ for active connection from WIinPAC/XPAC. If the first ‘Client IP’ can not
be connected to, VCEP will connect to second ‘Client IP’ automatically. If the
connection of the first ‘Client IP’ restore, you have to disconnect the second
connection manually to connect to the first one. The ‘Retry Cycle’ means the time
between two connections
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Public IP:

Public IP: 61.62.5.40

31.32.7.11

Switch
RS-405

Private IP:
10.0.0.100

Figure 3

Step 1: Enter appropriate variables in ’Connect to client’.

Step 2: Refer to ‘3-1-2 New Connection’ and create a new connection on PC.
Choose ‘Connect from server’ in ‘Connection Type’. The ‘Port number’ should be
the same with the ‘Port number’ at Step 1.

Step 3: Press the ‘Connect’ button and have patient waiting the connection from
WInPAC/XPAC.

Step 4. After successful connection, you can refer to ‘4-1 General Remote Control
from Client’ for all activities on WinPAC/XPAC.

4-3 Debugging and Maintaining

VCEP 4.2 allows user recording and playing script. This function is very
convenient to debug and maintain WinPAC/XPAC. For example, user can re-play
a script to re-generate the problem for debugging. Also, user can record a script
for registration which can simplify the procedure of deploying application to
different WinPAC/XPAC.
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[Recording]
Step 1: Choose ‘Script Events’ of ‘Recording Method’ in ‘New Connection’ dialog

Step 2: Refer to '4-1 General Remote Control from Client’ and connect to
WInPAC/XPAC

Step 3: Choose [Tools]->[Start Recording] to record all activities when connecting

Step 4: Choose [Tools]->[Stop Recording] to stop recording and save in file

[Playing]

Step 1: Refer to ‘3-1-4 New Scenario’ and create a scenario. If you check ‘Log
Results’, the log file will record all results when playing scenario. If you have
several scripts should be played in one scenario, you can add all of them in the
list by ‘Add’ function and set loop for each one. If the activities in scenario do not
need to see on PC, remember to check ‘Disable Video Update’.

Step 2: Choose one WIinPAC/XPAC to connect
Step 3: After press ‘Play’ button, you will see a ‘Run Script’ dialog. Choose the

WiInPAC/XPAC and ‘Run’. Now, you can find out WinPAC/XPAC act as you record
before

Date: Jun-17 2011 v4.2.0.9



	About This Manual
	1. Introduction
	2. Getting Started
	2-1 Installation
	2-2 Registration
	2-3 Running

	3. Function Overview
	3-1 Functions on Client (PC)
	3-1-1 Default Settings
	3-1-2 New Connection
	3-1-3 Connection Edit
	3-1-4 New Scenario
	3-1-5 Script Edit
	3-1-6 About

	3-2 Functions on Server (WinPAC/XPAC)
	3-2-1 Configure
	3-2-2 Disconnect
	3-2-3 Register
	3-2-4 About

	3-3 Functions when Connecting
	3-3-1 Configure
	3-3-2 File Explorer
	3-3-3 Edit
	3-3-4 Tools
	3-3-5 View


	4. Application
	4-1 General Remote Control from Client
	4-2 Active Connection from Server
	4-3 Debugging and Maintaining


