I-8068 User's Manual

Relay Output | Output Channel | 8
 | Relay Type | Form A : Relay 0 to 3 Form C : Relay 4 to 7
 | Contact Rating | 0.5A@125VAC 1A@30VDC
 | Operate/Release Time | 7mS/3mS
 | Life | 2*105
 | Dielectric Strength | Coil to contacts : 1500VAC Open contacts : 1000VAC
LED Display | 1 LED as Power/Communication indicator 8 LEDs as relay output indicators
Power Consumption | Typical : 0.5W Maximum : 1.9W
Note | 8068 : Internal Parallel Bus

I-8068 Pin Assignment
Terminal Number | Pin Name
1 | NO0
2 | COM0
3 | NO1
4 | COM1
5 | NO2
6 | COM2
7 | NO3
8 | COM3
9 | NO4
10 | NC4
11 | COM4
12 | NO5
13 | NC5
14 | COM5
15 | NO6
16 | NC6
17 | COM6
18 | NO7
19 | NC7
20 | COM7

I-8068 Block Diagram

Output Type ON State
LED ON
Readback as 1 		OFF State
LED OFF
Readback as 0
Form A Relay Contact
Load current On I-8068 Relay Contact
Load current Off I-8068 Relay Contact
Form C Relay Contact
Load current On I-8068 Relay Contact
Load current Off I-8068 Relay Contact

I-8068 Dimention

Back to Previous Page