I-8037 User's Manual

Digital Output | Output Channel | 16
 | Output Type | Open-Drain (source)
 | Max load current | 100mA per channel
 | Load Voltage | 30VDC (maxinum)
 | Isolation Voltage | 3750 Vrms
LED Display | 1 LED as Power/Communication indicator 16 LEDs as digital output indicators
Power Consumption | 0.5 W

I-8037 Pin Assignment

I-8037 Dimention

Back to Previous Page