Digital Output | Outputs per module | 32 (Sink)
 | Output Type | Isolated open-collector
 | Max load current | 100mA per channel
 | Load voltage | +5V to +30VDC
 | Isolation Voltage | 3750 Vrms
LED Display | 1 LED as Power/Communication indicator 32 LEDs as digital output indicators
Power Consumption | Maximum : 1.0W