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The connection solution of InduSoft with ET-7000 
series modules by using Modbus-TCP protocol 

This document will introduce how InduSoft software ac-
cesses the ET-7000 series using Modbus-TCP protocol. 

We will make a HMI page shown as follow for a distribution case, 
which offers five lamps, five buttons, a slider and a dial voltmeter. 
The specific lamp will get on depended on pushing the specific 
button while the application program is running. Furthermore, the 
specific lamp will off immediately when release the specific lamp 
button. The AO channel of ET-7000 will output the voltage in ac-
cordance with the value of the slider while moving the knob on 
the slider, and then the voltmeter will show the voltage monitored 
from the AI channel connect directly to AO channel. 

 

 

 

 

 

 

 

 

 

 

2 
3 

４ 

5 

6 

7 

8



 InduSoft Web Studio-Modbus TCP interface 

http://www.icpdas.com  14-2 

Follows the steps below to create a distribution board HMI:  

 1、Create a Project： 

1.  From the Studio main menu bar, select File->New. The 
New dialog display, and select the Project tab. Input the 
ModbusTCP in the Application name text box and spec-
ify a location, a Configuration file and a Target platform. 
Click OK when you are done. 

 

2. When the Project Wizard dialog displays (as follows), se-
lect Empty Application from the Template pane to create 
a new application. Specify the resolution to 640*480 and 
select <None> from the Shared Tags list. Click OK to 
close the New dialog. 
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3. In the Workspace pane, Select the Database tab, expand 
the Application Tags folder and right-click the Datasheet 
View icon. The pop-up menu displays, and then selects 
the Open to open the Application Tags window. Use the 
following information to complete the fields on this window. 
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 Name Array 
Size 

Type Description 

1. AI 7 Real Monitor the voltage 
from AO channel 

2. AO 3 Real Output the voltage 
3. ModbusToAI 0 Integer Modbus data converts 

to AI value 
4. AOToModbus 0 Integer AO value converts to 

Modbus data. 
5. DI 15 Boolean Digital input 
6. DO 15 Boolean Digital output 

 

 2、Create a display screen： 

1. In the Workspace pane, Select Graphics tab, and right-
click the Screens folder. When the pop-up menu displays, 
selects the Insert to open the Screen Attribute dialog. 
Set the Screen size to 500*300 and click OK. 
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 3、Create the Text： 

1. Click Text icon to create a Text object on the screen. Input 
the “Distribution Board” on this object  and click the Fonts 
button to specify font settings (Font Color is Blur and size 
is 16) 
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 4、Create the Lamp： 

1. Click the Button icon to create a Button object on the left-
upper of the Screen. Right-click the button to open the Ob-
ject Properties dialog and remove the text from the Cap-
tion field. 

2. Click the Rectangle object to make a rectangle on the 
Lamp (Button), and open the Object Properties dialog to 
change the fill color to Maroon. 

3. Apply the Colors dynamic property to this rectangle. Open 
the Object Properties dialog. Type “DI[0]” into the 
Tag/Expression filed, and change the color to Maroon on 
first Color field, change the color to Red on second Color 
field. 

 

4. Group the Button and Rectangle object, and use Copy 
and Paste action to duplicate four 3-D Lamps. Rename 
the Tag Name of Lamp as DI[1] /DI[2]/DI[3]/DI[4] sepa-
rately, the finished map is shown as follows. 

 

 5、Create the Button object： 

1. Create a button on bottom of the Lamp. Right-click the 
button to open the Object Properties dialog and type the 
“DO[0]” text on the Caption field.  
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Select this Button object and click on the Command icon to 
apply this dynamic to the object. Double-Click the Button to 
open the Command Object Properties dialog and add the 
following information on the dialog.  

At On Down tab 

Tag Expression 
DO[0] Not DO[0] 

 
At On Up tab 

Tag Expression 
DO[0] Not DO[0] 

 
2. Use Copy and Paste action to duplicate four same But-

tons. Rename the Tag Name of Button as 
DO[1]/DO[2]/DO[3]/DO[4] separately, the finished map is 
show as follows. 

 

 

 6、Create the Slider object： 

1. Click the Library icon to open the symbols library. Select 
Slider from the list then double-click on the slider icon to 
open the object on the screen. Apply the Position dy-
namic property to this slider. Open the Object  
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2. Properties dialog. Type “AO[0]” into the Horz filed, and 
input 0 and 10 value on the Range field. 

 7、Create a Voltmeter object： 

1. Click the Library icon to open the symbols library. Select 
meter from the list then double-click on the voltmeter icon 
to open the object on the screen. Open the Object Prop-
erties dialog, and click voltmeter icon to change the Tag 
Name on the To field of Whole Tag Name tab. Switch to 
String Value tab and input the following information on 
the table. 

From To 
Unit V 
100 10 
0 0 
25 2.5 
50 5 
75 7.5 

1

2 3
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2. Select Dynamic Rotation from the list on the Object 
Properties dialog. Add the 0 and 10 to the Range fields 
and close this dialog. 
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 8、Create a “Exit” Button ： 

1.  Create a button at the right-bottom of the Screen for exit-
ing the system. Select the Button object and click on the 
Command icon to apply this dynamic to the object. 

2. Double-click on the Button object to open the Object 
Properties dialog and type Shutdown() function on Ex-
pression field. 

3. Save the screen as a file named as Main.scr. The full 
screen is show as follows: 

 

14.1 Create the Modbus TCP worksheet 

Perform the following steps to select the Modbus/TCP driver 
from within the application:  

1. In the Workspace pane. Select the Comm tab, expand the 
Drivers folder and right-click the Drivers folder. The pop-up 
menu displays, and then selects the Add/Remove driver 
to open the Communication Drivers dialog. 



 InduSoft Web Studio-Modbus TCP interface 

http://www.icpdas.com  14-11 

2. Select the MOTCP driver from the Available Drivers list, 
and then click the Select button. 

 

3. When the MOTCP driver displays in the Selected Drivers 
list, click the OK button to close the dialog. 

 

4. Select the Comm tab, and located below the Workspace 
pane. Expand the Drivers folder, and right-click the 
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MOTCP subfolder. Select the Insert option from the pop-
up menu. 

 

5. When MOTCP001.DRV dialog displays, use the following 
information to complete the fields on this worksheet.  

Column Field Name Content 
Description DI 
Enable Read When Idle 1 
Station 192.168.0.150:502:1 
Header 1X:0 

 
 Tag Name Address Div Add 
1 DI[0] 1   
2 DI[1] 2   
3 DI[2] 3   
4 DI[3] 4   
5 DI[4] 5   

 
The detail information of the Column Field Name: 

 Description field：Type a description of the 
STANDARD DRIVER SHEET for documentation pur-
poses 
 Read Trigger field：Type a tag that allows IWS to read 
the worksheet automatically when you change this tag 
value 
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 Enable Read when Idle field：Type a tag or constant 
value. Use a tag (or constant) value greater than zero, to 
enable reading from the equipment 
 Read Completed field：Type in a tag and the communi-
cation driver toggles the tag when it completes a read 
command. 
 Read Status field：Type in a tag and the communication 
driver updates the tag with the status of the last read 
command. 
 Write Trigger field：Type a tag value to activate a group 
reading. Whenever you change this tag value, the pro-
gram writes an equipment worksheet. 
 Enable Write on Tag Change field：Type a tag or con-
stant value (not zero) to enable the communication driver 
to check the worksheet continuously for changes in the 
tag value. If a change occurs, IWS writes this value to an 
address in the field equipment. 
 Write Completed field：Type in a tag and the communi-
cation driver toggles the tag in this field when a write 
command completes. 
 Write Status field：Type in a tag and the communica-
tion driver updates the tag with the status of the last write 
command. 
 Station field：Type the equipment station number within 
the network. The syntax in this field varies with each 
communication driver. Refer to the appropriate driver 
documentation for further information. 
 Header field：Specify the data type and/or initial ad-
dress to be read or written in the equipment. The syntax 
in this field varies with each communication driver. Refer 
to the appropriate driver documentation for further infor-
mation. 
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 Increase Priority checkbox：Click (check) to keep the 
reading and writing commands for this sheet on the top of 
the communication queue whenever they are triggered.  
 Checkbox：Click (check) to specify the minimum and 
maximum values for field equipment data. 
 Min and Max field：Type a range of values to be con-
verted into an engineering format. These fields determine 
the minimum and maximum range of values. These val-
ues affect all tags in the worksheet. 

 

The complete syntax of Station and Header field parame-
ter are shown as follows  

Parameter Default 
Value 

Valid value Comments 

Station － － Specify the device using the fol-
lowing syntax： 
<IP address>：<Port Number>：
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<Station No.> 
where 
<IP Address>：is the ET-7000 
IP address in the TCP/IP network.
<Port Number>：is the port 
number for the Modbus TCP pro-
tocolTCP port number is 502. 
<Station No.>：is the ET-7000 
identification number (0~255) 

Header 0X:0 Refer to 
next table 

The variables can be read from or 
written to the device, and also a 
reference to the initial address.。

 

Header Field Information 
Type syntax Begin Address Comments 
0x 0x:0 Varies accord-

ing o the 
equipment  

Coil status：Read and 
write events using Modbus 
instructions  01, 05 and 15 

1x 1x:0 Varies accord-
ing o the 
equipment 

Input status：Read events 
using Modbus instructions  
02 

3x 3x:0 Varies accord-
ing o the 
equipment 

Input register：Read 
events using Modbus in-
structions  02 

4x 4x:0 Varies accord-
ing o the 
equipment 

Holding Register：Read 
and write events using 
Modbus instructions 03, 06 
and 16 

 

Use the Body area parameters as follows: 

 Tag Name field：Type a tag name for the communica-
tion driver to use. 
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 Address field：Type a field equipment address (or ad-
dress offset) related to the application tag. The syntax in 
this field varies with each communication driver. Refer to 
the appropriate driver documentation for further informa-
tion. 
 Div field：Specify a division constant to use when scale 
adjustment is required. IWS uses this value as a division 
factor in a read operation and a multiplication factor in a 
write operation. Do not use this field if you are already us-
ing Min or Max in the configuration body. 
 Add field：Specify an addition constant to use when 
scale adjustment is required. IWS uses this value as an 
addition factor in a read operation and a subtraction fac-
tor in a write operation. Do not use this field if you are al-
ready using Min or Max in the configuration body. 

6. The Sava As dialog will display while adding the informa-
tion to worksheet. Click OK to finish. 

7. Repeater the Step4~Step6 to add a new Modbus TCP 
worksheet. When MOTCP002.DRV dialog displays, use 
the following information to complete the fields on this 
worksheet. 

Column Field Name Content 
Description DO 
Enable Write On Tag 
Change 

1 

Station 192.168.0.150:502:1 
Header 0X:0 

 
 Tag Name Address Div Add 
1 DO[0] 1   
2 DO[1] 2   
3 DO[2] 3   
4 DO[3] 4   
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5 DO[4] 5   
 
8. Repeater the Step4~Step6 to add a new Modbus TCP 

worksheet. When MOTCP003.DRV dialog displays, use 
the following information to complete the fields on this 
worksheet. 

Column Field Name Content 
Description AI 
Enable Read When Idle 1 
Station 192.168.0.150:502:1 
Header 3X:0 

 
 Tag Name Address Div Add 
1 ModbusToAI 1   

 
9. Follows the Step4~Step6 to add a new Modbus TCP 

worksheet again. When MOTCP004.DRV dialog displays, 
use the following information to complete the fields on this 
worksheet. 

Column Field Name Content 
Description AO 
Enable Write On Tag 
Change 

1 

Station 192.168.0.150:502:1 
Header 4X:0 

 
 Tag Name Address Div Add 
1 AOToModbus 1   

 
10. The transmit format of Modbus protocol is Hex, and .. 

Select the Tasks tab, and located below the Workspace 
pane. Right-click the Math folder from the Project tree 
structure. Select the Insert option from the pop-up menu to 
open a Math worksheet. 
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 Formula translator of  the Analog Input： 
AI value = tag value / 32767 * Span 
Span = Maximum value of AI – 0 

 Formula translator of  the Analog Output： 
Tag value = AO value / Span * 32767 
Span = Maximum value of AO – 0 

11. When MATH001 dialog displays, use the following in-
formation to complete the fields on this worksheet. 

Column Field Name Content 
Description Formula_Translator 
Execution 1 

 
 Tag Name Expression 
1 AI[0] ModbusToAI/32767*10 
2 AOToModbus AO[0]/10*32767 
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12. Select Project→Status from the main menu bar. The 
Project Status dialog displays: 

13. Verify that the Driver Runtime task is set to Automatic. 

 If the setting is correct, click OK to close the dialog. 

 If the Driver Runtime task is set to Manual, select the 
Driver Runtime line. When the Startup button be-
comes active, click the button to toggle the Startup 
mode to Automatic. 

Click OK to close the Project Status dialog. 
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14. Start the application to run the driver while the setting is 
finished.  

 Push DO[2] button, and the lamp on the top of this but-
ton will get on, and the lamp will off immediately when 
release the DO[2] button. 

 While moving the knob on the slider, and then the 
voltmeter will show the voltage monitored from the AI 
channel connect directly to AO channel 

 

 


